Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3346

Hudson hangs on archiving

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Duplicate
    • maven-plugin
    • None
    • Platform: All, OS: All

    Description

      Build just hangs when it's almost complete. After I cancel the build (as it's
      stuck at:

      [INFO] Generating "Project Team" report.

      [INFO] Generating "Mailing Lists" report.

      [INFO] Generating "About" report.

      [INFO] Generating "Project Plugins" report.

      [INFO] Generating "Project Summary" report.

      [INFO] Generating "Dependencies" report.

      [HUDSON] Archiving site

      It reports the following error:

      [INFO] Unable to call getArtifactsDir. Invalid object ID 12

      [INFO] ------------------------------------------------------------------------

      [INFO] Trace

      java.lang.IllegalStateException: Unable to call getArtifactsDir. Invalid object
      ID 12

      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:259)

      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:246)

      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:206)

      at hudson.remoting.UserRequest.perform(UserRequest.java:92)

      at hudson.remoting.UserRequest.perform(UserRequest.java:46)

      at hudson.remoting.Request$2.run(Request.java:236)

      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)

      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)

      at java.util.concurrent.FutureTask.run(FutureTask.java:123)

      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)

      at java.lang.Thread.run(Thread.java:595)

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 317 minutes 26 seconds

      [INFO] Finished at: Tue Mar 24 12:49:30 MST 2009

      [INFO] Final Memory: 54M/132M

      This is from a Maven2 project. I'm not sure if it's Maven or Hudson which is
      causing the problem but since Hudson keeps it running for 317 minutes, something
      is wrong - build normally takes 30 min or less.

      Attachments

        Issue Links

          Activity

            Attached is our thread dump (thread-dump-hang.txt).

            Last log line is:

            [HUDSON] Archiving /var/lib/hudson/jobs/oxford-sakai/workspace/gradebook/app/sakai-tool/target/sakai-gradebook-tool-2.6-SNAPSHOT.war to /var/lib/hudson/jobs/oxford-sakai/modules/org.sakaiproject$sakai-gradebook-tool/builds/2010-09-29_11-30-38/archive/org.sakaiproject/sakai-gradebook-tool/2.6-SNAPSHOT/sakai-gradebook-tool-2.6-SNAPSHOT.war

            The build is a large but it only seems to be hanging in a few places.

            buckett Matthew Buckett added a comment - Attached is our thread dump (thread-dump-hang.txt). Last log line is: [HUDSON] Archiving /var/lib/hudson/jobs/oxford-sakai/workspace/gradebook/app/sakai-tool/target/sakai-gradebook-tool-2.6-SNAPSHOT.war to /var/lib/hudson/jobs/oxford-sakai/modules/org.sakaiproject$sakai-gradebook-tool/builds/2010-09-29_11-30-38/archive/org.sakaiproject/sakai-gradebook-tool/2.6-SNAPSHOT/sakai-gradebook-tool-2.6-SNAPSHOT.war The build is a large but it only seems to be hanging in a few places.

            We use the build timeout plugin to kill stuck jobs.

            http://wiki.jenkins-ci.org/display/JENKINS/Build-timeout+Plugin

            Although currently our build is hanging and even restart hudson doesn't seem to be allowing it to build correctly.

            buckett Matthew Buckett added a comment - We use the build timeout plugin to kill stuck jobs. http://wiki.jenkins-ci.org/display/JENKINS/Build-timeout+Plugin Although currently our build is hanging and even restart hudson doesn't seem to be allowing it to build correctly.

            After upgrading to 1.378 one of our builds was repeatedly failing. Downgrading to to 1.377 has given us a working hudson again.

            buckett Matthew Buckett added a comment - After upgrading to 1.378 one of our builds was repeatedly failing. Downgrading to to 1.377 has given us a working hudson again.
            robertredd robertredd added a comment -

            Looks to be the same problem as 7572 which is now assigned to someone.

            robertredd robertredd added a comment - Looks to be the same problem as 7572 which is now assigned to someone.

            Closed, as this is a duplicate of JENKINS-7572, and the fix tracking is bing done there.

            mwebber Matthew Webber added a comment - Closed, as this is a duplicate of JENKINS-7572 , and the fix tracking is bing done there.

            People

              Unassigned Unassigned
              rfidler78 rfidler78
              Votes:
              18 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: