Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37440

Disable FindBugs analysis when skipping tests

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Won't Do
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      JENKINS-36715 made a typical developer build of Jenkins (mvn -DskipTests clean install) much slower, adding about a minute of heavy CPU activity on my laptop. Static analysis is useless during developer builds: if there are any regressions, CI builds will catch them alongside automated tests.

      While you can disable the slow plugin execution with -Dfindbugs.skip, it would be nicer to have this be implied by the standard -DskipTests, which is an indication that you are just interested in producing artifacts as quickly as possible.

      For plugins we already do this, so it should be easy to copy that logic to core.

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev added a comment -

            Agreed. But we should run FindBugs in the case of lightweight tests, so the logic will be a bit different

            teilo James Nord added a comment - - edited

            I'm against this. As a Maven user I expect that -DskipTests skips tests and that -Dfindbugs.skip skips findbugs.

            Please do not overload a specific flag for a plugin with another flag. If you want to use a profile that you can activate -Pquickbuild or activate via a property -DskipTestsAndFindbugs.

            oleg_nenashev Oleg Nenashev added a comment -

            I would also prefer to have FB by default. This change just aligns the behavior with Parent POM.
            But we can change our mind about parent POM of course

            integer Kanstantsin Shautsou added a comment -

            Against. @jglick could implement https://wiki.jenkins-ci.org/display/JENKINS/Designing+pre-tested+commit or create his own global maven profile.

            oleg_nenashev Oleg Nenashev added a comment -

            I did my work on this grumbling from Jesse Glick. Since there is not so many fans of the proposed approach, somebody else can proceed. I am fine with the current state when FindBugs is being launched with "-DskipTests"


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jglick Jesse Glick
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: