Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38389

jenkins restart fails after installing ec2 plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: ec2-plugin
    • Labels:
      None
    • Environment:
      centos 7 server latest jenkins
    • Similar Issues:

      Description

      hudson.util.HudsonFailedToLoad: java.lang.NullPointerException
      at hudson.WebAppMain$3.run(WebAppMain.java:244)
      Caused by: java.lang.NullPointerException
      at hudson.plugins.ec2.EC2Cloud.createCredentialsProvider(EC2Cloud.java:599)
      at hudson.plugins.ec2.EC2Cloud.createCredentialsProvider(EC2Cloud.java:584)
      at hudson.plugins.ec2.EC2Cloud.connect(EC2Cloud.java:620)
      at hudson.plugins.ec2.EC2Computer._describeInstanceOnce(EC2Computer.java:166)
      at hudson.plugins.ec2.EC2Computer._describeInstance(EC2Computer.java:149)
      at hudson.plugins.ec2.EC2Computer.describeInstance(EC2Computer.java:107)
      at hudson.plugins.ec2.EC2Computer.getUptime(EC2Computer.java:133)
      at hudson.plugins.ec2.EC2RetentionStrategy.internalCheck(EC2RetentionStrategy.java:104)
      at hudson.plugins.ec2.EC2RetentionStrategy.check(EC2RetentionStrategy.java:85)
      at hudson.plugins.ec2.EC2RetentionStrategy.check(EC2RetentionStrategy.java:43)
      at hudson.slaves.SlaveComputer$4.run(SlaveComputer.java:725)
      at hudson.model.Queue._withLock(Queue.java:1303)
      at hudson.model.Queue.withLock(Queue.java:1180)
      at hudson.slaves.SlaveComputer.setNode(SlaveComputer.java:722)
      at hudson.model.AbstractCIBase.updateComputer(AbstractCIBase.java:118)
      at hudson.model.AbstractCIBase.access$000(AbstractCIBase.java:44)
      at hudson.model.AbstractCIBase$2.run(AbstractCIBase.java:186)
      at hudson.model.Queue._withLock(Queue.java:1303)
      at hudson.model.Queue.withLock(Queue.java:1180)
      at hudson.model.AbstractCIBase.updateComputerList(AbstractCIBase.java:169)
      at jenkins.model.Jenkins.updateComputerList(Jenkins.java:1470)
      at jenkins.model.Jenkins.<init>(Jenkins.java:948)
      at hudson.model.Hudson.<init>(Hudson.java:85)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.WebAppMain$3.run(WebAppMain.java:227)

        Attachments

          Issue Links

            Activity

            funeeldy marlene cote added a comment -

            You can close this. I was able to delete the plugin directory and reinstall it and it worked.

            funeeldy marlene cote added a comment -

            retried it multiple times and then manually deleted the plugin from the filesystem and then it installed and jenkins restarted

            batmat Baptiste Mathus added a comment -

            I am seeing an identical stack trace under some situation, reopening and assigning to self for followup.

            batmat Baptiste Mathus added a comment - - edited

            FTR, recent stack trace with ec2-plugin 1.35:

            hudson.util.HudsonFailedToLoad: java.lang.NullPointerException
            	at hudson.WebAppMain$3.run(WebAppMain.java:248)
            Caused by: java.lang.NullPointerException
            	at hudson.plugins.ec2.EC2Cloud.createCredentialsProvider(EC2Cloud.java:599)
            	at hudson.plugins.ec2.EC2Cloud.createCredentialsProvider(EC2Cloud.java:584)
            	at hudson.plugins.ec2.EC2Cloud.connect(EC2Cloud.java:620)
            	at hudson.plugins.ec2.EC2Computer._describeInstanceOnce(EC2Computer.java:166)
            	at hudson.plugins.ec2.EC2Computer._describeInstance(EC2Computer.java:149)
            	at hudson.plugins.ec2.EC2Computer.describeInstance(EC2Computer.java:107)
            	at hudson.plugins.ec2.EC2Computer.getUptime(EC2Computer.java:133)
            	at hudson.plugins.ec2.EC2RetentionStrategy.internalCheck(EC2RetentionStrategy.java:104)
            	at hudson.plugins.ec2.EC2RetentionStrategy.check(EC2RetentionStrategy.java:85)
            	at hudson.plugins.ec2.EC2RetentionStrategy.check(EC2RetentionStrategy.java:43)
            	at hudson.slaves.SlaveComputer$4.run(SlaveComputer.java:725)
            	at hudson.model.Queue._withLock(Queue.java:1309)
            	at hudson.model.Queue.withLock(Queue.java:1186)
            	at hudson.slaves.SlaveComputer.setNode(SlaveComputer.java:722)
            	at hudson.model.AbstractCIBase.updateComputer(AbstractCIBase.java:118)
            	at hudson.model.AbstractCIBase.access$000(AbstractCIBase.java:44)
            	at hudson.model.AbstractCIBase$2.run(AbstractCIBase.java:186)
            	at hudson.model.Queue._withLock(Queue.java:1309)
            	at hudson.model.Queue.withLock(Queue.java:1186)
            	at hudson.model.AbstractCIBase.updateComputerList(AbstractCIBase.java:169)
            	at jenkins.model.Jenkins.updateComputerList(Jenkins.java:1567)
            	at jenkins.model.Jenkins.<init>(Jenkins.java:968)
            	at hudson.model.Hudson.<init>(Hudson.java:85)
            	at hudson.model.Hudson.<init>(Hudson.java:81)
            	at hudson.WebAppMain$3.run(WebAppMain.java:231)
            
            batmat Baptiste Mathus added a comment -

            Added core component for now after Jesse Glick advice that we should at least fix core to forbid a failure in setNode to prevent Jenkins to start.

            jglick Jesse Glick added a comment -

            Core part filed separately.

            raihaan Raihaan Shouhell added a comment -

            Can't reproduce in the newer jenkins/plugin


              People

              Assignee:
              francisu Francis Upton
              Reporter:
              funeeldy marlene cote
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: