Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40663

strings cut-n-pasted from Description should not contain NUL or VT

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      It seems that Jenkins inserts a VerticalTAB character sequence in long lines in the Job description display in the Build History.

      Since a common workflow is to cut-and-paste a value from the Description into the input of another job, we had to installed a snippet of shell script to strip out those characters.

      The fix should either be that the Description doesn't get those invisible characters inserted, or that Job input parameters should strip the characters.

      $ echo -n "123456789-0" | od -ac
      0000000   1   2   3   4   5   b nul  vt   6   7   8   9   -   0
                1   2   3   4   5 342 200 213   6   7   8   9   -   0
      

        Attachments

          Issue Links

            Activity

            markhu Mark Hudson added a comment -

            Dupe of JENKINS-28022 circa April 2015.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              markhu Mark Hudson
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: