Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40697

Repository connector plugin is not working

    XMLWordPrintable

Details

    Description

      Repositoy connector plugin not working with Nexus 3.1 or 3.2 unable to fetch the artefact versions from nexus.

      No versions could be resolved for groupid.artifactid

      Attachments

        Activity

          aish_new Aishwarya R created issue -
          richb Richard Browne added a comment - - edited

          Same here. We are on Jenkins 2.32.2 and the repository connector is completely non functional. It can't resolve artifacts from http://repo1.maven.org/maven2.

          I'll also add that there is nothing in the Jenkins log and no way that I can find to enable logging with this plugin. I tried creating a 'org.jvnet.hudson.plugins.repositoryconnector' logger in Jenkins but no messages from the plugin appear.

          richb Richard Browne added a comment - - edited Same here. We are on Jenkins 2.32.2 and the repository connector is completely non functional. It can't resolve artifacts from http://repo1.maven.org/maven2 . I'll also add that there is nothing in the Jenkins log and no way that I can find to enable logging with this plugin. I tried creating a 'org.jvnet.hudson.plugins.repositoryconnector' logger in Jenkins but no messages from the plugin appear.
          dannythk Danny Tung added a comment -

          I think the issue is the ordering how it is send to Nexus:

          Correct way: <groupid>:<artifacts>:<version>:<extension>

          Current implementation: <groupid>:<artifacts>:<extension>:<version>

           

          But I tried to just send <groupid>:<artifacts>  it still failed.  So there might be more problem than I just stated.

          dannythk Danny Tung added a comment - I think the issue is the ordering how it is send to Nexus: Correct way: <groupid>:<artifacts>:<version>:<extension> Current implementation: <groupid>:<artifacts>:<extension>:<version>   But I tried to just send <groupid>:<artifacts>  it still failed.  So there might be more problem than I just stated.
          jgangemi Jae Gangemi added a comment -

          hello - are you still experiencing this issue?

          jgangemi Jae Gangemi added a comment - hello - are you still experiencing this issue?
          jgangemi Jae Gangemi added a comment -

          2.0.0 is due out in the next few days, please try that and see if it resolves your issues as it has been upgraded to use the same aether library as maven.

          please be sure to check the plugin readme before upgrading so you are aware of incompatible changes.

          jgangemi Jae Gangemi added a comment - 2.0.0 is due out in the next few days, please try that and see if it resolves your issues as it has been upgraded to use the same aether library as maven. please be sure to check the plugin readme before upgrading so you are aware of incompatible changes.
          jgangemi Jae Gangemi made changes -
          Field Original Value New Value
          Assignee Jae Gangemi [ jgangemi ]
          jgangemi Jae Gangemi made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]

          People

            jgangemi Jae Gangemi
            aish_new Aishwarya R
            Votes:
            2 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: