Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41266

java.lang.ArrayIndexOutOfBoundsException after AccuRev Plugin upgrade

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Fixed
    • accurev-plugin
    • None
    • Jenkins 2.41
      AccuRev Plugin which works is 0.7.6
      AccuRev Plugin which fails is 0.7.8
      Windows 8.1 Enterprise (64-bit)
      Accurev 6.2.3

    Description

      This Jenkins server is running on my laptop (not in Tomcat). It is configured with master and one local slave agent (on my laptop). After upgrading the AccuRev Plugin from version 0.7.6 to 0.7.8, a build failed with a java.lang.ArrayIndexOutOfBoundsException when it ran in the slave. It is successful if it runs in master.

      Build Console Output:

      12:37:36 Started by user anonymous
      12:37:36 [EnvInject] - Loading node environment variables.
      12:37:36 Building remotely on W1559922 in workspace C:/JenkinsSlave/workspace/AccuRev hdx-xall-dev Monitor
      12:37:36 [WS-CLEANUP] Deleting project workspace...
      12:37:36 [WS-CLEANUP] Done
      12:37:36 Authenticating with Accurev server...
      12:37:36 FATAL: 0
      12:37:36 java.lang.ArrayIndexOutOfBoundsException: 0
      12:37:36 	at java.lang.ProcessBuilder.start(Unknown Source)
      12:37:36 	at hudson.Proc$LocalProc.<init>(Proc.java:245)
      12:37:36 	at hudson.Proc$LocalProc.<init>(Proc.java:214)
      12:37:36 	at hudson.Launcher$LocalLauncher.launch(Launcher.java:846)
      12:37:36 	at hudson.Launcher$ProcStarter.start(Launcher.java:384)
      12:37:36 	at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1195)
      12:37:36 	at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1160)
      12:37:36 	at hudson.remoting.UserRequest.perform(UserRequest.java:152)
      12:37:36 	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      12:37:36 	at hudson.remoting.Request$2.run(Request.java:332)
      12:37:36 	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      12:37:36 	at java.util.concurrent.FutureTask.run(Unknown Source)
      12:37:36 	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      12:37:36 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      12:37:36 	at hudson.remoting.Engine$1$1.run(Engine.java:85)
      12:37:36 	at java.lang.Thread.run(Unknown Source)
      12:37:36 	at ......remote call to Channel to /10.150.141.150(Native Method)
      12:37:36 	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1537)
      12:37:36 	at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
      12:37:36 	at hudson.remoting.Channel.call(Channel.java:822)
      12:37:36 	at hudson.Launcher$RemoteLauncher.launch(Launcher.java:959)
      12:37:36 	at hudson.Launcher$ProcStarter.start(Launcher.java:384)
      12:37:36 	at hudson.Launcher$ProcStarter.join(Launcher.java:395)
      12:37:36 	at hudson.plugins.accurev.AccurevLauncher.justAccurev(AccurevLauncher.java:456)
      12:37:36 	at hudson.plugins.accurev.AccurevLauncher.findAccurevExe(AccurevLauncher.java:439)
      12:37:36 	at hudson.plugins.accurev.AccurevLauncher.createProcess(AccurevLauncher.java:266)
      12:37:36 	at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:218)
      12:37:36 	at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:103)
      12:37:36 	at hudson.plugins.accurev.cmd.Login.accurevLogin(Login.java:101)
      12:37:36 	at hudson.plugins.accurev.cmd.Login.ensureLoggedInToAccurev(Login.java:70)
      12:37:36 	at hudson.plugins.accurev.delegates.AbstractModeDelegate.setup(AbstractModeDelegate.java:63)
      12:37:36 	at hudson.plugins.accurev.delegates.AbstractModeDelegate.checkout(AbstractModeDelegate.java:102)
      12:37:36 	at hudson.plugins.accurev.AccurevSCM.checkout(AccurevSCM.java:387)
      12:37:36 	at hudson.scm.SCM.checkout(SCM.java:495)
      12:37:36 	at hudson.model.AbstractProject.checkout(AbstractProject.java:1278)
      12:37:36 	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
      12:37:36 	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      12:37:36 	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
      12:37:36 	at hudson.model.Run.execute(Run.java:1729)
      12:37:36 	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      12:37:36 	at hudson.model.ResourceController.execute(ResourceController.java:98)
      12:37:36 	at hudson.model.Executor.run(Executor.java:404)
      12:37:36 Notifying upstream projects of job completion
      12:37:36 Email was triggered for: Always
      12:37:36 Sending email for trigger: Always
      12:37:36 Sending email to: xxxxxxxxxxxxxxxx
      12:37:36 Finished: FAILURE
      

      Attachments

        Activity

          bercma00 Mark Berchem created issue -
          casz Joseph Petersen (old) made changes -
          Field Original Value New Value
          Description This Jenkins server is running on my laptop (not in Tomcat). It is configured with master and one local slave agent (on my laptop). After upgrading the AccuRev Plugin from version 0.7.6 to 0.7.8, a build failed with a java.lang.ArrayIndexOutOfBoundsException when it ran in the slave. It is successful if it runs in master.

          Build Console Output:

          12:37:36 Started by user anonymous
          12:37:36 [EnvInject] - Loading node environment variables.
          12:37:36 Building remotely on W1559922 in workspace C:/JenkinsSlave/workspace/AccuRev hdx-xall-dev Monitor
          12:37:36 [WS-CLEANUP] Deleting project workspace...
          12:37:36 [WS-CLEANUP] Done
          12:37:36 Authenticating with Accurev server...
          12:37:36 FATAL: 0
          12:37:36 java.lang.ArrayIndexOutOfBoundsException: 0
          12:37:36 at java.lang.ProcessBuilder.start(Unknown Source)
          12:37:36 at hudson.Proc$LocalProc.<init>(Proc.java:245)
          12:37:36 at hudson.Proc$LocalProc.<init>(Proc.java:214)
          12:37:36 at hudson.Launcher$LocalLauncher.launch(Launcher.java:846)
          12:37:36 at hudson.Launcher$ProcStarter.start(Launcher.java:384)
          12:37:36 at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1195)
          12:37:36 at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1160)
          12:37:36 at hudson.remoting.UserRequest.perform(UserRequest.java:152)
          12:37:36 at hudson.remoting.UserRequest.perform(UserRequest.java:50)
          12:37:36 at hudson.remoting.Request$2.run(Request.java:332)
          12:37:36 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
          12:37:36 at java.util.concurrent.FutureTask.run(Unknown Source)
          12:37:36 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
          12:37:36 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          12:37:36 at hudson.remoting.Engine$1$1.run(Engine.java:85)
          12:37:36 at java.lang.Thread.run(Unknown Source)
          12:37:36 at ......remote call to Channel to /10.150.141.150(Native Method)
          12:37:36 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1537)
          12:37:36 at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
          12:37:36 at hudson.remoting.Channel.call(Channel.java:822)
          12:37:36 at hudson.Launcher$RemoteLauncher.launch(Launcher.java:959)
          12:37:36 at hudson.Launcher$ProcStarter.start(Launcher.java:384)
          12:37:36 at hudson.Launcher$ProcStarter.join(Launcher.java:395)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.justAccurev(AccurevLauncher.java:456)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.findAccurevExe(AccurevLauncher.java:439)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.createProcess(AccurevLauncher.java:266)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:218)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:103)
          12:37:36 at hudson.plugins.accurev.cmd.Login.accurevLogin(Login.java:101)
          12:37:36 at hudson.plugins.accurev.cmd.Login.ensureLoggedInToAccurev(Login.java:70)
          12:37:36 at hudson.plugins.accurev.delegates.AbstractModeDelegate.setup(AbstractModeDelegate.java:63)
          12:37:36 at hudson.plugins.accurev.delegates.AbstractModeDelegate.checkout(AbstractModeDelegate.java:102)
          12:37:36 at hudson.plugins.accurev.AccurevSCM.checkout(AccurevSCM.java:387)
          12:37:36 at hudson.scm.SCM.checkout(SCM.java:495)
          12:37:36 at hudson.model.AbstractProject.checkout(AbstractProject.java:1278)
          12:37:36 at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
          12:37:36 at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
          12:37:36 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
          12:37:36 at hudson.model.Run.execute(Run.java:1729)
          12:37:36 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          12:37:36 at hudson.model.ResourceController.execute(ResourceController.java:98)
          12:37:36 at hudson.model.Executor.run(Executor.java:404)
          12:37:36 Notifying upstream projects of job completion
          12:37:36 Email was triggered for: Always
          12:37:36 Sending email for trigger: Always
          12:37:36 Sending email to: xxxxxxxxxxxxxxxx
          12:37:36 Finished: FAILURE
          This Jenkins server is running on my laptop (not in Tomcat). It is configured with master and one local slave agent (on my laptop). After upgrading the AccuRev Plugin from version 0.7.6 to 0.7.8, a build failed with a java.lang.ArrayIndexOutOfBoundsException when it ran in the slave. It is successful if it runs in master.

          Build Console Output:


          {code:java}
          12:37:36 Started by user anonymous
          12:37:36 [EnvInject] - Loading node environment variables.
          12:37:36 Building remotely on W1559922 in workspace C:/JenkinsSlave/workspace/AccuRev hdx-xall-dev Monitor
          12:37:36 [WS-CLEANUP] Deleting project workspace...
          12:37:36 [WS-CLEANUP] Done
          12:37:36 Authenticating with Accurev server...
          12:37:36 FATAL: 0
          12:37:36 java.lang.ArrayIndexOutOfBoundsException: 0
          12:37:36 at java.lang.ProcessBuilder.start(Unknown Source)
          12:37:36 at hudson.Proc$LocalProc.<init>(Proc.java:245)
          12:37:36 at hudson.Proc$LocalProc.<init>(Proc.java:214)
          12:37:36 at hudson.Launcher$LocalLauncher.launch(Launcher.java:846)
          12:37:36 at hudson.Launcher$ProcStarter.start(Launcher.java:384)
          12:37:36 at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1195)
          12:37:36 at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1160)
          12:37:36 at hudson.remoting.UserRequest.perform(UserRequest.java:152)
          12:37:36 at hudson.remoting.UserRequest.perform(UserRequest.java:50)
          12:37:36 at hudson.remoting.Request$2.run(Request.java:332)
          12:37:36 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
          12:37:36 at java.util.concurrent.FutureTask.run(Unknown Source)
          12:37:36 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
          12:37:36 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          12:37:36 at hudson.remoting.Engine$1$1.run(Engine.java:85)
          12:37:36 at java.lang.Thread.run(Unknown Source)
          12:37:36 at ......remote call to Channel to /10.150.141.150(Native Method)
          12:37:36 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1537)
          12:37:36 at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
          12:37:36 at hudson.remoting.Channel.call(Channel.java:822)
          12:37:36 at hudson.Launcher$RemoteLauncher.launch(Launcher.java:959)
          12:37:36 at hudson.Launcher$ProcStarter.start(Launcher.java:384)
          12:37:36 at hudson.Launcher$ProcStarter.join(Launcher.java:395)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.justAccurev(AccurevLauncher.java:456)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.findAccurevExe(AccurevLauncher.java:439)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.createProcess(AccurevLauncher.java:266)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:218)
          12:37:36 at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:103)
          12:37:36 at hudson.plugins.accurev.cmd.Login.accurevLogin(Login.java:101)
          12:37:36 at hudson.plugins.accurev.cmd.Login.ensureLoggedInToAccurev(Login.java:70)
          12:37:36 at hudson.plugins.accurev.delegates.AbstractModeDelegate.setup(AbstractModeDelegate.java:63)
          12:37:36 at hudson.plugins.accurev.delegates.AbstractModeDelegate.checkout(AbstractModeDelegate.java:102)
          12:37:36 at hudson.plugins.accurev.AccurevSCM.checkout(AccurevSCM.java:387)
          12:37:36 at hudson.scm.SCM.checkout(SCM.java:495)
          12:37:36 at hudson.model.AbstractProject.checkout(AbstractProject.java:1278)
          12:37:36 at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
          12:37:36 at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
          12:37:36 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
          12:37:36 at hudson.model.Run.execute(Run.java:1729)
          12:37:36 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          12:37:36 at hudson.model.ResourceController.execute(ResourceController.java:98)
          12:37:36 at hudson.model.Executor.run(Executor.java:404)
          12:37:36 Notifying upstream projects of job completion
          12:37:36 Email was triggered for: Always
          12:37:36 Sending email for trigger: Always
          12:37:36 Sending email to: xxxxxxxxxxxxxxxx
          12:37:36 Finished: FAILURE
          {code}
          casz Joseph Petersen (old) added a comment - - edited

          If it's the same laptop, there is no reason to connect the laptop as a slave, you can just increase the amount of executors on the master
          edit:
          heres how
          goto: http://localhost:8080/computer/(master)/configure and edit the amount of executors.

          casz Joseph Petersen (old) added a comment - - edited If it's the same laptop, there is no reason to connect the laptop as a slave, you can just increase the amount of executors on the master edit: heres how goto: http://localhost:8080/computer/(master)/configure and edit the amount of executors.
          bercma00 Mark Berchem added a comment -

          This is my test version of Jenkins. All changes are made on my laptop before upgrading our Jenkins CI Server. I am able to catch issues locally before causing our developer builds to fail. Having a slave locally is only to test the ability to connect and run in slaves. This problem might occur trying to connect to a remote slave as well.

          bercma00 Mark Berchem added a comment - This is my test version of Jenkins. All changes are made on my laptop before upgrading our Jenkins CI Server. I am able to catch issues locally before causing our developer builds to fail. Having a slave locally is only to test the ability to connect and run in slaves. This problem might occur trying to connect to a remote slave as well.

          Have you checked the server configuration?
          Also the exception never throw a caused by, which to me signals that I haven't gotten the full log.
          Can you try adding a logger for
          "hudson.plugins.accurev" and set it for all? You can add it under System log.

          casz Joseph Petersen (old) added a comment - Have you checked the server configuration? Also the exception never throw a caused by, which to me signals that I haven't gotten the full log. Can you try adding a logger for "hudson.plugins.accurev" and set it for all? You can add it under System log.

          I cannot test it myself atm our Accurev server is shutdown for backup

          casz Joseph Petersen (old) added a comment - I cannot test it myself atm our Accurev server is shutdown for backup
          casz Joseph Petersen (old) added a comment - - edited

          12:37:36 at hudson.plugins.accurev.AccurevLauncher.findAccurevExe(AccurevLauncher.java:439)

          Seems like you ended up in the isUnix in the findAccurevExe. But being on Windows that seems ODD
          on line 439... I will have figure out why I wouldn't have the slighest idea, why

          casz Joseph Petersen (old) added a comment - - edited 12:37:36 at hudson.plugins.accurev.AccurevLauncher.findAccurevExe( AccurevLauncher.java:439 ) Seems like you ended up in the isUnix in the findAccurevExe. But being on Windows that seems ODD on line 439... I will have figure out why I wouldn't have the slighest idea, why
          casz Joseph Petersen (old) added a comment - - edited

          Thanks found the issue.
          Sending an empty String to ProcessStarter is bad

          Should look something like this now

          FATAL: rocky: login (accurev login -H localhost:5050 test ******) failed with java.io.IOException: Cannot run program "accurev" (in directory "C:\Users\joseph\Documents\GitHub\casz\accurev-plugin\work\workspace\accurev-plugin"): CreateProcess error=2, The system cannot find the file specified
          java.io.IOException: Cannot run program "accurev" (in directory "C:\Users\joseph\Documents\GitHub\casz\accurev-plugin\work\workspace\accurev-plugin"): CreateProcess error=2, The system cannot find the file specified
          	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
          	at hudson.Proc$LocalProc.<init>(Proc.java:245)
          	at hudson.Proc$LocalProc.<init>(Proc.java:214)
          	at hudson.Launcher$LocalLauncher.launch(Launcher.java:846)
          	at hudson.Launcher$ProcStarter.start(Launcher.java:384)
          	at hudson.Launcher$ProcStarter.join(Launcher.java:395)
          	at hudson.plugins.accurev.AccurevLauncher.runCommandToCompletion(AccurevLauncher.java:247)
          	at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:220)
          	at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:100)
          	at hudson.plugins.accurev.cmd.Login.accurevLogin(Login.java:101)
          	at hudson.plugins.accurev.cmd.Login.ensureLoggedInToAccurev(Login.java:70)
          	at hudson.plugins.accurev.delegates.AbstractModeDelegate.setup(AbstractModeDelegate.java:63)
          	at hudson.plugins.accurev.delegates.AbstractModeDelegate.checkout(AbstractModeDelegate.java:102)
          	at hudson.plugins.accurev.AccurevSCM.checkout(AccurevSCM.java:387)
          	at hudson.scm.SCM.checkout(SCM.java:495)
          	at hudson.model.AbstractProject.checkout(AbstractProject.java:1278)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
          	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
          	at hudson.model.Run.execute(Run.java:1728)
          	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          	at hudson.model.ResourceController.execute(ResourceController.java:98)
          	at hudson.model.Executor.run(Executor.java:404)
          Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
          	at java.lang.ProcessImpl.create(Native Method)
          	at java.lang.ProcessImpl.<init>(ProcessImpl.java:386)
          	at java.lang.ProcessImpl.start(ProcessImpl.java:137)
          	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
          	... 22 more
          
          casz Joseph Petersen (old) added a comment - - edited Thanks found the issue. Sending an empty String to ProcessStarter is bad Should look something like this now FATAL: rocky: login (accurev login -H localhost:5050 test ******) failed with java.io.IOException: Cannot run program "accurev" (in directory "C:\Users\joseph\Documents\GitHub\casz\accurev-plugin\work\workspace\accurev-plugin" ): CreateProcess error=2, The system cannot find the file specified java.io.IOException: Cannot run program "accurev" (in directory "C:\Users\joseph\Documents\GitHub\casz\accurev-plugin\work\workspace\accurev-plugin" ): CreateProcess error=2, The system cannot find the file specified at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048) at hudson.Proc$LocalProc.<init>(Proc.java:245) at hudson.Proc$LocalProc.<init>(Proc.java:214) at hudson.Launcher$LocalLauncher.launch(Launcher.java:846) at hudson.Launcher$ProcStarter.start(Launcher.java:384) at hudson.Launcher$ProcStarter.join(Launcher.java:395) at hudson.plugins.accurev.AccurevLauncher.runCommandToCompletion(AccurevLauncher.java:247) at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:220) at hudson.plugins.accurev.AccurevLauncher.runCommand(AccurevLauncher.java:100) at hudson.plugins.accurev.cmd.Login.accurevLogin(Login.java:101) at hudson.plugins.accurev.cmd.Login.ensureLoggedInToAccurev(Login.java:70) at hudson.plugins.accurev.delegates.AbstractModeDelegate.setup(AbstractModeDelegate.java:63) at hudson.plugins.accurev.delegates.AbstractModeDelegate.checkout(AbstractModeDelegate.java:102) at hudson.plugins.accurev.AccurevSCM.checkout(AccurevSCM.java:387) at hudson.scm.SCM.checkout(SCM.java:495) at hudson.model.AbstractProject.checkout(AbstractProject.java:1278) at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604) at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529) at hudson.model.Run.execute(Run.java:1728) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:404) Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified at java.lang.ProcessImpl.create(Native Method) at java.lang.ProcessImpl.<init>(ProcessImpl.java:386) at java.lang.ProcessImpl.start(ProcessImpl.java:137) at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029) ... 22 more
          casz Joseph Petersen (old) added a comment - - edited

          You end up in isUnix because C:/JenkinsSlave hits the

          return !remote.contains("\\");
          

          User input I believe when setting the node's Remote root directory.
          Should be able to fix it by using the Launcher instead of FilePath to check if it's Unix or not.

          Edit:
          No reason to make such a lengthy environment details

          casz Joseph Petersen (old) added a comment - - edited You end up in isUnix because C:/JenkinsSlave hits the return !remote.contains( "\\" ); User input I believe when setting the node's Remote root directory. Should be able to fix it by using the Launcher instead of FilePath to check if it's Unix or not. Edit: No reason to make such a lengthy environment details
          casz Joseph Petersen (old) made changes -
          Environment Jenkins 2.41
          AccuRev Plugin which works is 0.7.6
          AccuRev Plugin which fails is 0.7.8
          Windows 8.1 Enterprise (64-bit)
          Accurev 6.2.3

          Environment Details:

          awt.toolkitsun.awt.windows.WToolkit
          executable-warC:\Program Files (x86)\Jenkins\jenkins.war
          file.encodingCp1252
          file.encoding.pkgsun.io
          file.separator\
          hudson.lifecyclehudson.lifecycle.WindowsServiceLifecycle
          java.awt.graphicsenvsun.awt.Win32GraphicsEnvironment
          java.awt.headlesstrue
          java.awt.printerjobsun.awt.windows.WPrinterJob
          java.class.pathC:\Program Files (x86)\Jenkins\jenkins.war
          java.class.version52.0
          java.endorsed.dirsC:\Program Files (x86)\Jenkins\jre\lib\endorsed
          java.ext.dirsC:\Program Files (x86)\Jenkins\jre\lib\ext;C:\windows\Sun\Java\lib\ext
          java.homeC:\Program Files (x86)\Jenkins\jre
          java.io.tmpdirC:\windows\TEMP\
          java.library.pathC:\Program Files (x86)\Jenkins\jre\bin;C:\windows\Sun\Java\bin;C:\windows\system32;C:\windows;C:\Program Files\HP_Fortify\HP_Fortify_SCA_and_Apps_4.31\bin;C:\Perl64\site\bin;C:\Perl64\bin;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\ProgramData\Oracle\Java\javapath;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\AccuRev\bin;C:\Program Files\ibm\gsk8\lib64;C:\Program Files (x86)\ibm\gsk8\lib;C:\IBM\SQLLIB\BIN;C:\IBM\SQLLIB\FUNCTION;C:\IBM\SQLLIB\SAMPLES\REPL;C:/imap/engine;C:\IBM\WebSphere Transformation Extender 8.3;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\hdx\ant\apache-ant-1.8.1\bin;C:\hdx\gradle-2.14\bin;c:\Ruby23-x64\bin;C:\Program Files\nodejs\;C:\opscode\chefdk\bin\;C:\opscode\chefdk\embedded\bin\;;.
          java.runtime.nameJava(TM) SE Runtime Environment
          java.runtime.version1.8.0_20-b26
          java.specification.nameJava Platform API Specification
          java.specification.vendorOracle Corporation
          java.specification.version1.8
          java.vendorOracle Corporation
          java.vendor.urlhttp://java.oracle.com/
          java.vendor.url.bughttp://bugreport.sun.com/bugreport/
          java.version1.8.0_20
          java.vm.infomixed mode
          java.vm.nameJava HotSpot(TM) Client VM
          java.vm.specification.nameJava Virtual Machine Specification
          java.vm.specification.vendorOracle Corporation
          java.vm.specification.version1.8
          java.vm.vendorOracle Corporation
          java.vm.version25.20-b23
          javamelody.About Monitoringhttps://wiki.jenkins-ci.org/display/JENKINS/Monitoring
          javamelody.analytics-idUA-1335263-7
          javamelody.custom-reportsJenkins Info,About Monitoring
          javamelody.gzip-compression-disabledtrue
          javamelody.http-transform-pattern/\d+/|/site/.+|avadoc/.+|/ws/.+|obertura/.+|estReport/.+|iolations/file/.+|/user/.+|/static/\w+/|/adjuncts/\w+/|/bound/[\w\-]+
          javamelody.Jenkins Info/systemInfo
          javamelody.no-databasetrue
          javamelody.storage-directory/C:\Program Files (x86)\Jenkins\monitoring
          javamelody.system-actions-enabledtrue
          jna.loadedtrue
          jnidispatch.pathC:\windows\TEMP\jna--1766566870\jna602122362884109575.dll
          line.separator

          mail.smtp.sendpartialtrue
          mail.smtps.sendpartialtrue
          os.archx86
          os.nameWindows 8.1
          os.version6.3
          path.separator;
          pid24904
          sun.arch.data.model32
          sun.boot.class.pathC:\Program Files (x86)\Jenkins\jre\lib\resources.jar;C:\Program Files (x86)\Jenkins\jre\lib\rt.jar;C:\Program Files (x86)\Jenkins\jre\lib\sunrsasign.jar;C:\Program Files (x86)\Jenkins\jre\lib\jsse.jar;C:\Program Files (x86)\Jenkins\jre\lib\jce.jar;C:\Program Files (x86)\Jenkins\jre\lib\charsets.jar;C:\Program Files (x86)\Jenkins\jre\lib\jfr.jar;C:\Program Files (x86)\Jenkins\jre\classes
          sun.boot.library.pathC:\Program Files (x86)\Jenkins\jre\bin
          sun.cpu.endianlittle
          sun.cpu.isalistpentium_pro+mmx pentium_pro pentium+mmx pentium i486 i386 i86
          sun.desktopwindows
          sun.io.unicode.encodingUnicodeLittle
          sun.java.commandC:\Program Files (x86)\Jenkins\jenkins.war --httpPort=8080
          sun.java.launcherSUN_STANDARD
          sun.jnu.encodingCp1252
          sun.management.compilerHotSpot Client Compiler
          sun.os.patch.level
          svnkit.http.methodsDigest,Basic,NTLM,Negotiate
          svnkit.ssh2.persistentfalse
          user.countryUS
          user.dirC:\Program Files (x86)\Jenkins
          user.homeC:\windows\system32\config\systemprofile
          user.languageen
          user.nameW1559922$
          user.script
          user.timezoneAmerica/New_York
          user.variant

          Environment Variables


          Name ↓

          Value

          ALLUSERSPROFILEC:\ProgramData
          ANT_HOMEC:\hdx\ant\apache-ant-1.8.1
          APPDATAC:\windows\system32\config\systemprofile\AppData\Roaming
          BASEC:\Program Files (x86)\Jenkins
          CLASSPATH.;C:\IBM\SQLLIB\java\db2java.zip;C:\IBM\SQLLIB\java\db2jcc.jar;C:\IBM\SQLLIB\java\sqlj.zip;C:\IBM\SQLLIB\java\db2jcc_license_cu.jar;C:\IBM\SQLLIB\bin;C:\IBM\SQLLIB\java\common.jar;C:/imap/engine
          CommonProgramFilesC:\Program Files (x86)\Common Files
          CommonProgramFiles(x86)C:\Program Files (x86)\Common Files
          CommonProgramW6432C:\Program Files\Common Files
          COMPUTERNAMEW1559922
          ComSpecC:\windows\system32\cmd.exe
          DB2INSTANCEDB2
          DEFLOGDIRC:\ProgramData\McAfee\DesktopProtection
          FP_NO_HOST_CHECKNO
          GRADLE_HOMEC:\hdx\gradle-2.14
          GRADLE_USER_HOMEC:\hdx\gradle
          IMAP_HOMEC:/imap/engine
          INCLUDEC:\IBM\SQLLIB\INCLUDE;C:\IBM\SQLLIB\LIB
          JAVA_HOMEC:\Program Files\Java\jdk1.8.0_92
          JENKINS_HOMEC:\Program Files (x86)\Jenkins
          LIB;C:\IBM\SQLLIB\LIB
          LOCALAPPDATAC:\windows\system32\config\systemprofile\AppData\Local
          NUMBER_OF_PROCESSORS8
          OSWindows_NT
          PathC:\Program Files\HP_Fortify\HP_Fortify_SCA_and_Apps_4.31\bin;C:\Perl64\site\bin;C:\Perl64\bin;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\ProgramData\Oracle\Java\javapath;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\AccuRev\bin;C:\Program Files\ibm\gsk8\lib64;C:\Program Files (x86)\ibm\gsk8\lib;C:\IBM\SQLLIB\BIN;C:\IBM\SQLLIB\FUNCTION;C:\IBM\SQLLIB\SAMPLES\REPL;C:/imap/engine;C:\IBM\WebSphere Transformation Extender 8.3;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\hdx\ant\apache-ant-1.8.1\bin;C:\hdx\gradle-2.14\bin;c:\Ruby23-x64\bin;C:\Program Files\nodejs\;C:\opscode\chefdk\bin\;C:\opscode\chefdk\embedded\bin\;
          PATHEXT.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
          PROCESSOR_ARCHITECTUREx86
          PROCESSOR_ARCHITEW6432AMD64
          PROCESSOR_IDENTIFIERIntel64 Family 6 Model 60 Stepping 3, GenuineIntel
          PROCESSOR_LEVEL6
          PROCESSOR_REVISION3c03
          ProgramDataC:\ProgramData
          ProgramFilesC:\Program Files (x86)
          ProgramFiles(x86)C:\Program Files (x86)
          ProgramW6432C:\Program Files
          PSModulePathC:\Program Files\WindowsPowerShell\Modules;C:\windows\system32\WindowsPowerShell\v1.0\Modules;C:\opscode\chefdk\modules\
          PUBLICC:\Users\Public
          RUBY_HOMEc:\Ruby23-x64
          SERVICE_IDjenkins
          SystemDriveC:
          SystemRootC:\windows
          TEMPC:\windows\TEMP
          TMPC:\windows\TEMP
          UATDATAC:\windows\CCM\UATData\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77
          USERDOMAINWHQ_NT_DOMAIN
          USERNAMEW1559922$
          USERPROFILEC:\windows\system32\config\systemprofile
          VSEDEFLOGDIRC:\ProgramData\McAfee\DesktopProtection
          windirC:\windows
          WINSW_EXECUTABLEC:\Program Files (x86)\Jenkins\jenkins.exe
          WTX_HOMEC:\IBM\WebSphere Transformation Extender 8.3

          Plugins


          Name ↓

          Version

          Enabled

          Pinned

          accurev0.7.8truefalse
          ace-editor1.1truefalse
          active-directory2.0truefalse
          ant1.4truefalse
          antisamy-markup-formatter1.5truefalse
          artifactdeployer0.33truefalse
          artifactory2.9.0truefalse
          attention1.1truefalse
          bouncycastle-api2.16.0truefalse
          branch-api1.11.1truefalse
          build-blocker-plugin1.7.3truefalse
          build-metrics1.3truefalse
          build-monitor-plugin1.11+build.201701152243truefalse
          build-timeout1.18truefalse
          buildresult-trigger0.17truefalse
          buildtriggerbadge2.7truefalse
          cloudbees-folder5.16truefalse
          conditional-buildstep1.3.5truefalse
          config-file-provider2.15.5truefalse
          copy-to-slave1.4.4truefalse
          credentials2.1.10truefalse
          cvs2.13truefalse
          deploy1.10truefalse
          deploy-websphere1.0truefalse
          description-column-plugin1.3truefalse
          display-url-api0.5truefalse
          durable-task1.13truefalse
          email-ext2.53truefalse
          envinject1.93.1truefalse
          Exclusion0.12truefalse
          extended-read-permission1.0truefalse
          external-monitor-job1.7truefalse
          external-workspace-manager1.1.1truefalse
          extra-columns1.17truefalse
          ez-templates1.2.5truefalse
          file-operations1.3truefalse
          filesystem_scm1.20truefalse
          fitnesse1.16truefalse
          git3.0.2truefalse
          git-client2.2.1truefalse
          git-server1.7truefalse
          github1.25.1truefalse
          github-api1.84truefalse
          github-branch-source1.10.1truefalse
          github-organization-folder1.5truefalse
          global-build-stats1.4truefalse
          gradle1.25truefalse
          greenballs1.15truefalse
          groovy1.30truefalse
          handlebars1.1.1truefalse
          icon-shim2.0.3truefalse
          ivy1.27.1truefalse
          jackson2-api2.7.3truefalse
          javadoc1.4truefalse
          jenkins-multijob-plugin1.23truefalse
          job-restrictions0.6truefalse
          join1.21truefalse
          jquery1.11.2-0truefalse
          jquery-detached1.2.1truefalse
          junit1.19truefalse
          ldap1.13truefalse
          lenientshutdown1.1.0truefalse
          mailer1.18truefalse
          mapdb-api1.0.9.0truefalse
          matrix-auth1.4truefalse
          matrix-project1.8truefalse
          maven-plugin2.14truefalse
          metrics3.1.2.9truefalse
          momentjs1.1.1truefalse
          monitoring1.63.0truefalse
          next-executions1.0.12truefalse
          pam-auth1.3truefalse
          parameterized-trigger2.32truefalse
          periodicbackup1.3truefalse
          pipeline-build-step2.4truefalse
          pipeline-graph-analysis1.3truefalse
          pipeline-input-step2.5truefalse
          pipeline-milestone-step1.3truefalse
          pipeline-rest-api2.4truefalse
          pipeline-stage-step2.2truefalse
          pipeline-stage-view2.4truefalse
          plain-credentials1.3truefalse
          postbuildscript0.17truefalse
          preSCMbuildstep0.3truefalse
          PrioritySorter3.5.0truefalse
          resource-disposer0.6truefalse
          run-condition1.0truefalse
          scm-api2.0.1truefalse
          script-security1.25truefalse
          shared-workspace1.0.2truefalse
          sidebar-update-notification1.1.0truefalse
          simple-theme-plugin0.3truefalse
          sonar2.5truefalse
          ssh-credentials1.12truefalse
          ssh-slaves1.12truefalse
          structs1.5truefalse
          subversion2.7.1truefalse
          support-core2.38truefalse
          timestamper1.8.7truefalse
          token-macro2.0truefalse
          translation1.15truefalse
          upstream-downstream-view1.006truefalse
          versionnumber1.8.1truefalse
          windows-slaves1.2truefalse
          workflow-aggregator2.4truefalse
          workflow-api2.8truefalse
          workflow-basic-steps2.3truefalse
          workflow-cps2.24truefalse
          workflow-cps-global-lib2.5truefalse
          workflow-durable-task-step2.8truefalse
          workflow-job2.9truefalse
          workflow-multibranch2.9.2truefalse
          workflow-scm-step2.3truefalse
          workflow-step-api2.7truefalse
          workflow-support2.12truefalse
          ws-cleanup0.32truefalse
          zentimestamp4.2truefalse
          Jenkins 2.41
          AccuRev Plugin which works is 0.7.6
          AccuRev Plugin which fails is 0.7.8
          Windows 8.1 Enterprise (64-bit)
          Accurev 6.2.3

          Code changed in jenkins
          User: Joseph
          Path:
          src/main/java/hudson/plugins/accurev/AccurevLauncher.java
          src/main/java/hudson/plugins/accurev/cmd/Login.java
          http://jenkins-ci.org/commit/accurev-plugin/a89fc085eccce375eb0c343a5b7f16060bf752f4
          Log:
          JENKINS-41266 Fix ArrayIndexOutOfBoundsException (#41)

          • Avoid sending empty string to process starter
          • Add CheckForNull
          • Use Launcher to check isUnix
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Joseph Path: src/main/java/hudson/plugins/accurev/AccurevLauncher.java src/main/java/hudson/plugins/accurev/cmd/Login.java http://jenkins-ci.org/commit/accurev-plugin/a89fc085eccce375eb0c343a5b7f16060bf752f4 Log: JENKINS-41266 Fix ArrayIndexOutOfBoundsException (#41) Avoid sending empty string to process starter Add CheckForNull Use Launcher to check isUnix
          bercma00 Mark Berchem added a comment -

          I upgraded to the 0.7.9 version of the AccuRev Plugin and it seems to be OK.

          bercma00 Mark Berchem added a comment - I upgraded to the 0.7.9 version of the AccuRev Plugin and it seems to be OK.
          casz Joseph Petersen (old) made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          jetersen Joseph Petersen made changes -
          Assignee Joseph Petersen (old) [ casz ] Joseph Petersen [ jetersen ]

          People

            jetersen Joseph Petersen
            bercma00 Mark Berchem
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: