Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41486

the timestamper format is not rememembered across jobs

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      As a user of Jenkins I do find the timestamper format (duration vs time) to be a global preference option that should be remembered, ideally as a user preference option (so it would be retained even across different machines/browsers).

      Still, if it would be to hard to implement, even the ability to remember the format per browser (cookie) would be much better than the current behavior.

        Attachments

          Activity

          ssbarnea Sorin Sbarnea created issue -
          stevengbrown Steven G Brown added a comment -

          The selected format is stored with cookies for each Jenkins site. Is this not working for you?

          ssbarnea Sorin Sbarnea added a comment -

          Steven G Brown I was able to identify the bug: the cookie is saved but it is useless because it is saved with the full job-execution path. So the value is remembered for /foo-job/123 which is making it kinda useless.

          I do have hundreds of different job names with thousands of executions and I was expecting to remember this preference for the entire jenkins instance ( path = / ) not for a specific job.

          Also the current implementation has another side-effect bug: it does clutter jenkins instance with cookies for each job, and is contributing to another known jenkins bug when the max cookie size limit is reached.

          ssbarnea Sorin Sbarnea made changes -
          stevengbrown Steven G Brown added a comment -

          You don't have to convince me. I've already said that it isn't meant to work that way.

          The cookie path is set to rootURL, or '/' if rootURL isn't defined. Perhaps something has changed in Jenkins so that the plugin can no longer use this value.

          stevengbrown Steven G Brown made changes -
          Issue Type Improvement [ 4 ] Bug [ 1 ]
          stevengbrown Steven G Brown added a comment -

          I haven't been able to reproduce this. Are you still experiencing the issue? What version of Jenkins and Timestamper are you running?

          stevengbrown Steven G Brown made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Resolved [ 5 ]

            People

            Assignee:
            stevengbrown Steven G Brown
            Reporter:
            ssbarnea Sorin Sbarnea
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: