Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41727

Upgrading/downgrading Jenkins needs to invalidate update site cache

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      2.280 and 2.277.1

      Description

      A weekly version of Jenkins was installed (2.42). Uninstalled that version and installed a LTS version (2.32.2). Jenkins shows the following notification: "New version of Jenkins (2.43) is available for download".

      It should detect this is a LTS installation and only prompt to update to LTS versions.

      Additionally, incompatible versions of plugins could be offered, when a more appropriate update site would offer compatible releases.

      On upgrade, Jenkins might miss new plugins not available to the previous baseline, such as detached plugins.

        Attachments

          Issue Links

            Activity

            Hide
            danielbeck Daniel Beck added a comment -

            Invalid link, I think – upgrading uses the local copy of the plugin.

            Show
            danielbeck Daniel Beck added a comment - Invalid link, I think – upgrading uses the local copy of the plugin.
            Hide
            danielbeck Daniel Beck added a comment -

            JENKINS-48365 tracks a bug in core related to detached plugins, but I expect without a fix for this issue, it will remain broken for many users.

            Show
            danielbeck Daniel Beck added a comment - JENKINS-48365 tracks a bug in core related to detached plugins, but I expect without a fix for this issue, it will remain broken for many users.

              People

              Assignee:
              timja Tim Jacomb
              Reporter:
              gtirloni Giovanni Tirloni
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: