Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43379

WARN: java.lang.InterruptedException: no matches found within 10000

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Do
    • Component/s: junit-plugin
    • Labels:
      None
    • Environment:
      jenkins 2.46.1 (also reproducible even with much older versions)
    • Similar Issues:

      Description

      It seems that this warning is triggered sometimes when junit fails to find any test results to grab and this is really confusing because it makes you waste time investigating the wrong problem.

      *There is no timeout involved in this, but the presence of InterruptedException and 1000 makes you believe that this is what really happened. *

      00:27:18.378 + exit 0
      00:27:18.451 Set build name.
      00:27:18.458 New build name is '#2_rhos-10.0-patches'
      00:27:18.485 Variable with name 'BUILD_DISPLAY_NAME' already exists, current value: '#2_rhos-10.0-patches', new value: '#2_rhos-10.0-patches'
      00:27:18.592 Archiving artifacts
      00:27:18.994 WARN: No artifacts found that match the file pattern "**/*.tar.gz, **/*.log, **/etc/tempest.conf". Configuration error?
      00:27:19.143 WARN: java.lang.InterruptedException: no matches found within 10000
      00:27:19.143 Recording test results
      00:27:19.597 ERROR: Step ‘Publish JUnit test result report’ failed: No test report files were found. Configuration error?
      00:27:19.597 [BFA] Scanning build for known causes...
      
      

        Attachments

          Issue Links

            Activity

            estefafdez Estefania Fernandez added a comment - - edited

            Hello, is there any solution for this problem? I have the same issue archieving an apk file after compile an android app using the archive artifacts plugin by pipeline:
             

            09:05:34 Archiving artifacts
            09:05:35 java.lang.InterruptedException: no matches found within 10000
            09:05:35 	at hudson.FilePath$ValidateAntFileMask.hasMatch(FilePath.java:2845)
            09:05:35 	at hudson.FilePath$ValidateAntFileMask.invoke(FilePath.java:2724)
            09:05:35 	at hudson.FilePath$ValidateAntFileMask.invoke(FilePath.java:2705)
            09:05:35 	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:3084)
            09:05:35 Also:   hudson.remoting.Channel$CallSiteStackTrace: Remote call to JNLP4-connect connection from 192.168.1.75/192.168.1.75:51562
            09:05:35 		at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1741)
            09:05:35 		at hudson.remoting.UserRequest$ExceptionResponse.retrieve(UserRequest.java:357)
            09:05:35 		at hudson.remoting.Channel.call(Channel.java:955)
            09:05:35 		at hudson.FilePath.act(FilePath.java:1070)
            09:05:35 		at hudson.FilePath.act(FilePath.java:1059)
            09:05:35 		at hudson.FilePath.validateAntFileMask(FilePath.java:2703)
            09:05:35 		at hudson.tasks.ArtifactArchiver.perform(ArtifactArchiver.java:243)
            09:05:35 		at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:80)
            09:05:35 		at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:67)
            09:05:35 		at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution$1$1.call(SynchronousNonBlockingStepExecution.java:50)
            09:05:35 		at hudson.security.ACL.impersonate(ACL.java:290)
            09:05:35 		at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution$1.run(SynchronousNonBlockingStepExecution.java:47)
            09:05:35 		at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
            09:05:35 		at java.util.concurrent.FutureTask.run(FutureTask.java:266)
            09:05:35 		at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
            09:05:35 		at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
            09:05:35 Caused: hudson.FilePath$TunneledInterruptedException
            09:05:35 	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:3086)
            09:05:35 	at hudson.remoting.UserRequest.perform(UserRequest.java:212)
            09:05:35 	at hudson.remoting.UserRequest.perform(UserRequest.java:54)
            09:05:35 	at hudson.remoting.Request$2.run(Request.java:369)
            09:05:35 	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
            09:05:35 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
            09:05:35 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
            09:05:35 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
            09:05:35 	at hudson.remoting.Engine$1.lambda$newThread$0(Engine.java:93)
            09:05:35 Caused: java.lang.InterruptedException: java.lang.InterruptedException: no matches found within 10000
            09:05:35 	at hudson.FilePath.act(FilePath.java:1072)
            09:05:35 	at hudson.FilePath.act(FilePath.java:1059)
            09:05:35 	at hudson.FilePath.validateAntFileMask(FilePath.java:2703)
            09:05:35 	at hudson.tasks.ArtifactArchiver.perform(ArtifactArchiver.java:243)
            09:05:35 	at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:80)
            09:05:35 	at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:67)
            09:05:35 	at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution$1$1.call(SynchronousNonBlockingStepExecution.java:50)
            09:05:35 	at hudson.security.ACL.impersonate(ACL.java:290)
            09:05:35 	at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution$1.run(SynchronousNonBlockingStepExecution.java:47)
            09:05:35 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
            09:05:35 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
            09:05:35 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
            09:05:35 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
            09:05:35 	at java.lang.Thread.run(Thread.java:748)
            

            Thanks

            ssbarnea Sorin Sbarnea added a comment -

            I am closing this becase this seems to be the only way to silence notifications on a bug and I am not allowed to change reporter to avoid these.

            If someone else has the power to change reported and reopen the bug feel free, if not create a new bug.

             


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              ssbarnea Sorin Sbarnea
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: