Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4337

Busy status does not switch back to available if build has finished

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • jabber-plugin
    • None
    • Platform: All, OS: All

    Description

      Tge busy status does not switch back to "available" if build has finished. This
      happens since the latest version (0.10). This problem is always reproducable.

      Attachments

        Activity

          kutzi kutzi added a comment -

          Thanks for reporting this.
          I've noted this behaviour, too. However in my case it goes back to available
          most of the time and only sometimes it stays busy.

          Currently, I still don't know what the problem could be.
          Do you have a testcase to reproduce the problem?

          kutzi kutzi added a comment - Thanks for reporting this. I've noted this behaviour, too. However in my case it goes back to available most of the time and only sometimes it stays busy. Currently, I still don't know what the problem could be. Do you have a testcase to reproduce the problem?
          kutzi kutzi added a comment -

          Does that happen only with failing builds or also with different ones?

          kutzi kutzi added a comment - Does that happen only with failing builds or also with different ones?
          jusername jusername added a comment -

          Maybe this helps:

          java version "1.6.0_12"
          Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
          Java HotSpot(TM) 64-Bit Server VM (build 11.2-b01, mixed mode)

          Debian Lenny

          Hudson ver. 1.321 (Debian package)

          Plugins:

          Hudson disk-usage plugin 0.9
          Hudson TextFinder plugin 1.7
          Emotional Hudson plugin 1.01
          Hudson Task Scanner Plug-in 3.10
          Hudson Mercurial plugin 1.16
          Subversion Plugin 1.5
          Hudson SSH Slaves plugin 0.7
          Hudson Support Subscription Notification Plugin 1.0
          Hudson Sonar Plugin1.1
          Maven Integration plugin 1.321
          Hudson Jabber notifier plugin 0.10
          Hudson Dependency Analyzer Plugin 0.3
          Hudson Warnings Plug-in 2.11

          1 build processor

          Only Jabber-ID and password are set in the preferences

          jusername jusername added a comment - Maybe this helps: java version "1.6.0_12" Java(TM) SE Runtime Environment (build 1.6.0_12-b04) Java HotSpot(TM) 64-Bit Server VM (build 11.2-b01, mixed mode) Debian Lenny Hudson ver. 1.321 (Debian package) Plugins: Hudson disk-usage plugin 0.9 Hudson TextFinder plugin 1.7 Emotional Hudson plugin 1.01 Hudson Task Scanner Plug-in 3.10 Hudson Mercurial plugin 1.16 Subversion Plugin 1.5 Hudson SSH Slaves plugin 0.7 Hudson Support Subscription Notification Plugin 1.0 Hudson Sonar Plugin1.1 Maven Integration plugin 1.321 Hudson Jabber notifier plugin 0.10 Hudson Dependency Analyzer Plugin 0.3 Hudson Warnings Plug-in 2.11 1 build processor Only Jabber-ID and password are set in the preferences
          jusername jusername added a comment -

          This does happen with all builds (successful or failing).

          jusername jusername added a comment - This does happen with all builds (successful or failing).
          kutzi kutzi added a comment -

          Nevermind, I think I've found the problem. If you like, I can send you a
          snapshot with the fix.

          kutzi kutzi added a comment - Nevermind, I think I've found the problem. If you like, I can send you a snapshot with the fix.

          Code changed in hudson
          User: : kutzi
          Path:
          trunk/hudson/plugins/jabber/src/main/java/hudson/plugins/jabber/im/AbstractIMConnection.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=21209
          Log:
          [FIXED JENKINS-4337] busy status not switching back to available after build finishes

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : kutzi Path: trunk/hudson/plugins/jabber/src/main/java/hudson/plugins/jabber/im/AbstractIMConnection.java http://fisheye4.cenqua.com/changelog/hudson/?cs=21209 Log: [FIXED JENKINS-4337] busy status not switching back to available after build finishes
          jusername jusername added a comment -

          That would be nice

          thomas@atunes.org

          jusername jusername added a comment - That would be nice thomas@atunes.org
          jusername jusername added a comment -

          The problem is still present in the latest release (0.11).

          jusername jusername added a comment - The problem is still present in the latest release (0.11).
          kutzi kutzi added a comment -

          hmpf, there seems to be no clean, reliable way to calculate the number of busy
          executors with a RunListener.
          I guess, I'll have to use brute-force i.e. polling for busy executors.

          kutzi kutzi added a comment - hmpf, there seems to be no clean, reliable way to calculate the number of busy executors with a RunListener. I guess, I'll have to use brute-force i.e. polling for busy executors.
          kutzi kutzi added a comment -

          Could you please check if you have warnings like this in Hudson's log:
          Didn't find executor for run xyz among the list of busy executors.

          kutzi kutzi added a comment - Could you please check if you have warnings like this in Hudson's log: Didn't find executor for run xyz among the list of busy executors.

          Code changed in hudson
          User: : kutzi
          Path:
          trunk/hudson/plugins/jabber/src/main/java/hudson/plugins/jabber/im/HudsonIsBusyListener.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=21639
          Log:
          JENKINS-4337: workaround for wrong executor count

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : kutzi Path: trunk/hudson/plugins/jabber/src/main/java/hudson/plugins/jabber/im/HudsonIsBusyListener.java http://fisheye4.cenqua.com/changelog/hudson/?cs=21639 Log: JENKINS-4337 : workaround for wrong executor count
          jusername jusername added a comment -

          There is no warning like this in the log.

          jusername jusername added a comment - There is no warning like this in the log.

          Code changed in hudson
          User: : kutzi
          Path:
          trunk/hudson/plugins/jabber/pom.xml
          trunk/hudson/plugins/jabber/src/main/java/hudson/plugins/jabber/im/HudsonIsBusyListener.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=21641
          Log:
          JENKINS-4337: workaround for wrong executor count

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : kutzi Path: trunk/hudson/plugins/jabber/pom.xml trunk/hudson/plugins/jabber/src/main/java/hudson/plugins/jabber/im/HudsonIsBusyListener.java http://fisheye4.cenqua.com/changelog/hudson/?cs=21641 Log: JENKINS-4337 : workaround for wrong executor count
          kutzi kutzi added a comment -

          I still don't completely understand why it didn't work in your case.
          Nevertheless it should be - finally - fixed in 1.0

          kutzi kutzi added a comment - I still don't completely understand why it didn't work in your case. Nevertheless it should be - finally - fixed in 1.0

          People

            kutzi kutzi
            jusername jusername
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: