Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4535

The ability to clone from multiple repositories into separate directories would be useful

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Won't Fix
    • git-plugin
    • None
    • Platform: All, OS: All

    Description

      We have a git based hudson project, where we'd like to clone/pull from multiple separate git repos into
      the same workspace.

      Currently the only way to clone multiple repos assumes that we're attempting to merge contents, and
      works on the same directory [ the workspace root ].

      Would be good to be able to clone from multiple independent git repos into the same workspace, and
      specify the subdirectory they should be cloned to.

      Attachments

        Issue Links

          Activity

            abayer Andrew Bayer added a comment -

            The Multiple SCMs plugin is the solution here.

            abayer Andrew Bayer added a comment - The Multiple SCMs plugin is the solution here.

            we need a setting per repository to fix this issue

            mireczatko Miroslav Zaťko added a comment - we need a setting per repository to fix this issue

            Agree to Jayson. It is definitely not a duplicate of 6357 and it is not resolved yet. The setting should be per Git repository

            mireczatko Miroslav Zaťko added a comment - Agree to Jayson. It is definitely not a duplicate of 6357 and it is not resolved yet. The setting should be per Git repository
            jaysonminard Jayson Minard added a comment -

            I don't think it is a duplicate, nor solves the problem. The related issue 6357 adds an advanced setting that is NOT per Git repo. It is one advanced setting that appears to apply to all GIT repo's evenly. So you still end up with them pulling on top of each other to the same location, yes?

            jaysonminard Jayson Minard added a comment - I don't think it is a duplicate, nor solves the problem. The related issue 6357 adds an advanced setting that is NOT per Git repo. It is one advanced setting that appears to apply to all GIT repo's evenly. So you still end up with them pulling on top of each other to the same location, yes?
            abayer Andrew Bayer added a comment -

            Marking as a resolved duplicate.

            abayer Andrew Bayer added a comment - Marking as a resolved duplicate.
            asinglepixel asinglepixel added a comment -

            We too have a project with several different git repositories. e.g. our code in one git repo, 3rd-party dependencies in other git repos. I'd like to be able to clone them to separate folders rather than one git repo taking over the entire workspace's root.

            asinglepixel asinglepixel added a comment - We too have a project with several different git repositories. e.g. our code in one git repo, 3rd-party dependencies in other git repos. I'd like to be able to clone them to separate folders rather than one git repo taking over the entire workspace's root.

            People

              abayer Andrew Bayer
              sdezzi sdezzi
              Votes:
              5 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: