Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46986

No valid crumb was included in the request


    • Icon: Bug Bug
    • Resolution: Not A Defect
    • Icon: Major Major
    • core
    • jenkins-2.77-1.1.noarch.rpm
      My server is running Red Hat 4.8.5-16
      Linux version kernel 3.10.0-693.2.2.el7.x86_64

      This was also tried on many other servers running Debian and CentOS, and Amazon AWS free server. The error "No valid crumb was included in the request" gets displayed when trying to configure a new job and specifically when inserting a link of the GIT repository. Sometimes this message gets displayed inside the configuration body of GIT. And sometimes the page goes white and the error displays this. Sometimes it passes the step where you configure your job and when you click Save at the bottom, then it displays the error. Sometimes while installing the basic Jenkins installation with basic packages the error gets displayed. Git repository is a custom GitLab repository. The only time it worked when I installed Jenkins on my Linux laptop and then configured a job and while accessing Jenkins, I had to enter localhost:8080 in my browser to access it locally. When I tried connecting to the Jenkins remotely, through its IP and port, it didn't work. I tried to connect to the server via VirtualNetworkComputing (VNC) like through a remote desktop and also didn't work. I also thought that the SSL needs to be configured on the server's domain to securely access Jenkins, but that didn't work either. The error still gets displayed. I also tried versions 2.60 and 2.7.

        1. err1.PNG
          70 kB
        2. err2.PNG
          82 kB
        3. newError.PNG
          25 kB
        4. Screenshot_20170919_090351.png
          51 kB

            danielbeck Daniel Beck
            emil_kosic Emil Kosic
            1 Vote for this issue
            1 Start watching this issue