Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47019

Ajax blocked due to http/https mismatch in client side update check

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 2.77
    • Similar Issues:

      Description

      Setup

      Due to firewall restrictions I'm using the "Use Browser to download Meta Data" feature.

      This allowed me in the past to view all updates available for jenkins, even though the server itself has no internet access.

      Issue

      Since the last update to 2.77 this feature stopped working.
      When opening the browser console I get the following error:

      Mixed Content: The page at 'https://xxxx/sbjenkins/pluginManager/checkUpdates' was loaded over HTTPS, but requested an insecure resource 'http://updates.jenkins-ci.org/update-center.json.html?id=default&version=2.77'. This request has been blocked; the content must be served over HTTPS.

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          R. Tyler Croy Daniel Beck Likely it has been caused by https://github.com/jenkinsci/jenkins/pull/2996 .

          Probably the update center configuration in Jenkins needs to be updated in order to use the HTTPS address.

          danielbeck Daniel Beck added a comment -

          I'm pretty sure this is a legacy setup that has an HTTP update site URL configured.

          David S Manage Jenkins » Manage Plugins » Advanced. What's the URL at the bottom? What happens when you specify the equivalent https url?

          davidgiga1993 David S added a comment -

          Daniel Beck Doh, this fixes the issue. Sorry for overlooking that option. I was assuming the protocol changes automaticaly when you define "https" as jenkins URL.

          danielbeck Daniel Beck added a comment -

          User configuration.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            davidgiga1993 David S
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: