Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47820

GitHub Status setter: "201 Created" API response => Numeric value out of range of int

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: github-api-plugin
    • Labels:
      None
    • Environment:
      github-plugin 1.27.0
    • Similar Issues:

      Description

      If 'Set GitHub commit status (universal)' is used, the job always fails because the GitHub plugin is not able to parse a response from GitHub. The content of the response is, at least in my case, "I did set the commit status successfully". That means the status is set correctly on GitHub but the plugin fails anyway.

      ERROR: Build step failed with exception
      org.jenkinsci.plugins.github.common.CombineErrorHandler$ErrorHandlingException: org.kohsuke.github.HttpException: Server returned HTTP response code: 201, message: 'Created' for URL: https://api.github.com/repos/upgrades-migrations/redhat-upgrade-tool/statuses/d71bce490b81a6b7dcfa6d8ee9152ecf599c5763
       at org.jenkinsci.plugins.github.common.CombineErrorHandler.handle(CombineErrorHandler.java:74)
       at org.jenkinsci.plugins.github.status.GitHubCommitStatusSetter.perform(GitHubCommitStatusSetter.java:164)
       at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:78)
       at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
       at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
       at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723)
       at hudson.model.Build$BuildExecution.post2(Build.java:185)
       at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668)
       at hudson.model.Run.execute(Run.java:1763)
       at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
       at hudson.model.ResourceController.execute(ResourceController.java:98)
       at hudson.model.Executor.run(Executor.java:410)
      Caused by: org.kohsuke.github.HttpException: Server returned HTTP response code: 201, message: 'Created' for URL: https://api.github.com/repos/upgrades-migrations/redhat-upgrade-tool/statuses/d71bce490b81a6b7dcfa6d8ee9152ecf599c5763
       at org.kohsuke.github.Requester.parse(Requester.java:613)
       at org.kohsuke.github.Requester._to(Requester.java:263)
       at org.kohsuke.github.Requester.to(Requester.java:225)
       at org.kohsuke.github.GHRepository.createCommitStatus(GHRepository.java:1000)
       at org.jenkinsci.plugins.github.status.GitHubCommitStatusSetter.perform(GitHubCommitStatusSetter.java:160)
       ... 10 more
      Caused by: java.io.IOException: Failed to deserialize {"url":"https://api.github.com/repos/upgrades-migrations/redhat-upgrade-tool/statuses/d71bce490b81a6b7dcfa6d8ee9152ecf599c5763","id":4299395834,"state":"success","description":"Build #12 succeeded in 2.4 sec","target_url":"https://gist.github.com/bf7888d68ade859fa7233b1fea9ddd08","context":"Unit tests for a commit","created_at":"2017-11-03T15:58:14Z","updated_at":"2017-11-03T15:58:14Z","creator":{"login":"preupg-bot","id":23213543,"avatar_url":"https://avatars2.githubusercontent.com/u/23213543?v=4","gravatar_id":"","url":"https://api.github.com/users/preupg-bot","html_url":"https://github.com/preupg-bot","followers_url":"https://api.github.com/users/preupg-bot/followers","following_url":"https://api.github.com/users/preupg-bot/following{/other_user}","gists_url":"https://api.github.com/users/preupg-bot/gists{/gist_id}","starred_url":"https://api.github.com/users/preupg-bot/starred{/owner}{/repo}","subscriptions_url":"https://api.github.com/users/preupg-bot/subscriptions","organizations_url":"https://api.github.com/users/preupg-bot/orgs","repos_url":"https://api.github.com/users/preupg-bot/repos","events_url":"https://api.github.com/users/preupg-bot/events{/privacy}","received_events_url":"https://api.github.com/users/preupg-bot/received_events","type":"User","site_admin":false}}
       at org.kohsuke.github.Requester.parse(Requester.java:603)
       ... 14 more
      Caused by: com.fasterxml.jackson.databind.JsonMappingException: Numeric value (4299395834) out of range of int
       at [Source: java.io.StringReader@66189d98; line: 1, column: 144] (through reference chain: org.kohsuke.github.GHCommitStatus["id"])
       at com.fasterxml.jackson.databind.JsonMappingException.wrapWithPath(JsonMappingException.java:232)
       at com.fasterxml.jackson.databind.JsonMappingException.wrapWithPath(JsonMappingException.java:197)
       at com.fasterxml.jackson.databind.deser.BeanDeserializerBase.wrapAndThrow(BeanDeserializerBase.java:1311)
       at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserializeFromObject(BeanDeserializer.java:297)
       at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserialize(BeanDeserializer.java:121)
       at com.fasterxml.jackson.databind.ObjectMapper._readMapAndClose(ObjectMapper.java:2888)
       at com.fasterxml.jackson.databind.ObjectMapper.readValue(ObjectMapper.java:2034)
       at org.kohsuke.github.Requester.parse(Requester.java:601)
       ... 14 more
      Caused by: com.fasterxml.jackson.core.JsonParseException: Numeric value (4299395834) out of range of int
       at [Source: java.io.StringReader@66189d98; line: 1, column: 144]
       at com.fasterxml.jackson.core.JsonParser._constructError(JsonParser.java:1369)
       at com.fasterxml.jackson.core.base.ParserMinimalBase._reportError(ParserMinimalBase.java:532)
       at com.fasterxml.jackson.core.base.ParserBase.convertNumberToInt(ParserBase.java:847)
       at com.fasterxml.jackson.core.base.ParserBase.getIntValue(ParserBase.java:643)
       at com.fasterxml.jackson.databind.deser.std.StdDeserializer._parseInteger(StdDeserializer.java:306)
       at com.fasterxml.jackson.databind.deser.std.NumberDeserializers$IntegerDeserializer.deserialize(NumberDeserializers.java:319)
       at com.fasterxml.jackson.databind.deser.std.NumberDeserializers$IntegerDeserializer.deserialize(NumberDeserializers.java:301)
       at com.fasterxml.jackson.databind.deser.SettableBeanProperty.deserialize(SettableBeanProperty.java:464)
       at com.fasterxml.jackson.databind.deser.impl.FieldProperty.deserializeAndSet(FieldProperty.java:107)
       at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserializeFromObject(BeanDeserializer.java:295)
       ... 18 more
      Build step 'Set GitHub commit status (universal)' marked build as failure

        Attachments

          Issue Links

            Activity

            atodorov Alexander Todorov added a comment -

            I'm changing this to Bug and making it Blocker priority. My team uses the gitHub plugin to build projects in Jenkins and we need to be able to set the status accordingly. Furthermore this issue is failing the builds so we either have to not use the github-notifier publisher or have failed builds. None of these is acceptable since there aren't alternatives.

             

            This is the relevant snippet of my JJB file:

             

                publishers:
                  - github-notifier

             

             

            This is the console log from my build job:

            {{ [Set GitHub commit status (universal)] SUCCESS on repos [GHRepository@4835e8ad[description=<null>,homepage=<null>,name=bdcs,license=<null>,fork=true,size=607,milestones={},language=Haskell,commits={},url=}}
            {{ https://api.github.com/repos/atodorov/bdcs,id=88608615}}
            {{ ]] (sha:741f1bc) with context:atodorov-bdcs-runtest}}
            {{ Setting commit status on GitHub for }}
            {{ https://github.com/atodorov/bdcs/commit/741f1bc8e0e45f9da96e93fea0e75ee23a385d47}}
            {{ ERROR: Build step failed with exception}}
            {{ com.fasterxml.jackson.core.JsonParseException: Numeric value (4329239285) out of range of int}}
            {{ at [Source: {"url":"}}
            {{ https://api.github.com/repos/atodorov/bdcs/statuses/741f1bc8e0e45f9da96e93fea0e75ee23a385d47}}
            {{ ","id":4329239285,"state":"success","description":"Build #1 succeeded in 3.2 sec","target_url":"}}
            {{ https://composer-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/atodorov-bdcs-runtest/1/display/redirect}}
            {{ ","context":"atodorov-bdcs-runtest","created_at":"2017-11-20T10:51:50Z","updated_at":"2017-11-20T10:51:50Z","creator":{"login":"atodorov","id":1002300,"avatar_url":"https://avatars3.githubusercontent.com/u/1002300?v=4","gravatar_id":"","url":"https://api.github.com/users/atodorov","html_url":"https://github.com/atodorov","followers_url":"https://api.github.com/users/atodorov/followers","following_url":"https://api.github.com/users/atodorov/following{/other_user}","gists_url":"https://api.github.com/users/atodorov/gists{/gist_id}","starred_url":"https://api.github.com/users/atodorov/starred{/owner}{/repo}","subscriptions_url":"https://api.github.com/users/atodorov/subscriptions","organizations_url":"https://api.github.com/users/atodorov/orgs","repos_url":"https://api.github.com/users/atodorov/repos","events_url":"https://api.github.com/users/atodorov/events{/privacy}","received_events_url":"https://api.github.com/users/atodorov/received_events","type":"User","site_admin":false}}; line: 1, column: 118]}}
            {{ at com.fasterxml.jackson.core.JsonParser._constructError(JsonParser.java:1586)}}
            {{ at com.fasterxml.jackson.core.base.ParserMinimalBase._reportError(ParserMinimalBase.java:521)}}
            {{ at com.fasterxml.jackson.core.base.ParserBase.convertNumberToInt(ParserBase.java:938)}}
            {{ at com.fasterxml.jackson.core.base.ParserBase._parseIntValue(ParserBase.java:876)}}
            {{ at com.fasterxml.jackson.core.base.ParserBase.getIntValue(ParserBase.java:704)}}
            {{ at com.fasterxml.jackson.databind.deser.std.NumberDeserializers$IntegerDeserializer.deserialize(NumberDeserializers.java:313)}}
            {{ at com.fasterxml.jackson.databind.deser.std.NumberDeserializers$IntegerDeserializer.deserialize(NumberDeserializers.java:293)}}
            {{ at com.fasterxml.jackson.databind.deser.SettableBeanProperty.deserialize(SettableBeanProperty.java:490)}}
            {{ at com.fasterxml.jackson.databind.deser.impl.FieldProperty.deserializeAndSet(FieldProperty.java:101)}}
            {{ at com.fasterxml.jackson.databind.deser.BeanDeserializer.vanillaDeserialize(BeanDeserializer.java:260)}}
            {{ Caused: com.fasterxml.jackson.databind.JsonMappingException: Numeric value (4329239285) out of range of int}}
            {{ at [Source: {"url":"}}
            {{ https://api.github.com/repos/atodorov/bdcs/statuses/741f1bc8e0e45f9da96e93fea0e75ee23a385d47}}
            {{ ","id":4329239285,"state":"success","description":"Build #1 succeeded in 3.2 sec","target_url":"}}
            {{ https://composer-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/atodorov-bdcs-runtest/1/display/redirect}}
            {{ ","context":"atodorov-bdcs-runtest","created_at":"2017-11-20T10:51:50Z","updated_at":"2017-11-20T10:51:50Z","creator":{"login":"atodorov","id":1002300,"avatar_url":"https://avatars3.githubusercontent.com/u/1002300?v=4","gravatar_id":"","url":"https://api.github.com/users/atodorov","html_url":"https://github.com/atodorov","followers_url":"https://api.github.com/users/atodorov/followers","following_url":"https://api.github.com/users/atodorov/following{/other_user}","gists_url":"https://api.github.com/users/atodorov/gists{/gist_id}","starred_url":"https://api.github.com/users/atodorov/starred{/owner}{/repo}","subscriptions_url":"https://api.github.com/users/atodorov/subscriptions","organizations_url":"https://api.github.com/users/atodorov/orgs","repos_url":"https://api.github.com/users/atodorov/repos","events_url":"https://api.github.com/users/atodorov/events{/privacy}","received_events_url":"https://api.github.com/users/atodorov/received_events","type":"User","site_admin":false}}; line: 1, column: 118]}}
            {{ at [Source: {"url":"}}
            {{ https://api.github.com/repos/atodorov/bdcs/statuses/741f1bc8e0e45f9da96e93fea0e75ee23a385d47}}
            {{ ","id":4329239285,"state":"success","description":"Build #1 succeeded in 3.2 sec","target_url":"}}
            {{ https://composer-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/atodorov-bdcs-runtest/1/display/redirect}}
            {{ ","context":"atodorov-bdcs-runtest","created_at":"2017-11-20T10:51:50Z","updated_at":"2017-11-20T10:51:50Z","creator":{"login":"atodorov","id":1002300,"avatar_url":"https://avatars3.githubusercontent.com/u/1002300?v=4","gravatar_id":"","url":"https://api.github.com/users/atodorov","html_url":"https://github.com/atodorov","followers_url":"https://api.github.com/users/atodorov/followers","following_url":"https://api.github.com/users/atodorov/following{/other_user}","gists_url":"https://api.github.com/users/atodorov/gists{/gist_id}","starred_url":"https://api.github.com/users/atodorov/starred{/owner}{/repo}","subscriptions_url":"https://api.github.com/users/atodorov/subscriptions","organizations_url":"https://api.github.com/users/atodorov/orgs","repos_url":"https://api.github.com/users/atodorov/repos","events_url":"https://api.github.com/users/atodorov/events{/privacy}","received_events_url":"https://api.github.com/users/atodorov/received_events","type":"User","site_admin":false}}; line: 1, column: 108] (through reference chain: org.kohsuke.github.GHCommitStatus["id"])}}
            {{ at com.fasterxml.jackson.databind.JsonMappingException.wrapWithPath(JsonMappingException.java:339)}}
            {{ at com.fasterxml.jackson.databind.JsonMappingException.wrapWithPath(JsonMappingException.java:299)}}
            {{ at com.fasterxml.jackson.databind.deser.BeanDeserializerBase.wrapAndThrow(BeanDeserializerBase.java:1511)}}
            {{ at com.fasterxml.jackson.databind.deser.BeanDeserializer.vanillaDeserialize(BeanDeserializer.java:262)}}
            {{ at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserialize(BeanDeserializer.java:125)}}
            {{ at com.fasterxml.jackson.databind.ObjectMapper._readMapAndClose(ObjectMapper.java:3789)}}
            {{ at com.fasterxml.jackson.databind.ObjectMapper.readValue(ObjectMapper.java:2779)}}
            {{ at org.kohsuke.github.Requester.parse(Requester.java:606)}}
            {{ Caused: java.io.IOException: Failed to deserialize {"url":"}}
            {{ https://api.github.com/repos/atodorov/bdcs/statuses/741f1bc8e0e45f9da96e93fea0e75ee23a385d47}}
            {{ ","id":4329239285,"state":"success","description":"Build #1 succeeded in 3.2 sec","target_url":"}}
            {{ https://composer-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/atodorov-bdcs-runtest/1/display/redirect}}
            {{ ","context":"atodorov-bdcs-runtest","created_at":"2017-11-20T10:51:50Z","updated_at":"2017-11-20T10:51:50Z","creator":{"login":"atodorov","id":1002300,"avatar_url":"https://avatars3.githubusercontent.com/u/1002300?v=4","gravatar_id":"","url":"https://api.github.com/users/atodorov","html_url":"https://github.com/atodorov","followers_url":"https://api.github.com/users/atodorov/followers","following_url":"https://api.github.com/users/atodorov/following{/other_user}","gists_url":"https://api.github.com/users/atodorov/gists{/gist_id}","starred_url":"https://api.github.com/users/atodorov/starred{/owner}{/repo}","subscriptions_url":"https://api.github.com/users/atodorov/subscriptions","organizations_url":"https://api.github.com/users/atodorov/orgs","repos_url":"https://api.github.com/users/atodorov/repos","events_url":"https://api.github.com/users/atodorov/events{/privacy}","received_events_url":"https://api.github.com/users/atodorov/received_events","type":"User","site_admin":false}}}}
            {{ at org.kohsuke.github.Requester.parse(Requester.java:608)}}
            {{ Caused: org.kohsuke.github.HttpException: Server returned HTTP response code: 201, message: 'Created' for URL: }}
            {{ https://api.github.com/repos/atodorov/bdcs/statuses/741f1bc8e0e45f9da96e93fea0e75ee23a385d47}}
            {{ at org.kohsuke.github.Requester.parse(Requester.java:622)}}
            {{ at org.kohsuke.github.Requester.parse(Requester.java:584)}}
            {{ at org.kohsuke.github.Requester._to(Requester.java:264)}}
            {{ at org.kohsuke.github.Requester.to(Requester.java:226)}}
            {{ at org.kohsuke.github.GHRepository.createCommitStatus(GHRepository.java:1000)}}
            {{ at org.jenkinsci.plugins.github.status.GitHubCommitStatusSetter.perform(GitHubCommitStatusSetter.java:160)}}
            {{ Caused: org.jenkinsci.plugins.github.common.CombineErrorHandler$ErrorHandlingException}}
            {{ at org.jenkinsci.plugins.github.common.CombineErrorHandler.handle(CombineErrorHandler.java:74)}}
            {{ at org.jenkinsci.plugins.github.status.GitHubCommitStatusSetter.perform(GitHubCommitStatusSetter.java:164)}}
            {{ at com.cloudbees.jenkins.GitHubCommitNotifier.perform(GitHubCommitNotifier.java:151)}}
            {{ at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:81)}}
            {{ at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)}}
            {{ at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:735)}}
            {{ at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:676)}}
            {{ at hudson.model.Build$BuildExecution.post2(Build.java:186)}}
            {{ at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:621)}}
            {{ at hudson.model.Run.execute(Run.java:1760)}}
            {{ at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)}}
            {{ at hudson.model.ResourceController.execute(ResourceController.java:97)}}
            {{ at hudson.model.Executor.run(Executor.java:405)}}
            {{ Build step 'Set build status on GitHub commit [deprecated]' marked build as failure}}

             

             

            danbovey Dan Bovey added a comment -

            Same issue here, looks like GitHub commit status IDs have gone over a certain number that the JSON parser doesn't support.

            atodorov Alexander Todorov added a comment -

            For the record I've seen a similar exception reported against ElasticSearch and the fix supposedly was to change all ints to long!

            atodorov Alexander Todorov added a comment -

            I'm not sure if this is the same or similar issue but I have the same root error causing failures for GitHub Pull Request Builder and subsequently that Jenkins job is not able to pass git revision to downstream jobs causing them to fail.

            danbovey Dan Bovey added a comment -

            Marked as Resolved. If you update your GitHub API plugin to 1.90 it fixes the Numeric value out of range of int bug that has affected a lot of GitHub APIs.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Maciej Jagiełło
            Path:
            pom.xml
            http://jenkins-ci.org/commit/github-plugin/b7d6017f790751064692923763232c95a62dbd5a
            Log:
            JENKINS-47820 Update github-api dependency (#183)

            Updating org.jenkins-ci.plugins.github-api to the newest version should resolve an issue JENKINS-47820 about parsing large IDs from github.


              People

              Assignee:
              lanwen Kirill Merkushev
              Reporter:
              mbocek Michal Bocek
              Votes:
              3 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: