Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48551

Cannot select CIFS publish in project configuration

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Fixed

    Description

      In Jenkins configuration, I have two CIFS share

       

      When I try to configure the project, I cannot select a CIFS share, before I can.

      Attachments

        Issue Links

          Activity

            slide_o_mix Alex Earl added a comment -

            Did you upgrade something recently? You said before you can select the share, what changed in your environment if anything?

            slide_o_mix Alex Earl added a comment - Did you upgrade something recently? You said before you can select the share, what changed in your environment if anything?
            qblack Quinton Black added a comment -

            I am currently experiencing the same issue and it is indeed after an upgrade of Jenkins and several other plugins & java.

            // select.js:8 Uncaught TypeError: Cannot read property 'firstChild' of undefined
            at updateListBox (select.js:8)
            at select.js:79
            at h (hudson-behavior.js:1295)
            at refillOnChange (hudson-behavior.js:1310)
            at select.js:77
            at Array.forEach (<anonymous>)
            at behavior.js:111
            at Array.forEach (<anonymous>)
            at behavior.js:107
            at Array.forEach (<anonymous>)
            

            shows up in the console if that helps.

            qblack Quinton Black added a comment - I am currently experiencing the same issue and it is indeed after an upgrade of Jenkins and several other plugins & java. // select.js:8 Uncaught TypeError: Cannot read property 'firstChild' of undefined at updateListBox (select.js:8) at select.js:79 at h (hudson-behavior.js:1295) at refillOnChange (hudson-behavior.js:1310) at select.js:77 at Array.forEach (<anonymous>) at behavior.js:111 at Array.forEach (<anonymous>) at behavior.js:107 at Array.forEach (<anonymous>) shows up in the console if that helps.
            qblack Quinton Black added a comment -

            So for me If i uninstall the multiple scms plugin and the credentials plug in everything seems to work again. Although double check your builds have the correct CIFS as mine all changed. Could have been to a rename I did trouble shooting though.

            qblack Quinton Black added a comment - So for me If i uninstall the multiple scms plugin and the credentials plug in everything seems to work again. Although double check your builds have the correct CIFS as mine all changed. Could have been to a rename I did trouble shooting though.
            slide_o_mix Alex Earl added a comment -

            Is it both plugins required to be uninstalled, or just one of them? It would help narrow things down.

            slide_o_mix Alex Earl added a comment - Is it both plugins required to be uninstalled, or just one of them? It would help narrow things down.
            qblack Quinton Black added a comment -

            Well I reinstalled the credentials plug in and everything stopped working again which to me means its that one.

            I made a ticket before the holidays https://issues.jenkins-ci.org/browse/JENKINS-48633 that had a few more details. 

             

            qblack Quinton Black added a comment - Well I reinstalled the credentials plug in and everything stopped working again which to me means its that one. I made a ticket before the holidays https://issues.jenkins-ci.org/browse/JENKINS-48633  that had a few more details.   
            qblack Quinton Black added a comment -

            So fun piece of information that may help you mgr when I did the CIFS as a post build step it worked for me. 

            qblack Quinton Black added a comment - So fun piece of information that may help you mgr when I did the CIFS as a post build step it worked for me. 
            ruesp83 Fabio Russo added a comment -

            The function "Send file to a windows share" does not work and reading jenkins system logs, I found this exception:

             
            jenkins.plugins.publish_over.BapPublisherException: Failed to find configuration named [] check the global configuration
            at jenkins.plugins.publish_over.BPInstanceConfig.getConfiguration(BPInstanceConfig.java:106)
            at jenkins.plugins.publish_over.BPInstanceConfig.perform(BPInstanceConfig.java:136)
            at jenkins.plugins.publish_over.BPPlugin.perform(BPPlugin.java:126)
            at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:81)
            at jenkins.plugins.publish_over_cifs.CifsBuilderPlugin.perform(CifsBuilderPlugin.java:61)
            at org.jenkins_ci.plugins.run_condition.BuildStepRunner$2.run(BuildStepRunner.java:110)
            at org.jenkins_ci.plugins.run_condition.BuildStepRunner$Fail.conditionalRun(BuildStepRunner.java:154)
            at org.jenkins_ci.plugins.run_condition.BuildStepRunner.perform(BuildStepRunner.java:105)
            at org.jenkinsci.plugins.conditionalbuildstep.singlestep.SingleConditionalBuilder.perform(SingleConditionalBuilder.java:108)
            at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
            at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:744)
            at hudson.model.Build$BuildExecution.build(Build.java:206)
            at hudson.model.Build$BuildExecution.doRun(Build.java:163)
            at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
            at hudson.model.Run.execute(Run.java:1727)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:97)
            at hudson.model.Executor.run(Executor.java:429)

            ruesp83 Fabio Russo added a comment - The function "Send file to a windows share" does not work and reading jenkins system logs, I found this exception:   jenkins.plugins.publish_over.BapPublisherException: Failed to find configuration named [] check the global configuration at jenkins.plugins.publish_over.BPInstanceConfig.getConfiguration(BPInstanceConfig.java:106) at jenkins.plugins.publish_over.BPInstanceConfig.perform(BPInstanceConfig.java:136) at jenkins.plugins.publish_over.BPPlugin.perform(BPPlugin.java:126) at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:81) at jenkins.plugins.publish_over_cifs.CifsBuilderPlugin.perform(CifsBuilderPlugin.java:61) at org.jenkins_ci.plugins.run_condition.BuildStepRunner$2.run(BuildStepRunner.java:110) at org.jenkins_ci.plugins.run_condition.BuildStepRunner$Fail.conditionalRun(BuildStepRunner.java:154) at org.jenkins_ci.plugins.run_condition.BuildStepRunner.perform(BuildStepRunner.java:105) at org.jenkinsci.plugins.conditionalbuildstep.singlestep.SingleConditionalBuilder.perform(SingleConditionalBuilder.java:108) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:744) at hudson.model.Build$BuildExecution.build(Build.java:206) at hudson.model.Build$BuildExecution.doRun(Build.java:163) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504) at hudson.model.Run.execute(Run.java:1727) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:97) at hudson.model.Executor.run(Executor.java:429)

            I found that when I try to configure the plugin as a Post Step on a build the list of configured shares is blank. However, when I use Post Build Action the plugin does have the list of shares and works as expected.

            Also when using Configure Jenkins to manage shares there is an "Advanced..." button at the bottom to configure defaults. When selecting Configure defaults also has an empty list of shares.

            corneil_duplessis Corneil du Plessis added a comment - I found that when I try to configure the plugin as a Post Step on a build the list of configured shares is blank. However, when I use Post Build Action the plugin does have the list of shares and works as expected. Also when using Configure Jenkins to manage shares there is an "Advanced..." button at the bottom to configure defaults. When selecting Configure defaults also has an empty list of shares.
            kevin_waite Kevin Waite added a comment -

            I am having the same problem as those above. The share configuration list is empty, but is set up in the global config, see 2nd image at the bottom.

            Promotion does not finish with SUCCESS, no gold star, etc.

            Jenkins ver. 2.113

            Publish Over CIFS 0.9

            Drop down is wrongly empty, the plugin's checkboxes are not labeled. 

            Promotion results in this error:

            ERROR: Failed to find configuration named [] check the global configuration
            build CifsPromotionPublisherPlugin[delegate=CifsPublisherPlugin[consolePrefix=CIFS: ,delegate=BPInstanceConfig[publishers=[CifsPublisher[configName=,verbose=true,transfers=[CifsTransfer[sourceFiles=**,excludes=,removePrefix=,remoteDirectory=$JOB_NAME/$BUILD_NUMBER,remoteDirectorySDF=false,flatten=true,cleanRemote=false,noDefaultExcludes=false,makeEmptyDirs=false,patternSeparator=]],useWorkspaceInPromotion=false,usePromotionTimestamp=false,retry=CifsRetry[retries=0,retryDelay=0],label=CifsPublisherLabel[label=],credentials=<null>]],continueOnError=false,failOnError=false,masterNodeName=<null>,alwaysPublishFromMaster=false,paramPublish=CifsParamPublish[parameterName=]]]]

             

            kevin_waite Kevin Waite added a comment - I am having the same problem as those above. The share configuration list is empty, but is set up in the global config, see 2nd image at the bottom. Promotion does not finish with SUCCESS, no gold star, etc. Jenkins ver. 2.113 Publish Over CIFS   0.9 Drop down is wrongly empty, the plugin's checkboxes are not labeled.  Promotion results in this error: ERROR: Failed to find configuration named [] check the global configuration build CifsPromotionPublisherPlugin[delegate=CifsPublisherPlugin[consolePrefix=CIFS: ,delegate=BPInstanceConfig[publishers=[CifsPublisher[configName=,verbose=true,transfers=[CifsTransfer [sourceFiles=**,excludes=,removePrefix=,remoteDirectory=$JOB_NAME/$BUILD_NUMBER,remoteDirectorySDF=false,flatten=true,cleanRemote=false,noDefaultExcludes=false,makeEmptyDirs=false,patternSeparator=] ],useWorkspaceInPromotion=false,usePromotionTimestamp=false,retry=CifsRetry [retries=0,retryDelay=0] ,label=CifsPublisherLabel [label=] ,credentials=<null>]],continueOnError=false,failOnError=false,masterNodeName=<null>,alwaysPublishFromMaster=false,paramPublish=CifsParamPublish [parameterName=] ]]]  
            kevin_waite Kevin Waite added a comment -

            Note: Latest unreleased build from https://ci.jenkins.io/job/Plugins/job/publish-over-cifs-plugin/job/master/ still is exhibiting this problem.

            Publish Over CIFS
            Send build artifacts to a windows share (CIFS/SMB/samba)
            0.10-SNAPSHOT (private-7fe5315e-win2012-8a8450$) D

            JOB's config for CIFS name drop down is still blank. Still makes error during promotion. I have deleted the global CIFS config entry and re-added, I have stopped and started Jenkins. I am ready to offer any diagnostic help. Thanks in advance -Kevin Waite

             

            kevin_waite Kevin Waite added a comment - Note: Latest unreleased build from  https://ci.jenkins.io/job/Plugins/job/publish-over-cifs-plugin/job/master/  still is exhibiting this problem. Publish Over CIFS Send build artifacts to a windows share (CIFS/SMB/samba) 0.10-SNAPSHOT (private-7fe5315e-win2012-8a8450$) D JOB's config for CIFS name drop down is still blank. Still makes error during promotion. I have deleted the global CIFS config entry and re-added, I have stopped and started Jenkins. I am ready to offer any diagnostic help. Thanks in advance -Kevin Waite  
            slide_o_mix Alex Earl added a comment -

            Sadly, you may need to open the jobs that are affected and resave the configuration so that the name gets saved off correctly. The problem is that the field was not saved under some circumstances, so you need to reapply the name in the job, but going forward it should be saved correctly. Please let me know if that still doesn't work.

            slide_o_mix Alex Earl added a comment - Sadly, you may need to open the jobs that are affected and resave the configuration so that the name gets saved off correctly. The problem is that the field was not saved under some circumstances, so you need to reapply the name in the job, but going forward it should be saved correctly. Please let me know if that still doesn't work.
            kevin_waite Kevin Waite added a comment -

            Unfortunately, re-saving the jobs doesn't fix this problem, after several saves and Jenkins restart the this drop down for CIFS name remains empty. Promotion still is failing with the error listed above.

             

            kevin_waite Kevin Waite added a comment - Unfortunately, re-saving the jobs doesn't fix this problem, after several saves and Jenkins restart the this drop down for CIFS name remains empty. Promotion still is failing with the error listed above.  
            slide_o_mix Alex Earl added a comment -

            You open the job configuration, select the correct CIFS share and resave and it doesn't remain? Can you verify you have the snapshot version of the plugin installed?

            slide_o_mix Alex Earl added a comment - You open the job configuration, select the correct CIFS share and resave and it doesn't remain? Can you verify you have the snapshot version of the plugin installed?
            kevin_waite Kevin Waite added a comment - - edited

            Jenkins is reporting this snapshot for this plugin "0.10-SNAPSHOT (private-7fe5315e-win2012-8a8450$)"...

            How else / more can I provide verification? 

            The problem is that the CIFS drop down is empty, I cannot select any name to save. 

            kevin_waite Kevin Waite added a comment - - edited Jenkins is reporting this snapshot for this plugin " 0.10-SNAPSHOT (private-7fe5315e-win2012-8a8450$) "... How else / more can I provide verification?  The problem is that the CIFS drop down is empty, I cannot select any name to save. 
            klepeis Matthew Klepeis added a comment - - edited

            I am experiencing this same issue as well.  I am using Jenkins v2.89.4.  I experienced this issue earlier in the year when I upgraded Jenkins to v2.10x. I was able to get things back up and running by "downgrading" to 2.89.4.  I am now running a fresh install of 2.89.4 with the same issue.  I can see the CIFS shares selection dropdown when I add send files to a windows share build step, but if I select Send files to a windows share within a conditional step the CIFS share list is not populating.  I am using Publish Over CIFS version .9  and Conditional BuildStep 1.3.5

             

             

            UPDATE:

            the CIFS plugin is working properly in as a "Post Build" step, but is not displaying the list of available shares in the "Build" step area.

            klepeis Matthew Klepeis added a comment - - edited I am experiencing this same issue as well.  I am using Jenkins v2.89.4.  I experienced this issue earlier in the year when I upgraded Jenkins to v2.10x. I was able to get things back up and running by "downgrading" to 2.89.4.  I am now running a fresh install of 2.89.4 with the same issue.  I can see the CIFS shares selection dropdown when I add send files to a windows share build step, but if I select Send files to a windows share within a conditional step the CIFS share list is not populating.  I am using Publish Over CIFS version .9  and Conditional BuildStep 1.3.5     UPDATE: the CIFS plugin is working properly in as a "Post Build" step, but is not displaying the list of available shares in the "Build" step area.
            slide_o_mix Alex Earl added a comment -

            klepeis does the version from the ci.jenkins.io server fix this issue as well?

            slide_o_mix Alex Earl added a comment - klepeis does the version from the ci.jenkins.io server fix this issue as well?

            slide_o_mix yes this is resolved by the .10 release.  When I add a new "Send to Windows Share" element to a job now though I think the Pattern Separator is missing its default value. I added 6 new elements and 5 of them failed.  After 30 minutes I realized that property was missing, after adding it everything worked no prob.

            Thanks again for your help!

            klepeis Matthew Klepeis added a comment - slide_o_mix yes this is resolved by the .10 release.  When I add a new "Send to Windows Share" element to a job now though I think the Pattern Separator is missing its default value. I added 6 new elements and 5 of them failed.  After 30 minutes I realized that property was missing, after adding it everything worked no prob. Thanks again for your help!
            slide_o_mix Alex Earl added a comment -

            Fixed in 0.10

            slide_o_mix Alex Earl added a comment - Fixed in 0.10

            For your information, all publish-over-cifs component type JENKINS issues related to the Publish Over CIFS plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues

            Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues/74
            And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-cifs-plugin/issues?q=%22JENKINS-48551%22

            (Note: this is an automated bulk comment)

            gmcdonald Gavin McDonald added a comment - For your information, all publish-over-cifs component type JENKINS issues related to the Publish Over CIFS plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues/74 And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-cifs-plugin/issues?q=%22JENKINS-48551%22 (Note: this is an automated bulk comment)

            People

              slide_o_mix Alex Earl
              mgr Michaël Gauthier
              Votes:
              7 Vote for this issue
              Watchers:
              14 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: