Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-50681

Startup Trigger label list doesnt work with master

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • startup-trigger-plugin
    • None
    • Jenkins 2.46.2 core
      startup-trigger-plugin 2.8
      nodelabelparameter 1.7.2

    Description

      Triggers on master do not work when given a "Restricted node Label" list. All labels except master are triggered as desired, and an additional job is triggered that never runs. This extra job has the message "(pending – There are no nodes with the label '') ". I presume this is the master trigger that is causing the empty input parameter, as the job with the master input parameter is never run.

      For the included config.xml, there are ~5 nodes labeled with Windows_7. Master is labeled Windows_Server2008.
      All of the nodes with Windows_7 labels trigger fine.

      Attachments

        Activity

          ejpenney Emory Penney added a comment -

          Working on the release now, Maven hates me. Will get the release done as soon as humanly possible.

          ejpenney Emory Penney added a comment - Working on the release now, Maven hates me. Will get the release done as soon as humanly possible.
          rmills688 Ryan Mills added a comment -

          Yep, the new plugin worked as expected. Thanks!

          rmills688 Ryan Mills added a comment - Yep, the new plugin worked as expected. Thanks!
          ejpenney Emory Penney added a comment - - edited

          Haha, fair enough.  You can build it from source using the tutorial here Luckily you only care about the environment setup bits. It's basically: Install the JDK, download Maven, mangle the settings.xml and set some env variables.  Then run:

          mvn install

          Then retrieve the .hpi.  I tested a little more in my environment today, I'm fairly confident this resolves your issue, but don't want to go through the headache of a full release if it doesn't fix it.  Let me know...

          ejpenney Emory Penney added a comment - - edited Haha, fair enough.  You can build it from source using the tutorial here Luckily you only care about the environment setup bits. It's basically: Install the JDK, download Maven, mangle the settings.xml and set some env variables.  Then run: mvn install Then retrieve the .hpi.  I tested a little more in my environment today, I'm fairly confident this resolves your issue, but don't want to go through the headache of a full release if it doesn't fix it.  Let me know...
          rmills688 Ryan Mills added a comment -

          Yeah installing something from someone's Google drive isn't going to fly with my IT department. I'll have to figure out how to build

          rmills688 Ryan Mills added a comment - Yeah installing something from someone's Google drive isn't going to fly with my IT department. I'll have to figure out how to build
          ejpenney Emory Penney added a comment -

          Hmmm, probably more complicated than I want to walk through on here.  You can get a dev build of the plugin here and then you should be able to replace startup-trigger-plugin.jpi with startup-trigger-plugin.hpi (note the different suffixes, you will need to remove/replace the jpi) in your Jenkins "Plugins" directory.  Restart Jenkins and it should load the new plugin . If this works for you I'll go ahead and mark this ticket resolved and get working on a release for 2.9.

          ejpenney Emory Penney added a comment - Hmmm, probably more complicated than I want to walk through on here.  You can get a dev build of the plugin here and then you should be able to replace startup-trigger-plugin. jpi with startup-trigger-plugin. hpi (note the different suffixes, you will need to remove/replace the jpi) in your Jenkins "Plugins" directory.  Restart Jenkins and it should load the new plugin . If this works for you I'll go ahead and mark this ticket resolved and get working on a release for 2.9.
          rmills688 Ryan Mills added a comment -

          I don't have the setup to compile a plugin for test. How complex is it?

          rmills688 Ryan Mills added a comment - I don't have the setup to compile a plugin for test. How complex is it?
          ejpenney Emory Penney added a comment -

          I've pushed a change to master that fixes the issue for me in my environment, are you able to verify this fixes the issue for you?

          ejpenney Emory Penney added a comment - I've pushed a change to master that fixes the issue for me in my environment, are you able to verify this fixes the issue for you?

          People

            ejpenney Emory Penney
            rmills688 Ryan Mills
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: