Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52065

Blue Ocean not showing input step

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Minor
    • Resolution: Unresolved
    • blueocean-plugin
    • running the latest version of Jenkins and its plugins (RHEL v7.4)
      - Jenkins v2.121.1
      - BlueOcean 1.7.0 (and its dependencies)

    Description

      Hi there,

      I've built a pipeline script, which reads some property files and lets the user select some groups and items (it creates parallel stages dynamically). In order to reproduce this bug, please run the Jenkinsfile attached to this issue. You also need to copy all the txt-files to your /tmp directory.

      When executing the pipeline for the first time, select "item_grp_1" and at the next stage, check/mark all the three items, then click select. This will dynamically build parallel stages for the selected items. Now for each of the selected item, there's a input message, just click "Continue" and let the pipeline finish successfully.

      Now restart the pipeline again and select "item_grp_2" or "item_grp_3" and select only one item. Since there's only one item selected, the script does not spawn parallel stages, but the required input message is not shown. Instead the visualisation from the previous build is shown and cannot be refreshed to see the input message.

      Only when accessing the "console output" (in the classic UI) the input can answered.

      Attachments

        1. item_grp_1.txt
          0.2 kB
        2. item_grp_2.txt
          0.2 kB
        3. item_grp_3.txt
          0.2 kB
        4. item-groups.txt
          0.3 kB
        5. Jenkinsfile
          4 kB

        Activity

          jbd José Bargues added a comment -

          grzegorz_dubicki: Hi Greg, thanks for your reply. A flag: "clear-previous-build-view" (or similar) would fix this issue. It sounds very simple, but it seems not to fit in the basic design.

          jbd José Bargues added a comment - grzegorz_dubicki : Hi Greg, thanks for your reply. A flag: "clear-previous-build-view" (or similar) would fix this issue. It sounds very simple, but it seems not to fit in the basic design.
          grzegorz_dubicki Greg Dubicki added a comment -

          No, jbd, me and the whole team has learned to live with it... We just say to ourselves "remember that Jenkins web UI lies", wait until job is done, force a refresh and only then assume that what we see is the truth.

          grzegorz_dubicki Greg Dubicki added a comment - No, jbd , me and the whole team has learned to live with it... We just say to ourselves "remember that Jenkins web UI lies", wait until job is done, force a refresh and only then assume that what we see is the truth.
          jbd José Bargues added a comment -

          Just found this issue: https://issues.jenkins-ci.org/browse/JENKINS-47897

          It seems I wasn't the first one having this problem. A "clear pipeline before rerun flag" would fix this problem.

          grzegorz_dubicki: Did you solve this issue yourself (maybe by using a workaround)?

          jbd José Bargues added a comment - Just found this issue: https://issues.jenkins-ci.org/browse/JENKINS-47897 It seems I wasn't the first one having this problem. A "clear pipeline before rerun flag" would fix this problem. grzegorz_dubicki : Did you solve this issue yourself (maybe by using a workaround)?

          People

            Unassigned Unassigned
            jbd José Bargues
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated: