Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52104

Plugin always fills arguments field with "all" for build tool

    XMLWordPrintable

Details

    Description

      I use the option "build tool".

      Whenever I change and save something in my build job, the CMake plugin sets Arguments to "all".

      This is quite annoying, because I don't have any all targets in my CMake configuration, so the next build fails.

      cmake-plugin 2.5
       

      Attachments

        Activity

          saimen54 Simon M added a comment -

          Works.

           

          Thanks for the super-fast fix!

          saimen54 Simon M added a comment - Works.   Thanks for the super-fast fix!
          15knots Martin Weber added a comment -

          Please close if its working

          15knots Martin Weber added a comment - Please close if its working
          15knots Martin Weber added a comment -

          To be precise, "all" is just the default value shown in the UI if the arguments field is empty. If you empty the field and the save form, the empty value will be in effect.

          Anyway, I agree it is annoying if the arguments field is re-filled with the default value each time you open the project page again.

          15knots Martin Weber added a comment - To be precise, "all" is just the default value shown in the UI if the arguments field is empty. If you empty the field and the save form, the empty value will be in effect. Anyway, I agree it is annoying if the arguments field is re-filled with the default value each time you open the project page again.

          People

            15knots Martin Weber
            saimen54 Simon M
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: