Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53892

Unable to execute pipeline Jobs after subversion plugin update from 2.11.1 to 2.12.1

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • subversion-plugin
    • None

    Description

      All of our pipeline Jobs stopped working when upgrading the Subersion plugin from version 2.11.1 to 2.12.1,  started working again as soon as the plugin was reverted.    We use pipeline jobs defined in pipeline files stored in SVN.   The error occurs trying to read the pipeline file before the job starts. 

       

      Started by an SCM changeStarted by an SCM changeorg.tmatesoft.svn.core.SVNException: svn: E160013: '/p1/p2/!svn/p3/247025/p4/p6/trunk/p7/p8/pipelines/pipelines/App.pipeline' path not found: 404 Not Found (https://server.my.company.net) at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:70) at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:57) at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:760) at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:352) at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:920) at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.doGet(DAVConnection.java:335) at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getFile(DAVRepository.java:289) at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getFile(DAVRepository.java:251) at jenkins.scm.impl.subversion.SubversionSCMFile.content(SubversionSCMFile.java:82)Caused: java.io.IOException: failed to fetch file: pipelines/App.pipeline at jenkins.scm.impl.subversion.SubversionSCMFile.content(SubversionSCMFile.java:85) at jenkins.scm.api.SCMFile.contentAsString(SCMFile.java:338) at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:110) at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:67) at org.jenkinsci.plugins.workflow.job.WorkflowRun.run(WorkflowRun.java:303) at hudson.model.ResourceController.execute(ResourceController.java:97) at hudson.model.Executor.run(Executor.java:429)Finished: FAILURE

      Attachments

        Issue Links

          Activity

            jsolanu Jon Solanu created issue -
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-53839 [ JENKINS-53839 ]
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

            see https://issues.jenkins.io/browse/JENKINS-53839, the problem is the lightweight checkout.

            ifernandezcalvo Ivan Fernandez Calvo added a comment - see https://issues.jenkins.io/browse/JENKINS-53839 , the problem is the lightweight checkout.
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Link This issue is related to JENKINS-48420 [ JENKINS-48420 ]

            People

              ifernandezcalvo Ivan Fernandez Calvo
              jsolanu Jon Solanu
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: