Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54399

Configuration page no longer loads

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Since version 3.4 every time I click the configure system link (manage -> configure system) I get an error page.

       

       

      The error is:

       

      org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-2.138.2.jar!/jenkins/model/Jenkins/configure.jelly:51:84: <st:include> No page found 'config.jelly' for class org.jenkinsci.plugins.configfiles.GlobalConfigFiles
      	at org.kohsuke.stapler.jelly.IncludeTag.doTag(IncludeTag.java:124)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
      	at org.kohsuke.stapler.jelly.CallTagLibScript$1.run(CallTagLibScript.java:99)
      	at 
      

      Downgrading to 3.3 fixes the issue.

       

        Attachments

          Issue Links

            Activity

            davidgoate David Goate created issue -
            davidgoate David Goate made changes -
            Field Original Value New Value
            Component/s config-file-provider-plugin [ 16140 ]
            Component/s core [ 15593 ]
            davidgoate David Goate made changes -
            Environment jenkins 2.138.2 jenkins 2.138.2
            config fiel provider 3.4
            davidgoate David Goate made changes -
            Description Every time I click the configure system link I get an error page.

             

             

            The error is:

             
            {code:java}
            org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-2.138.2.jar!/jenkins/model/Jenkins/configure.jelly:51:84: <st:include> No page found 'config.jelly' for class org.jenkinsci.plugins.configfiles.GlobalConfigFiles
            at org.kohsuke.stapler.jelly.IncludeTag.doTag(IncludeTag.java:124)
            at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
            at org.kohsuke.stapler.jelly.CallTagLibScript$1.run(CallTagLibScript.java:99)
            at
            {code}
            currently I can't access any configuration page.

             

            I think today two plugins were updated but I can't find a way to list which ones.

             

             

             
            Since version 3.4 every time I click the configure system link (manage -> configure system) I get an error page.

             

             

            The error is:

             
            {code:java}
            org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-2.138.2.jar!/jenkins/model/Jenkins/configure.jelly:51:84: <st:include> No page found 'config.jelly' for class org.jenkinsci.plugins.configfiles.GlobalConfigFiles
            at org.kohsuke.stapler.jelly.IncludeTag.doTag(IncludeTag.java:124)
            at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
            at org.kohsuke.stapler.jelly.CallTagLibScript$1.run(CallTagLibScript.java:99)
            at
            {code}
            Downgrading to 3.3 fixes the issue.

             
            jtancer Jon Tancer added a comment -

            I just ran into this same issue.

            Downgrading to 3.3 fixed the problem.

            keith_ball Keith Ball added a comment -

            I just ran into the same issue as well and downgrading to 3.3. also fixed the problem for me.

            rienk_prinsen Rienk Prinsen made changes -
            Assignee Rienk Prinsen [ rienk_prinsen ]
            sorrison Sam Morrison added a comment -

            Also see this on LTS 2.138.2

            shimizuf Frank Shimizu added a comment -

            Also seeing this on Jenkins 2.149. Rollback to 3.3 fixes it.

            falcon benoit guerin added a comment -

            Fixed confirmed in 3.4.1

            ctataryn Craig Tataryn added a comment -

            Updating to Config File Provider Plugin 3.4.1 fixed this for me as well.

            shimizuf Frank Shimizu added a comment -

            Also fixed with 3.4.1 here.

            o_ozardic Onur Ozardic added a comment -

            Issue encountered in LTS 2.138.2 w/ Config File Provider Plugin 3.4 - resolved after manually installing the 3.4.1 update. 

            rienk_prinsen Rienk Prinsen made changes -
            Assignee Rienk Prinsen [ rienk_prinsen ] Dominik Bartholdi [ domi ]
            imod Dominik Bartholdi added a comment -

            solved with 3.4.1

            imod Dominik Bartholdi made changes -
            Link This issue duplicates JENKINS-54411 [ JENKINS-54411 ]
            imod Dominik Bartholdi made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            zdtsw Wen Zhou added a comment -

            confirm Jenkins ver. 2.138.2 + config-file-provider/3.4.1 works

            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              Assignee:
              domi Dominik Bartholdi
              Reporter:
              davidgoate David Goate
              Votes:
              5 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: