Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55353

Upgrade Jenkins core to 2.138.4

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      ssh-slaves-1.30.0

      Description

      After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

      • Update Jenkins file to compile an test on Jenkins core 2.150.1, 2.164.1, and 2.168 (2 LTS and last weekly)
      • Compile and test weekly with JDK 11
      • Upgrade Jenkins core to 2.150.1, I will support 2 LTS versions
      • Remove JDKInstaller references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
      • Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
      • Remove unused code
      • Remove old fields related to deprecated constructors
      • Fix tests after changes
      • Remove deprecated package dependency javax.xml.bind
      • fix Inconsistent synchronization of hudson.plugins.sshslaves.SSHLauncher.host

        Attachments

          Issue Links

            Activity

            ifernandezcalvo Ivan Fernandez Calvo created issue -
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Field Original Value New Value
            Status Open [ 1 ] In Progress [ 3 ]
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Description After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Upgrade Jenkins core to 2.121.3, I will support 3 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.121.3, 2.138.4, 2.150.1, and 2.156 (3 LTS and last weekly)
            * Upgrade Jenkins core to 2.121.3, I will support 3 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Description After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.121.3, 2.138.4, 2.150.1, and 2.156 (3 LTS and last weekly)
            * Upgrade Jenkins core to 2.121.3, I will support 3 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.121.3, 2.138.4, 2.150.1, and 2.156 (3 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.121.3, I will support 3 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Description After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.121.3, 2.138.4, 2.150.1, and 2.156 (3 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.121.3, I will support 3 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.121.3, 2.138.4, 2.150.1, and 2.156 (3 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.121.3, I will support 3 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            * Remove deprecated package depencency javax.xml.bind
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Description After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.121.3, 2.138.4, 2.150.1, and 2.156 (3 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.121.3, I will support 3 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            * Remove deprecated package depencency javax.xml.bind
            After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.138.4, 2.150.4, and 2.164 (2 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.138.4, I will support 2 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            * Remove deprecated package depencency javax.xml.bind
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Summary Upgrade Jenkins core to 2.121.3 Upgrade Jenkins core to 2.138.4
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Description After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.138.4, 2.150.4, and 2.164 (2 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.138.4, I will support 2 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            * Remove deprecated package depencency javax.xml.bind
            After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.138.4, 2.150.4, and 2.164 (2 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.138.4, I will support 2 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            * Remove deprecated package depencency javax.xml.bind
            * fix Inconsistent synchronization of hudson.plugins.sshslaves.SSHLauncher.host
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Remote Link This issue links to "PR (Web Link)" [ 22523 ]
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Description After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.138.4, 2.150.4, and 2.164 (2 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.138.4, I will support 2 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            * Remove deprecated package depencency javax.xml.bind
            * fix Inconsistent synchronization of hudson.plugins.sshslaves.SSHLauncher.host
            After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.150.1, 2.164.1, and 2.168 (2 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.150.1, I will support 2 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            * Remove deprecated package depencency javax.xml.bind
            * fix Inconsistent synchronization of hudson.plugins.sshslaves.SSHLauncher.host
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Fixed but Unreleased [ 10203 ]
            jsoref Josh Soref made changes -
            Description After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.

            * Update Jenkins file to compile an test on Jenkins core 2.150.1, 2.164.1, and 2.168 (2 LTS and last weekly)
            * Compile and test weekly with JDK 11
            * Upgrade Jenkins core to 2.150.1, I will support 2 LTS versions
            * Remove JDKInstaler references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
            * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
            * Remove unused code
            * Remove old fields related to deprecated constructors
            * Fix tests after changes
            * Remove deprecated package depencency javax.xml.bind
            * fix Inconsistent synchronization of hudson.plugins.sshslaves.SSHLauncher.host
            After tested the plugin to compile against different Jenkins core versions, I have detected some changes that I have to make to test it.
             * Update Jenkins file to compile an test on Jenkins core 2.150.1, 2.164.1, and 2.168 (2 LTS and last weekly)
             * Compile and test weekly with JDK 11
             * Upgrade Jenkins core to 2.150.1, I will support 2 LTS versions
             * Remove JDKInstaller references, is not used in ssh-slaves and it is no longer in Jenkins core, it is in tool-jdk plugin
             * Remove deprecated constructors, all these constructors were marked with a warning in logs 6 months ago.
             * Remove unused code
             * Remove old fields related to deprecated constructors
             * Fix tests after changes
             * Remove deprecated package dependency javax.xml.bind
             * fix Inconsistent synchronization of hudson.plugins.sshslaves.SSHLauncher.host
            ifernandezcalvo Ivan Fernandez Calvo made changes -
            Released As ssh-slaves-1.30.0
            Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]

              People

              Assignee:
              ifernandezcalvo Ivan Fernandez Calvo
              Reporter:
              ifernandezcalvo Ivan Fernandez Calvo
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: