Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55633

Failing with Azure Stack

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Moved from github.

      charliejllewellyn:

      Hi I am trying to use this with Azure Stack. It is failing with:Hi I am trying to use this with Azure Stack. It is failing with:

       

      Failed to validate storage account details. Please verify storage account name and key. If you are using a private or other Windows Azure cloud service, make sure that the blob endpoint url is correct.Storage Account name -->jenkinsupload<--Blob end point url --->https://jenkinsupload.blob.local.azurestack.external/<---ERROR: Step ‘Upload artifacts to Microsoft Azure Storage’ aborted due to exception: java.io.IOException: Plugin can not continue, until previous errors are addressed at com.microsoftopentechnologies.windowsazurestorage.WAStoragePublisher.perform(WAStoragePublisher.java:403) at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:78) at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:32) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720) at hudson.model.Build$BuildExecution.post2(Build.java:186) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665) at hudson.model.Run.execute(Run.java:1753) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:405)
      

      This could be for many reasons, SSL verification (although I have added the root cert to the java keystore), incorrect API versions, or incorrect resource provided in the token request. 
      How can I enable debug logging and where should I look to troubleshoot this please.

       

      juniwang:

      Unfortunately we haven't tested the plugin in Azure Stack nor exposed the underlying exception. Might be better to verbose the underlying exception for debuging in next release.

      For now, it's really hard to find the root cause. But at my first sight, your blob endpoint Url https://jenkinsupload.blob.local.azurestack.external/ is beyond our expect. See https://github.com/jenkinsci/windows-azure-storage-plugin/blob/dev/src/main/java/com/microsoftopentechnologies/windowsazurestorage/helper/AzureUtils.java#L199. We tried to parse the endpoint suffix by finding substring `core` in the url. That means in your case, you didn't even try to connect to your AzureStack.

      If it's possible, could you please try to build and debug the plugin on your side? Sure we can do some fixes about logs/endpoints but it's hard for us to validate it since we don't have a AzureStack instance.

       

        Attachments

          Activity

          jieshe Jie Shen created issue -
          jieshe Jie Shen made changes -
          Field Original Value New Value
          Description Moved from github.

          Hi I am trying to use this with Azure Stack. It is failing with:Hi I am trying to use this with Azure Stack. It is failing with:
          ```Failed to validate storage account details. Please verify storage account name and key. If you are using a private or other Windows Azure cloud service, make sure that the blob endpoint url is correct.Storage Account name --->jenkinsupload<----Blob end point url --->https://jenkinsupload.blob.local.azurestack.external/&lt;----ERROR: Step ‘Upload artifacts to Microsoft Azure Storage’ aborted due to exception: java.io.IOException: Plugin can not continue, until previous errors are addressed at com.microsoftopentechnologies.windowsazurestorage.WAStoragePublisher.perform(WAStoragePublisher.java:403) at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:78) at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:32) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720) at hudson.model.Build$BuildExecution.post2(Build.java:186) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665) at hudson.model.Run.execute(Run.java:1753) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:405)```
          This could be for many reasons, SSL verification (although I have added the root cert to the java keystore), incorrect API versions, or incorrect resource provided in the token request. 
          How can I enable debug logging and where should I look to troubleshoot this please.
          Moved from github.

          charliejllewellyn:

          Hi I am trying to use this with Azure Stack. It is failing with:Hi I am trying to use this with Azure Stack. It is failing with:

           
          {code:java}
          Failed to validate storage account details. Please verify storage account name and key. If you are using a private or other Windows Azure cloud service, make sure that the blob endpoint url is correct.Storage Account name -->jenkinsupload<--Blob end point url --->https://jenkinsupload.blob.local.azurestack.external/&lt;---ERROR: Step ‘Upload artifacts to Microsoft Azure Storage’ aborted due to exception: java.io.IOException: Plugin can not continue, until previous errors are addressed at com.microsoftopentechnologies.windowsazurestorage.WAStoragePublisher.perform(WAStoragePublisher.java:403) at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:78) at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:32) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720) at hudson.model.Build$BuildExecution.post2(Build.java:186) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665) at hudson.model.Run.execute(Run.java:1753) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:405)
          {code}

           This could be for many reasons, SSL verification (although I have added the root cert to the java keystore), incorrect API versions, or incorrect resource provided in the token request. 
           How can I enable debug logging and where should I look to troubleshoot this please.

           

          juniwang:

          Unfortunately we haven't tested the plugin in Azure Stack nor exposed the underlying exception. Might be better to verbose the underlying exception for debuging in next release.

          For now, it's really hard to find the root cause. But at my first sight, your blob endpoint Url https://jenkinsupload.blob.local.azurestack.external/ is beyond our expect. See https://github.com/jenkinsci/windows-azure-storage-plugin/blob/dev/src/main/java/com/microsoftopentechnologies/windowsazurestorage/helper/AzureUtils.java#L199. We tried to parse the endpoint suffix by finding substring `core` in the url. That means in your case, you didn't even try to connect to your AzureStack.

          If it's possible, could you please try to build and debug the plugin on your side? Sure we can do some fixes about logs/endpoints but it's hard for us to validate it since we don't have a AzureStack instance.

           
          jieshe Jie Shen added a comment -

          Low priority, back log.

          timja Tim Jacomb added a comment -

          All issues have been transferred to GitHub.

          See https://github.com/jenkinsci/azure-vm-agents-plugin/issues

          Search the issue title to find it.

          (This is a bulk comment and can't link to the specific issue)

          timja Tim Jacomb made changes -
          Resolution Duplicate [ 3 ]
          Status Open [ 1 ] Closed [ 6 ]
          ircbot Jenkins IRC Bot made changes -
          Component/s _unsorted [ 19622 ]
          Component/s windows-azure-storage-plugin [ 17466 ]

            People

            Assignee:
            jieshe Jie Shen
            Reporter:
            jieshe Jie Shen
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: