Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-557

Support aggregator plugins!

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      You're not going to like this!

      Support for maven2 aggregator plugins.

      e.g.

      root
      + pom.xml
      + child1
      + pom.xml
      + child2
      + pom.xml
      + subproj
      + pom.xml
      + child3
      + pom.xml
      + child4
      + pom.xml

      If root/pom.xml includes a plugin that attaches an aggregator goal to a phase,
      the aggregator may not function as intended:

      • maven2 projects effectively invoke each module as mvn -N
      • thus each module is built independently of the others
      • thus each module does not have the context of the other builds
      • this is why to get the separate modules to use the other modules that have
        just been build, hudson requires mvn install and not mvn package. with mvn
        package, the build artifacts should be retained in the maven context and used in
        preference to the repository. Because each module is in it's own context, we
        require mvn install.
      • thus the aggregator plugin running in pom.xml will not see any of the
        artifacts from the child projects.

      The only way I see around this at the moment is to fall back to the standard
      freestyle project.

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Issue #532 is related to this, in the sense that the m2 support needs to provide
          different modes of execution. I guess one of them must be to build everything in
          one go.

          kohsuke Kohsuke Kawaguchi added a comment -

          Implemented in 1.133, and made as the default mode for the native maven2 projects.

          For compatibility reasons projects created before 1.133 will continue to be
          built like it has been before. This setting can be changed by clicking the
          "advanced..." button.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            stephenconnolly Stephen Connolly
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: