Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56750

Micro Focus Application Automation Tools - Build log incorrect for multiple test instances of the same test.

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Cannot Reproduce

    Description

      I'm having a reporting issue with the Jenkins plug-in for QC. I opened a bug in the Jira for their plug-in but no one has looked at it. Can you assist and discuss with Micro Focus if needed? I downgraded to 5.6.2 from 5.7 because of another issue "length cannot be zero". I've attached the build log that has the error. I have a test case in a test set 9 times. The point is that I need to run the test on 9 PCs. The error in the build log shows the 9th PC repeatedly and it should show 1,2,3,4..9. See attached files.

      To clarify, the Jenkins job is running three Test Sets. Each Test Set has one test to run on 9 PCs. The build log should show 27 test instances consisting of 3 (1-9) tests. The report should have 3 test instances of (1), (2), (3), .... (9). Instead, there are 27 instances of (9).

      Attachments

        1. build.log
          31 kB
        2. BuildStep.png
          BuildStep.png
          14 kB
        3. image-2019-09-17-10-11-01-078.png
          image-2019-09-17-10-11-01-078.png
          11 kB
        4. RunResults.png
          RunResults.png
          33 kB
        5. RunTestOnHostName.pptx
          195 kB
        6. Tests about to run.png
          Tests about to run.png
          20 kB

        Activity

          Can you also provide me the properties file? Thanks.

          aslaakso Anda Sorina Laakso added a comment - Can you also provide me the properties file? Thanks.

          As you can see on the attach image for me the host name is not missing, Did you remember to add itin the "advanced" section?

          aslaakso Anda Sorina Laakso added a comment - As you can see on the attach image for me the host name is not missing, Did you remember to add itin the "advanced" section?

          As you can see in the attached image for the me the host name is present when selecting run on planed host option. Did you specify the host name in the "Advanced " section of the job configuration?

          Thanks.

          aslaakso Anda Sorina Laakso added a comment - As you can see in the attached image for the me the host name is present when selecting run on planed host option. Did you specify the host name in the "Advanced " section of the job configuration? Thanks.
          jimsears Jim Sears added a comment -

          Hi aslaakso

          Before I close this ticket, may I ask two things from you?

          1) Repeat your exercise but add the same test "GUITest100" so that you have three instances, [1][2][3]. And set the "Another Host" to be Host1, Host2, Host3.

          When you look at the results, the test report should say what test ran on which PC. Your example is reversed because you use the same host.

          2) You asked if I populated the HostName but if I did, that would be inefficient. One Jenkins job runs 10 tests, each test on a different PC. If I set the HostName in the Jenkins job then I would have to set it to one PC. That means I would need 10 jobs, 1 for each PC to run one test.

          Please see attached PPT.

           

          jimsears Jim Sears added a comment - Hi aslaakso Before I close this ticket, may I ask two things from you? 1) Repeat your exercise but add the same test "GUITest100" so that you have three instances,  [1] ,  [2] ,  [3] . And set the "Another Host" to be Host1, Host2, Host3. When you look at the results, the test report should say what test ran on which PC. Your example is reversed because you use the same host. 2) You asked if I populated the HostName but if I did, that would be inefficient. One Jenkins job runs 10 tests, each test on a different PC. If I set the HostName in the Jenkins job then I would have to set it to one PC. That means I would need 10 jobs, 1 for each PC to run one test. Please see attached PPT.  
          hildaboth Hilda added a comment - - edited

          Hello,

          I have tried to reproduce this issue, but it is working as expected for me with the latest plugin version.

          Are you facing the issue with the latest version of our plugin?

          I am going to Close this case, but feel free to reopen it anytime, and we can discuss further steps.

          Thank you,

          Hilda Both

          hildaboth Hilda added a comment - - edited Hello, I have tried to reproduce this issue, but it is working as expected for me with the latest plugin version. Are you facing the issue with the latest version of our plugin? I am going to Close this case, but feel free to reopen it anytime, and we can discuss further steps. Thank you, Hilda Both

          People

            aslaakso Anda Sorina Laakso
            jimsears Jim Sears
            Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: