Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56788

VM without disk space aren't remove from the available pool

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: _unsorted
    • Labels:
      None
    • Similar Issues:

      Description


      This affect at least azure-vm-plugin version 0.9.0

        Attachments

          Activity

          jieshe Jie Shen added a comment -

          hi Olivier Vernin, this issue does not exist in previous versions or you just encounter it at the first time? How can help you with this case?

          olblak Olivier Vernin added a comment -

          I don't think so as far I remember I started seeing this one or two weeks ago.
          So basically what happened:
          A job request a node from the pool, start running and immediately receive a no space left issue, job fails and the node return to the available pool like here.
          As the node return to the available pool, this issue is hit as long as the job is assigned the same node.
          As a workaround, I have to manually flag the need as unavailable.
          As you can see on the screenshot, it seems like jenkins doesn't detect that the wrong node (third on the picture), doesn't detect disk space.

          jieshe Jie Shen added a comment -

          So it is better this plugin could detect the no disk space issue and mark the computer as unavailable, right?

          olblak Olivier Vernin added a comment -

          As you can see on the screenshot, they are cases where it detect the free space.
          I wondering if this issue could be related tothe idle retention strategy.

          jieshe Jie Shen added a comment -

          Olivier Vernin I have made a PR (https://github.com/jenkinsci/azure-vm-agents-plugin/pull/142) for this issue. But I am now afraid it is not the right way to fix this. Jenkins itself can detect the free disk space of agents and decide whether to mark them as offline just as discussion from  stackoverflow . I am just curious why the free disk space is N/A in your case.

           

          A similar issue is JENKINS-51591 .

          olblak Olivier Vernin added a comment -

          You are right, normally Jenkins detects disk space issue and we can configured disk space issue treshold, so the problem was probably coming from jenkins itself and not this plugin, anyway I don't have the issue anymore with the latest stable version.
          So feel free to mark this ticket as cannot be reproduced


            People

            Assignee:
            jieshe Jie Shen
            Reporter:
            olblak Olivier Vernin
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: