Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57779

Bitbucket plugin JSONObject["username"] not found

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hi! Just faced with the issue with Bitbucket cloud webhooks. At webhook status page I see error 500 and in Jenkins logs I see:

      WARNING o.e.j.s.h.ContextHandler$Context#log: Error while serving https://jenkins.my.domain/bitbucket-hook/
      net.sf.json.JSONException: JSONObject["username"] not found.

      After quick investigation I recognized that Bitbucket depricate and remove username field from the api request. More details here:

      https://developer.atlassian.com/cloud/bitbucket/bitbucket-api-changes-gdpr/?_ga=2.164415676.2088283489.1559219877-1322535506.1557927444

       

       

        Attachments

          Issue Links

            Activity

            vasili439 Vasily Yanov created issue -
            satgna sat gna added a comment -

            I'm facing the same problem.

            foosome Fauzan added a comment -

            same problem since yesterday

            am using Bitbucket Plugin version 1.1.8

            marionantes Mario Nantes added a comment -

            I have the same problem, do you have any outline solution?

             

            jumpyjester John James added a comment -

            Hi we are having the same problem that has affected a number of our Jenkins installs we are running behind nginx proxy with the error 
            net.sf.json.JSONException: JSONObject["username"] not found.

            My workaround that I am currently trying to do is to hardcode a username in the plugin source and rebuild the plugin just so we can get builds working again

            eugene_riabchuk eugene riabchuk added a comment -

            The same problem occurred in our organization 

            balaaa01 bala k added a comment -

            Same problem in our installation as well.

            balaaa01 bala k made changes -
            Field Original Value New Value
            Rank Ranked higher
            ibotpeaches Connor Tumbleson added a comment -

            Took awhile to find this report. All webhooks now broken from Bitbucket due to this. 

            zaverden Denis Zavershinskiy added a comment -

            Same for me. 

            There is a pull request to fix the issue https://github.com/jenkinsci/bitbucket-plugin/pull/64

            zaverden Denis Zavershinskiy added a comment -

            PR is merged, issue is resolved in 1.1.9

            JENKINS-57787

            vasili439 Vasily Yanov added a comment -

            Looks like the issue is solved. Thank you for quick turnaround!

            vasili439 Vasily Yanov made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
            vasili439 Vasily Yanov made changes -
            Released As https://github.com/jenkinsci/bitbucket-plugin/releases/tag/bitbucket-1.1.9
            Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]
            foosome Fauzan added a comment -

            Thanks Deniis!!

            rodrigc Craig Rodrigues made changes -
            Link This issue relates to JENKINS-56987 [ JENKINS-56987 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              vasili439 Vasily Yanov
              Votes:
              5 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: