Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58849

Logstash plugin: requires insecure "mask-passwords"

    XMLWordPrintable

Details

    Description

      The mask-passwords plugin contains CVE-2019-10370 for which there is no released fix; however, the Logstash plugin depends on this plugin:

       

      https://github.com/jenkinsci/logstash-plugin/blob/master/pom.xml#L162

      Attachments

        Activity

          thcipriani Tyler Cipriani created issue -
          jbochenski Jakub Bochenski made changes -
          Field Original Value New Value
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]
          thcipriani Tyler Cipriani made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Closed [ 6 ] Reopened [ 4 ]

          People

            jbochenski Jakub Bochenski
            thcipriani Tyler Cipriani
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: