Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59901

UFT Tests from ALM. Run on Planned Host.

    XMLWordPrintable

Details

    Description

      Plugin updated from 5.7 to 5.9

      Any Job we start, Console Output shows "Node Not Found" and Planned Host to Run On is not discovered.
      Running as SYSTEM
      Building remotely on SRVQLTYC01 (ALM) in workspace c:\Jenkinsdev\workspace\UFT-Autorizaciones
      [WS-CLEANUP] Deleting project workspace...
      [WS-CLEANUP] Deferred wipeout is used...
      [WS-CLEANUP] Done
      No emails were triggered.
      [UFT-Autorizaciones] $ c:\Jenkinsdev\workspace\UFT-Autorizaciones\HpToolsLauncher.exe -paramfile props23102019150056211.txt
      "Started..."
      Timeout is set to: -1
      Run mode is set to: RUN_PLANNED_HOST
      Unable to retrieve test set folder: Node not found.
      ============================================================================
      Starting test set execution
      Test set name: BLUA_Analitica, Test set id: 501
      Test 1: [1]LOPD will run on host:
      Test 2: [1]Preguntas Frecuentes will run on host:
      Test 3: [1]Solicitud will run on host:
      Problem while running TestSet: Excepci¢n de HRESULT: 0x80040459
      "Scheduler started at:23/10/2019 15:01:01
      -------------------------------------------------------------------------------------------------------Excepci¢n no controlada: System.ArgumentNullException: El valor no puede ser nulo.
      Nombre del par metro: Current test set is null.
      en HpToolsLauncher.AlmTestSetsRunner.SetTestResults(ITSTest currentTest, IExecutionStatus executionStatus, ITestSet targetTestSet, TestRunResults activeTestDesc, TestSuiteRunResults runDesc, String testPath, String abortFilename)
      en HpToolsLauncher.AlmTestSetsRunner.RunTestSet(String tsFolderName, String tsName, String testParameters, Double timeout, QcRunMode runMode, String runHost, Boolean isFilterSelected, String filterByName, List`1 filterByStatuses, TestStorageType testStorageType)
      en HpToolsLauncher.AlmTestSetsRunner.Run()
      en HpToolsLauncher.Launcher.Run()
      en HpToolsLauncher.Program.Main(String[] args)
      Recording test results
      None of the test reports contained any result
      RunResultRecorder: didn't find any test results to record
      Email was triggered for: Always
      Sending email for trigger: Always
      Request made to compress build log
      Sending email to: cert.calidad@sanitas.es
      Finished: SUCCESS

      However, if we specify "HOST" in Job Configuration, the job can be executed.

      This didn't happen in 5.7 version.

       

       

      Attachments

        Activity

          jpabloruiz Juan Pablo Ruiz-Moyano Gomez created issue -
          narcisamgalan Maria Narcisa Galan made changes -
          Field Original Value New Value
          Assignee Maria Narcisa Galan [ narcisamgalan ] Anda Sorina Laakso [ aslaakso ]
          narcisamgalan Maria Narcisa Galan made changes -
          Labels UFT
          mihaicampean Mihai made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]

          People

            aslaakso Anda Sorina Laakso
            jpabloruiz Juan Pablo Ruiz-Moyano Gomez
            Votes:
            3 Vote for this issue
            Watchers:
            9 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: