Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60995

Triggered builds section not displaying intermittently since upgrading to blue ocean 1.17

    XMLWordPrintable

Details

    • Bug
    • Status: In Review (View Workflow)
    • Major
    • Resolution: Unresolved
    • blueocean-plugin
    • None
    • Jenkins 2.176.2.3
      Blue ocean 1.17.0
      Groovy pipeline

    Description

      I have encountered an issue that severely limits the usability of the BlueOcean plugin when used with downstream jobs.

       

      When triggering a downstream job BlueOcean normally displays the following section with a link to the downstream job, as introduced in JENKINS-38339

      However, after upgrading to BlueOcean 1.17 this behaviour seems to have regressed:

      There are a lot of comments on the original ticket JENKINS-38339 listing the same issue.

      I am aware that this was once an issue for declarative pipelines and fixed as part of https://github.com/jenkinsci/blueocean-plugin/pull/1918/files

      But I am running legacy groovy pipeline.

       

      It is important to note that this does not always happen: sometimes a run will show the link, then when the exact same run is re-ran again it fails to show.

      I have found this issue with both sequential and parallel pipelines where jobs are kicked off.

      Attachments

        Issue Links

          Activity

            People

              vlatombe Vincent Latombe
              ryanstewart456 Ryan Stewart
              Votes:
              22 Vote for this issue
              Watchers:
              24 Start watching this issue

              Dates

                Created:
                Updated: