Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61279

Update version number dependency to 1.7

    XMLWordPrintable

Details

    • Jenkins 2.224

    Attachments

      Issue Links

        Activity

          timja Tim Jacomb added a comment -

          It's more that it's annoying and wastes time for the plugin developer whose IDE is complaining about all these deprecation warnings after bumping the minimum required core version, and has to go investigate them, it's a waste of time IMO.

          timja Tim Jacomb added a comment - It's more that it's annoying and wastes time for the plugin developer whose IDE is complaining about all these deprecation warnings after bumping the minimum required core version, and has to go investigate them, it's a waste of time IMO.

          timja, thanks. Though since this only affects plugin build and not its executions and (as I understood) it does not even prevent the static analysis to detect problems, I still lean towards not to add this.

          olivergondza Oliver Gondža added a comment - timja , thanks. Though since this only affects plugin build and not its executions and (as I understood) it does not even prevent the static analysis to detect problems, I still lean towards not to add this.
          timja Tim Jacomb added a comment -

          This is for CheckNonNull, Nullable etc, without this change when you increase your minimum core version you pick up a version of spotbugs that has deprecated the annotations that don't violate the javax license.

          When we increased the configuration-as-code baseline to ~2.220 we got 50+ deprecation warnings due to this,
          this one line lib bump fixes it for plugins without any workaround on the plugin side having to mess around excluding core dependencies

          timja Tim Jacomb added a comment - This is for CheckNonNull, Nullable etc, without this change when you increase your minimum core version you pick up a version of spotbugs that has deprecated the annotations that don't violate the javax license. When we increased the configuration-as-code baseline to ~2.220 we got 50+ deprecation warnings due to this, this one line lib bump fixes it for plugins without any workaround on the plugin side having to mess around excluding core dependencies

          timja, how does the deprecation manifests? It is a build warning for plugins depending on affected core version?

          olivergondza Oliver Gondža added a comment - timja , how does the deprecation manifests? It is a build warning for plugins depending on affected core version?
          danielbeck Daniel Beck added a comment -

          timjaIf you label an issue lts-candidate, you should make sure its issue type doesn't disqualify it from backporting: https://issues.jenkins-ci.org/issues/?filter=12146

          danielbeck Daniel Beck added a comment - timja If you label an issue lts-candidate, you should make sure its issue type doesn't disqualify it from backporting: https://issues.jenkins-ci.org/issues/?filter=12146

          People

            Unassigned Unassigned
            timja Tim Jacomb
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: