Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61415

Polling baselines cannot be easily removed from Pipelines once added

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      workflow-job 2.37

      Description

      Once a Pipeline has a polling baseline added to it for a given SCM (shared library, main repo, etc), that baseline cannot be removed directly, and the job will always be built when the SCM is updated.

      The only way to remove the baseline is to disable polling for the SCM, build the job, and then restart Jenkins after the build completes. Once that is done, the polling baseline will no longer be present for that SCM and the job will not be built when the SCM is updated.

      It should be possible to remove the polling baseline without needing to restart Jenkins.

      There are probably some related issues that should be closed as a duplicate of this issue.

        Attachments

          Issue Links

            Activity

            dnusbaum Devin Nusbaum created issue -
            dnusbaum Devin Nusbaum made changes -
            Field Original Value New Value
            Labels pipeline
            dnusbaum Devin Nusbaum made changes -
            Remote Link This issue links to "jenkinsci/workflow-job-plugin#152 (Web Link)" [ 24713 ]
            dnusbaum Devin Nusbaum made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            dnusbaum Devin Nusbaum made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            dnusbaum Devin Nusbaum added a comment -

            A fix for this issue was released in Pipeline: Job Plugin version 2.37. See the changelog for details.

            dnusbaum Devin Nusbaum made changes -
            Released As workflow-job 2.37
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]

              People

              Assignee:
              ataylor Alex Taylor
              Reporter:
              dnusbaum Devin Nusbaum
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: