Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61910

htmlpublisher makes Freestyle job FAILURE, not UNSTABLE when action fails due to missing report and skips rest of reports

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Won't Fix
    • htmlpublisher-plugin
    • None
    • Jenkins 2.222 (latest LTS)
      HTML Publisher plugin 1.22 (latest)

    Description

      When I have option " Allow missing report" false and no report is found, the job is set to result FAILURE. Also the rest of the reports are skipped.

      Also, I think the convention of post-build actions is to make the job UNSTABLE when it fails unless it's a misconfiguration. I guess you could argue that this can indeed be a misconfiguration.

      https://github.com/jenkinsci/htmlpublisher-plugin/blob/master/src/main/java/htmlpublisher/HtmlPublisher.java#L232 https://github.com/jenkinsci/htmlpublisher-plugin/blob/master/src/main/java/htmlpublisher/HtmlPublisher.java#L229

      Attachments

        Activity

          As suggested will close this issue as, although whether it should be unstable or failed is debateable, at least a fix for JENKINS-61911 will make it less of an issue.

          r2b2_nz Richard Bywater added a comment - As suggested will close this issue as, although whether it should be unstable or failed is debateable, at least a fix for JENKINS-61911 will make it less of an issue.
          marcus_phi Marcus Philip added a comment -

          It is a minor issue, so I think you can close this. Especially if you fix the skipping part in the other issue I opened.

          marcus_phi Marcus Philip added a comment - It is a minor issue, so I think you can close this. Especially if you fix the skipping part in the other issue I opened.

          Thanks for the report and apologies for the delay in responding. With all that's going on in the world it's taking a while to get to things

          It's a tricky one as I think you could view it both ways as you say as it could be a misconfiguration but it could also be by design. I'd probably be loathed to change it outright but perhaps being able to set whether you want publisher errors to cause the build to be UNSTABLE or FAILED would do the trick (with the default being FAILED as per today).

          I can't promise to look at making a change in any particular timeframe but if you are so inclined then PRs are always welcome.

          r2b2_nz Richard Bywater added a comment - Thanks for the report and apologies for the delay in responding. With all that's going on in the world it's taking a while to get to things It's a tricky one as I think you could view it both ways as you say as it could be a misconfiguration but it could also be by design. I'd probably be loathed to change it outright but perhaps being able to set whether you want publisher errors to cause the build to be UNSTABLE or FAILED would do the trick (with the default being FAILED as per today). I can't promise to look at making a change in any particular timeframe but if you are so inclined then PRs are always welcome.

          People

            r2b2_nz Richard Bywater
            marcus_phi Marcus Philip
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: