Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62163

'Available' plugin manager tab keeps showing "Plugin list is loading..." in IE11

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      Jenkins 2.236

      Description

      Hi,

      I have upgraded to Jenkins 2.235 and trying to fetch the available plugins.

      I can check my proxy is working fine as well I have clicked check now.Even after several minutes the available section is still showing as "Plugin list is loading..."

       

      Could you please help me to resolve as it is blocking whole activity.

       

        Attachments

          Issue Links

            Activity

            souravmajumder Sourav Majumder created issue -
            souravmajumder Sourav Majumder made changes -
            Field Original Value New Value
            Attachment Plugin list loading 30 minutes.JPG [ 51143 ]
            danielbeck Daniel Beck added a comment -

            Are there Javascript errors in your browser's error console?

            danielbeck Daniel Beck made changes -
            Component/s core [ 15593 ]
            Component/s _unsorted [ 19622 ]
            danielbeck Daniel Beck made changes -
            Labels regression
            souravmajumder Sourav Majumder added a comment -

            I am using IE11 and unfortunately there is no Javascript errors.

            markewaite Mark Waite made changes -
            Attachment Annotation 2020-05-06 145320.png [ 51149 ]
            markewaite Mark Waite made changes -
            Attachment screenshot-1.png [ 51150 ]
            markewaite Mark Waite added a comment -

            I can confirm the issue with IE 11 and Jenkins 2.235.

            I can open the "Manage Plugins" page in Internet Explorer 11, download plugin updates, restart Jenkins, and view installed plugins. When I try to view available plugins, it sits with "plugin list is loading".

            The Available plugins page works well with Microsoft Edge, but fails if I open the page with Internet Explorer 11. In Edge, it looks like this:

            danielbeck Daniel Beck added a comment -

            Time to stop using IE11 then.

            danielbeck Daniel Beck made changes -
            Assignee Daniel Beck [ danielbeck ]
            danielbeck Daniel Beck made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            markewaite Mark Waite made changes -
            Environment Linux Jenkins 2.235 with Internet Explorer 11
            Linux
            markewaite Mark Waite made changes -
            Description Hi,

            I have upgraded to Jenkins 2.235 and trying to fetch the available plugins.

            I can check my proxy is working fine as well I have clicked check now.Even after several minutes the available section is still showing as "Plugin list is loading..."

             

            Could you please help me to resolve as it is blocking whole activity.

             
            Hi,

            I have upgraded to Jenkins 2.235 and trying to fetch the available plugins.

             !Plugin list loading.JPG|thumbnail!

            I can check my proxy is working fine as well I have clicked check now.Even after several minutes the available section is still showing as "Plugin list is loading..."

              !Plugin list loading 30 minutes.JPG|thumbnail!

            Could you please help me to resolve as it is blocking whole activity.

             
            danielbeck Daniel Beck made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            danielbeck Daniel Beck made changes -
            Remote Link This issue links to "PR 4713 (Web Link)" [ 24899 ]
            danielbeck Daniel Beck made changes -
            Labels regression lts-candidate regression
            danielbeck Daniel Beck made changes -
            Priority Blocker [ 1 ] Major [ 3 ]
            danielbeck Daniel Beck made changes -
            Summary Jenkins 2.235||Available plugin keeps loading as "Plugin list is loading..." Available plugin keeps showing "Plugin list is loading..." in IE11
            danielbeck Daniel Beck made changes -
            Summary Available plugin keeps showing "Plugin list is loading..." in IE11 'Available' plugin manager tab keeps showing "Plugin list is loading..." in IE11
            souravmajumder Sourav Majumder added a comment -

            Hi Daniel,

            I can understand that but the problem is sometime edge/chrome/Firefox may not be available to use to comply with company policy.

            So in that case can we resolve it.

             

            markewaite Mark Waite made changes -
            Released As Jenkins 2.236
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            olivergondza Oliver Gondža made changes -
            Labels lts-candidate regression 2.235.1-fixed regression
            oleg_nenashev Oleg Nenashev made changes -
            Labels 2.235.1-fixed regression 2.235.1-fixed plugin-manager regression ui

              People

              Assignee:
              danielbeck Daniel Beck
              Reporter:
              souravmajumder Sourav Majumder
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: