Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63043

Upgrade dependencies to Python 3

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      At the moment the plugin documentation and code appear to use Python 2, which is end-of-life since the beginning of this year, and even considered a security issue unless the site/company is working closely with a company that supports it.

      We should look at upgrading our current documentation (and Docker image?) to Python 3. This requires testing to confirm Zeppelin and the rest of the plug-in works too with Python 3 (it should, I don't remember testing Python 2 with the plug-in).

        Attachments

          Activity

          Hide
          loghijiaha Loghi Perinpanayagam added a comment -
          Show
          loghijiaha Loghi Perinpanayagam added a comment - Refer to the link for more information. https://github.com/jenkinsci/machine-learning-plugin/blob/master/CHANGELOG.md
          Hide
          kinow Bruno P. Kinoshita added a comment -

          Sorry for the brevity in the description of the issue Loghi Perinpanayagam. Will try to include more information in the next ones.

          Show
          kinow Bruno P. Kinoshita added a comment - Sorry for the brevity in the description of the issue Loghi Perinpanayagam . Will try to include more information in the next ones.

            People

            Assignee:
            loghijiaha Loghi Perinpanayagam
            Reporter:
            kinow Bruno P. Kinoshita
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: