Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63313

WS agent can't connect to with jdk11, works with jdk8

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: remoting
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      Trying to make a websocket agent connection to the master fails with

      $ java -jar agent.jar -jnlpUrl https://j4.beeroclock.net/computer/s1-is.beeroclock.net/slave-agent.jnlp -secret @jenkins.locm3.secret-file -workDir /var/opt/jenkins-agent
      Aug 05, 2020 8:58:29 PM org.jenkinsci.remoting.engine.WorkDirManager initializeWorkDir
      INFO: Using /var/opt/jenkins-agent/remoting as a remoting work directory
      Aug 05, 2020 8:58:29 PM org.jenkinsci.remoting.engine.WorkDirManager setupLogging
      INFO: Both error and output logs will be printed to /var/opt/jenkins-agent/remoting
      Aug 05, 2020 8:58:33 PM hudson.remoting.jnlp.Main createEngine
      INFO: Setting up agent: s1-is.beeroclock.net
      Aug 05, 2020 8:58:33 PM hudson.remoting.jnlp.Main$CuiListener <init>
      INFO: Jenkins agent is running in headless mode.
      Aug 05, 2020 8:58:33 PM hudson.remoting.Engine startEngine
      INFO: Using Remoting version: 4.3
      Aug 05, 2020 8:58:33 PM org.jenkinsci.remoting.engine.WorkDirManager initializeWorkDir
      INFO: Using /var/opt/jenkins-agent/remoting as a remoting work directory
      Aug 05, 2020 8:59:06 PM hudson.remoting.jnlp.Main$CuiListener error
      SEVERE: Handshake response not received.
      io.jenkins.remoting.shaded.javax.websocket.DeploymentException: Handshake response not received.
      	at io.jenkins.remoting.shaded.org.glassfish.tyrus.client.ClientManager$3$1.run(ClientManager.java:694)
      	at io.jenkins.remoting.shaded.org.glassfish.tyrus.client.ClientManager$3.run(ClientManager.java:712)
      	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
      	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
      	at io.jenkins.remoting.shaded.org.glassfish.tyrus.client.ClientManager$SameThreadExecutorService.execute(ClientManager.java:866)
      	at java.base/java.util.concurrent.AbstractExecutorService.submit(AbstractExecutorService.java:118)
      	at io.jenkins.remoting.shaded.org.glassfish.tyrus.client.ClientManager.connectToServer(ClientManager.java:511)
      	at io.jenkins.remoting.shaded.org.glassfish.tyrus.client.ClientManager.connectToServer(ClientManager.java:355)
      	at hudson.remoting.Engine.runWebSocket(Engine.java:627)
      	at hudson.remoting.Engine.run(Engine.java:469) 

       

      With the help of "halkeye" on IRC, we tested a newer remoting agent.jar (4.5) which also failed.

      "halkeye" could connect happily as an agent to my master though, so we confirmed that the nginx configuration of my master was ok.

      I could not connect to their master though, with either remoting 4.3 (from my master) or 4.5 (from theirs), confirming again that the master was not at fault here.

      Finally, I downgraded my agent from jdk11 to jdk8, and it instantly started working.

      This is a perfectly acceptable workaround to me, but (obviously) something that should get fixed

       

        Attachments

          Issue Links

            Activity

            jthompson Jeff Thompson added a comment -

            This is a duplicate of JENKINS-61212 and a known limitation of Java 11 support.

            Some day this should get fixed, but as Jesse explains on the other issue, this is not a high priority.


              People

              Assignee:
              jthompson Jeff Thompson
              Reporter:
              karlp Karl P
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: