Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63629

Resolve artifacts from Artifactory - Repo options not loading after save

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: artifactory-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.235.5
      Artifactory Plugin 3.8.1
    • Similar Issues:

      Description

      For Freestyle or Maven projects when you enable Resolve artifacts from Artifactory you can select or specify the repos you would like to use.

      Save and build would work

      But when you configure your job AGAIN - the repositories are set to blank. So when you save/apply the build will error out.

      You have to always specify a repository every time you configure

        Attachments

          Activity

          Hide
          cebero cebero NA added a comment - - edited

          It seems that above snapshot plugin breaks again when upgrading jenkins to 2.249.2 LTS. The very same does-not-save-AF-configuration happens again with it. Works fine with previous 2.235.4 LTS

          Edit: installed snapshot of our prod plugins + snapshot of AF plugin to clean jenksins installation env and it didn't break there. Settings were saved correctly. So it seems this issue depends of some other configs/things as well.

          Show
          cebero cebero NA added a comment - - edited It seems that above snapshot plugin breaks again when upgrading jenkins to 2.249.2 LTS. The very same does-not-save-AF-configuration happens again with it. Works fine with previous 2.235.4 LTS Edit: installed snapshot of our prod plugins + snapshot of AF plugin to clean jenksins installation env and it didn't break there. Settings were saved correctly. So it seems this issue depends of some other configs/things as well.
          Hide
          yahaviz Yahav Itzhak added a comment -

          JM Del Rosario cebero NA Vijay Mummigatti Adarsh KN
          Jenkins Artifactory plugin 3.9.0 is released. This version includes a fix for this issue. Feel free to upgrade!
          We'd appreciate your feedback for that.

          Show
          yahaviz Yahav Itzhak added a comment - JM Del Rosario cebero NA Vijay Mummigatti Adarsh KN Jenkins Artifactory plugin 3.9.0 is released. This version includes a fix for this issue. Feel free to upgrade! We'd appreciate your feedback for that.
          Hide
          adarsh_kn Adarsh KN added a comment -

          Thank you Yahav Itzhak for the update. I just updated the plugin and check to be working as expected. thanks again for the fix.

          Show
          adarsh_kn Adarsh KN added a comment - Thank you Yahav Itzhak for the update. I just updated the plugin and check to be working as expected. thanks again for the fix.
          Hide
          vijaym Vijay Mummigatti added a comment -

          Thankyou very much Yahav Itzhak for this update. Plugin is working as expected.

          Show
          vijaym Vijay Mummigatti added a comment - Thankyou very much  Yahav Itzhak for this update. Plugin is working as expected.
          Hide
          mattdelros JM Del Rosario added a comment -

          Yahav Itzhak yes I can also confirm that the fix packaged with the latest release fixes the issue. THANKS!

          Show
          mattdelros JM Del Rosario added a comment - Yahav Itzhak yes I can also confirm that the fix packaged with the latest release fixes the issue. THANKS!

            People

            Assignee:
            yahaviz Yahav Itzhak
            Reporter:
            mattdelros JM Del Rosario
            Votes:
            4 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated: