Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63798

The extensions footer and the other parts not together

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      OS: macOS
      browser: chrome
      JDK: 8
      Jenkins: 2.257
    • Similar Issues:
    • Released As:
      Jenkins 2.262

      Description

      It's a regression from JENKINS-61496. Before the changes, they are together, but they are separate now.

        Attachments

          Activity

          yjuns Shi YanJun created issue -
          yjuns Shi YanJun made changes -
          Field Original Value New Value
          Assignee Shi YanJun [ yjuns ]
          yjuns Shi YanJun made changes -
          Assignee Shi YanJun [ yjuns ]
          danielbeck Daniel Beck made changes -
          oleg_nenashev Oleg Nenashev added a comment -
          egutierrez Evaristo Gutierrez made changes -
          Assignee Shi YanJun [ yjuns ]
          egutierrez Evaristo Gutierrez made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          egutierrez Evaristo Gutierrez added a comment -
          egutierrez Evaristo Gutierrez made changes -
          Status In Progress [ 3 ] In Review [ 10005 ]
          oleg_nenashev Oleg Nenashev made changes -
          Labels lts-candidate
          timja Tim Jacomb made changes -
          Attachment screenshot-1.png [ 52944 ]
          timja Tim Jacomb added a comment -

          This might have caused the below javascript code to start showing up in my Jenkins in the footer:

          "(function() { var amContainer = document.getElementById("visible-am-container"); var amInsertion = document.getElementById("visible-am-insertion"); if (amInsertion)

          { amInsertion.appendChild(amContainer); }

          })();"

          nothing in the console

          timja Tim Jacomb made changes -
          Attachment screenshot-2.png [ 52945 ]
          timja Tim Jacomb added a comment - - edited

          Caused by moving the include footer.jelly into the div on the PR for this issue, may not have shown in development as this issue would only be triggered when admin monitors were being displayed

          timja Tim Jacomb added a comment -

          Regression showing JS when admin monitor triggered fixed in https://github.com/jenkinsci/jenkins/pull/5001

          oleg_nenashev Oleg Nenashev made changes -
          Released As Jenkins 2.262
          Resolution Fixed [ 1 ]
          Status In Review [ 10005 ] Resolved [ 5 ]
          markewaite Mark Waite made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          olivergondza Oliver Gondža made changes -
          Labels lts-candidate 2.249.3-fixed

            People

            Assignee:
            yjuns Shi YanJun
            Reporter:
            yjuns Shi YanJun
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: