Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64644

IllegalArgumentException with git plugin 4.5.0 + JCasC

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I'm unable to update git-plugin to >=4.5.0, when Jenkins starts up it throws java.lang
      .IllegalArgumentException: No jenkins.scm.api.SCMSource implementation found for git (see the full attached stacktrace). I'm using JCasC, though I'm not sure if it's relevant in this context. I've also attached the plugins.yaml; the only relevant part of the jenkins.yaml file pertaining to the git plugin is as such:

      gitSCM:
         createAccountBasedOnEmail: false
        showEntireCommitSummaryInChanges: false
         useExistingAccountWithSameEmail: false

      I'm not sure why this is occurring, does anyone have an idea?

        Attachments

          Activity

          nre_ableton Nik Reiman created issue -
          nre_ableton Nik Reiman made changes -
          Field Original Value New Value
          Description I'm unable to update git-plugin to >=4.5.0, when Jenkins starts up it throws {{java.lang
          .IllegalArgumentException: No jenkins.scm.api.SCMSource implementation found for git}} (see the full attached stacktrace). I'm using JCasC, though I'm not sure if it's relevant in this context. I've also attached the {{plugins.yaml}}; the only relevant part of the {{jenkins.yaml}} file pertaining to the git plugin is as such:

          {{
            gitSCM:
              createAccountBasedOnEmail: false
              showEntireCommitSummaryInChanges: false
              useExistingAccountWithSameEmail: false
          }}

          I'm not sure why this is occurring, does anyone have an idea?
          I'm unable to update git-plugin to >=4.5.0, when Jenkins starts up it throws java.lang
           .IllegalArgumentException: No jenkins.scm.api.SCMSource implementation found for git (see the full attached stacktrace). I'm using JCasC, though I'm not sure if it's relevant in this context. I've also attached the {{plugins.yaml}}; the only relevant part of the {{jenkins.yaml}} file pertaining to the git plugin is as such:

          gitSCM:
             createAccountBasedOnEmail: false
            showEntireCommitSummaryInChanges: false
             useExistingAccountWithSameEmail: false

          I'm not sure why this is occurring, does anyone have an idea?
          markewaite Mark Waite added a comment - - edited

          That's a very strange error message, since the git plugin has an implementation of jenkins.scm.api.SCMSource in GitSCMSource.java that extends AbstractGitSCMSource that extends jenkins.scm.api.SCMSource.

          I have those same configuration lines in my jenkins.yaml file and am loading git plugin 4.5.2 without any issue on both Java 8 and Java 11.

          I updated my jenkins.yaml to only include those lines and confirmed that it still starts and runs with git plugin 4.5.2. You are welcome to compare the plugin versions I'm running in that Docker image definition with the plugin versions you're using.

          Nik Reiman can you duplicate the problem on other computers with the same definition? Are you willing to share the complete jenkins.yaml file (with sensitive information removed)?

          markewaite Mark Waite made changes -
          Assignee Mark Waite [ markewaite ]
          markewaite Mark Waite added a comment -

          Nik Reiman any further information?

          nre_ableton Nik Reiman added a comment -

          Mark Waite Sorry, I haven't had time to investigate yet, but I'll try to do that this week and report back.

          nre_ableton Nik Reiman added a comment -

          Ok, this is quite bizarre, but I can no longer reproduce this behavior. I think that a combination of updating other plugins and updating JCasC itself to 1.47 fixed it.

          Sorry for the noise! At least there is nothing sinister going on under the surface here.

          nre_ableton Nik Reiman made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            nre_ableton Nik Reiman
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: