Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64709

java.io.IOException: Could not open channel (state:4)

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I am trying to connect a RHEL 7 system running java 8 as a node on a RHEL 7 Jenkins server. running the same version of Java. Below is the error message that I am getting. BTW I can connect a RHEL 6 system fine

      java.io.IOException: Could not open channel (state:4)
       at com.trilead.ssh2.channel.ChannelManager.ioException(ChannelManager.java:1542)
       at com.trilead.ssh2.channel.ChannelManager.waitUntilChannelOpen(ChannelManager.java:124)
       at com.trilead.ssh2.channel.ChannelManager.openSessionChannel(ChannelManager.java:576)
       at com.trilead.ssh2.Session.<init>(Session.java:42)
       at com.trilead.ssh2.Connection.openSession(Connection.java:1082)
       at com.trilead.ssh2.Connection.exec(Connection.java:1473)
       at hudson.plugins.sshslaves.SSHLauncher.verifyNoHeaderJunk(SSHLauncher.java:583)
       at hudson.plugins.sshslaves.SSHLauncher.access$100(SSHLauncher.java:113)
       at hudson.plugins.sshslaves.SSHLauncher$1.call(SSHLauncher.java:438)
       at hudson.plugins.sshslaves.SSHLauncher$1.call(SSHLauncher.java:423)
       at java.util.concurrent.FutureTask.run(FutureTask.java:266)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
       at java.lang.Thread.run(Thread.java:748)
      Caused by: java.io.IOException: The connection is being shutdown
       at com.trilead.ssh2.channel.ChannelManager.handleEndMessage(ChannelManager.java:1524)
       at com.trilead.ssh2.transport.TransportManager$1.run(TransportManager.java:535) ... 1 more
      Caused by: java.net.SocketException: Connection reset
       at java.net.SocketInputStream.read(SocketInputStream.java:210)
       at java.net.SocketInputStream.read(SocketInputStream.java:141)
       at com.trilead.ssh2.crypto.cipher.CipherInputStream.fill_buffer(CipherInputStream.java:41)
       at com.trilead.ssh2.crypto.cipher.CipherInputStream.internal_read(CipherInputStream.java:52)
       at com.trilead.ssh2.crypto.cipher.CipherInputStream.getBlock(CipherInputStream.java:79)
       at com.trilead.ssh2.crypto.cipher.CipherInputStream.read(CipherInputStream.java:108)
       at com.trilead.ssh2.transport.TransportConnection.receiveMessage(TransportConnection.java:232)
       at com.trilead.ssh2.transport.TransportManager.receiveLoop(TransportManager.java:706)
       at com.trilead.ssh2.transport.TransportManager$1.run(TransportManager.java:502) ... 1 more [01/25/21 13:15:09] Launch failed - cleaning up connection [01/25/21 13:15:09] [SSH] Connection closed. 

        Attachments

          Activity

          aragland8 Andrew Ragland created issue -
          danielbeck Daniel Beck made changes -
          Field Original Value New Value
          Description I am trying to connect a RHEL 7 system running java 8 as a node on a RHEL 7 Jenkins server. running the same version of Java. Below is the error message that I am getting. BTW I can connect a RHEL 6 system fine

          java.io.IOException: Could not open channel (state:4) at com.trilead.ssh2.channel.ChannelManager.ioException(ChannelManager.java:1542) at com.trilead.ssh2.channel.ChannelManager.waitUntilChannelOpen(ChannelManager.java:124) at com.trilead.ssh2.channel.ChannelManager.openSessionChannel(ChannelManager.java:576) at com.trilead.ssh2.Session.<init>(Session.java:42) at com.trilead.ssh2.Connection.openSession(Connection.java:1082) at com.trilead.ssh2.Connection.exec(Connection.java:1473) at hudson.plugins.sshslaves.SSHLauncher.verifyNoHeaderJunk(SSHLauncher.java:583) at hudson.plugins.sshslaves.SSHLauncher.access$100(SSHLauncher.java:113) at hudson.plugins.sshslaves.SSHLauncher$1.call(SSHLauncher.java:438) at hudson.plugins.sshslaves.SSHLauncher$1.call(SSHLauncher.java:423) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748) Caused by: java.io.IOException: The connection is being shutdown at com.trilead.ssh2.channel.ChannelManager.handleEndMessage(ChannelManager.java:1524) at com.trilead.ssh2.transport.TransportManager$1.run(TransportManager.java:535) ... 1 more Caused by: java.net.SocketException: Connection reset at java.net.SocketInputStream.read(SocketInputStream.java:210) at java.net.SocketInputStream.read(SocketInputStream.java:141) at com.trilead.ssh2.crypto.cipher.CipherInputStream.fill_buffer(CipherInputStream.java:41) at com.trilead.ssh2.crypto.cipher.CipherInputStream.internal_read(CipherInputStream.java:52) at com.trilead.ssh2.crypto.cipher.CipherInputStream.getBlock(CipherInputStream.java:79) at com.trilead.ssh2.crypto.cipher.CipherInputStream.read(CipherInputStream.java:108) at com.trilead.ssh2.transport.TransportConnection.receiveMessage(TransportConnection.java:232) at com.trilead.ssh2.transport.TransportManager.receiveLoop(TransportManager.java:706) at com.trilead.ssh2.transport.TransportManager$1.run(TransportManager.java:502) ... 1 more [01/25/21 13:15:09] Launch failed - cleaning up connection [01/25/21 13:15:09] [SSH] Connection closed.
          I am trying to connect a RHEL 7 system running java 8 as a node on a RHEL 7 Jenkins server. running the same version of Java. Below is the error message that I am getting. BTW I can connect a RHEL 6 system fine
          {noformat}
          java.io.IOException: Could not open channel (state:4)
           at com.trilead.ssh2.channel.ChannelManager.ioException(ChannelManager.java:1542)
           at com.trilead.ssh2.channel.ChannelManager.waitUntilChannelOpen(ChannelManager.java:124)
           at com.trilead.ssh2.channel.ChannelManager.openSessionChannel(ChannelManager.java:576)
           at com.trilead.ssh2.Session.<init>(Session.java:42)
           at com.trilead.ssh2.Connection.openSession(Connection.java:1082)
           at com.trilead.ssh2.Connection.exec(Connection.java:1473)
           at hudson.plugins.sshslaves.SSHLauncher.verifyNoHeaderJunk(SSHLauncher.java:583)
           at hudson.plugins.sshslaves.SSHLauncher.access$100(SSHLauncher.java:113)
           at hudson.plugins.sshslaves.SSHLauncher$1.call(SSHLauncher.java:438)
           at hudson.plugins.sshslaves.SSHLauncher$1.call(SSHLauncher.java:423)
           at java.util.concurrent.FutureTask.run(FutureTask.java:266)
           at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
           at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
           at java.lang.Thread.run(Thread.java:748)
          Caused by: java.io.IOException: The connection is being shutdown
           at com.trilead.ssh2.channel.ChannelManager.handleEndMessage(ChannelManager.java:1524)
           at com.trilead.ssh2.transport.TransportManager$1.run(TransportManager.java:535) ... 1 more
          Caused by: java.net.SocketException: Connection reset
           at java.net.SocketInputStream.read(SocketInputStream.java:210)
           at java.net.SocketInputStream.read(SocketInputStream.java:141)
           at com.trilead.ssh2.crypto.cipher.CipherInputStream.fill_buffer(CipherInputStream.java:41)
           at com.trilead.ssh2.crypto.cipher.CipherInputStream.internal_read(CipherInputStream.java:52)
           at com.trilead.ssh2.crypto.cipher.CipherInputStream.getBlock(CipherInputStream.java:79)
           at com.trilead.ssh2.crypto.cipher.CipherInputStream.read(CipherInputStream.java:108)
           at com.trilead.ssh2.transport.TransportConnection.receiveMessage(TransportConnection.java:232)
           at com.trilead.ssh2.transport.TransportManager.receiveLoop(TransportManager.java:706)
           at com.trilead.ssh2.transport.TransportManager$1.run(TransportManager.java:502) ... 1 more [01/25/21 13:15:09] Launch failed - cleaning up connection [01/25/21 13:15:09] [SSH] Connection closed. {noformat}
          oleg_nenashev Oleg Nenashev made changes -
          Component/s ssh-slaves-plugin [ 15578 ]
          Component/s trilead-api-plugin [ 22324 ]
          Component/s core [ 15593 ]
          aragland8 Andrew Ragland added a comment -

          I was able to resolve this issue. The issue was caused by FIPS being on. This is one of our stig (hardening) requirements. When FIPS was on, the keys were being created in PKCS#8 format. With that said, PKCS#8 format is not supported by Jenkins. In order to fix this we has to turn off FIPS and then regenerate the keys so they would create in PKCS#1 format. 

          aragland8 Andrew Ragland made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Fixed but Unreleased [ 10203 ]

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            aragland8 Andrew Ragland
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: