Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65298

Allow dependency versions to be taken from the plugin BOM

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      From a discussion with Jesse Glick in JENKINS-59148:

      Make it possible to use @dependabot to get push notifications for newer versions of any plugin in the list. (Or, make it possible to reuse the BOM, which already uses Dependabot and runs plugin-compat-tester against the entire set to ensure a basic level of mutual compatibility.)

      Even though JENKINS-59148 was resolved as "Fixed", this gap still remains. In my opinion it would be desirable to implement this suggestion to improve the user experience when using Plugin Installation Manager Tool. As I wrote in the comments to that bug:

      I would much rather take the version from the BOM (which has been tested with PCT) rather than the latest version.

        Attachments

          Issue Links

            Activity

            There are no comments yet on this issue.

              People

              Assignee:
              stopalopa Natasha Stopa
              Reporter:
              basil Basil Crow
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated: