Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65611

Jobs fail to to run in Jenkins 2.292

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Fixed
    • core
    • Jenkins 2.292
    • Jenkins 2.293

    Description

      After upgrading to Jenkins 2.292 all my jobs started to fail with:

      java.lang.UnsupportedOperationException: remove
      	at java.base/java.util.Iterator.remove(Iterator.java:102)
      	at com.cloudbees.plugins.credentials.CredentialsProvider.trackAll(CredentialsProvider.java:1636)
      	at com.cloudbees.plugins.credentials.CredentialsProvider.track(CredentialsProvider.java:1583)
      	at jenkins.plugins.git.GitSCMFileSystem$BuilderImpl.build(GitSCMFileSystem.java:329)
      	at jenkins.scm.api.SCMFileSystem.of(SCMFileSystem.java:197)
      	at jenkins.scm.api.SCMFileSystem.of(SCMFileSystem.java:173)
      	at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:114)
      	at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:68)
      	at org.jenkinsci.plugins.workflow.job.WorkflowRun.run(WorkflowRun.java:309)
      	at hudson.model.ResourceController.execute(ResourceController.java:100)
      	at hudson.model.Executor.run(Executor.java:433)
      Finished: FAILURE 

      After downgrading to 2.291 the jobs started to work again normally.

      Attachments

        Issue Links

          Activity

            smelchior Seb M created issue -

            Running into the same issue but I can't paste the full stacktrace because we are using templating-engine-plugin that seems to wrap it (see https://github.com/jenkinsci/templating-engine-plugin/issues/212)

            Rollback to 2.291 fixed the issue too

            opa Vincent Letarouilly added a comment - Running into the same issue but I can't paste the full stacktrace because we are using templating-engine-plugin that seems to wrap it (see https://github.com/jenkinsci/templating-engine-plugin/issues/212 ) Rollback to 2.291 fixed the issue too
            saper Marcin Cieślak added a comment - Could this be caused by https://github.com/jenkinsci/jenkins/pull/5464 ?
            bbara BeBa added a comment - - edited

            Duplicate: JENKINS-65620

            The implementation of iterator() has been changed in the PR mentioned by saper.

            The new implementation does not enable the remove() method.

            bbara BeBa added a comment - - edited Duplicate: JENKINS-65620 The implementation of iterator() has been changed in the PR mentioned by saper . The new implementation does not enable the remove() method.
            raihaan Raihaan Shouhell made changes -
            Field Original Value New Value
            Assignee Raihaan Shouhell [ raihaan ]
            raihaan Raihaan Shouhell made changes -
            Remote Link This issue links to "PR-5486 (Web Link)" [ 26731 ]
            raihaan Raihaan Shouhell made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            raihaan Raihaan Shouhell made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            raihaan Raihaan Shouhell made changes -
            Link This issue is blocked by JENKINS-65620 [ JENKINS-65620 ]
            danielbeck Daniel Beck made changes -
            Labels regression
            markewaite Mark Waite added a comment -

            See https://github.com/jenkinsci/jenkins/pull/5486 for discussion of a possible fix.

            I was unable to duplicate the problem. Can more details be provided about the job that is showing the issue so that we can confirm the proposed pull request resolves the issue?

            markewaite Mark Waite added a comment - See https://github.com/jenkinsci/jenkins/pull/5486 for discussion of a possible fix. I was unable to duplicate the problem. Can more details be provided about the job that is showing the issue so that we can confirm the proposed pull request resolves the issue?
            smelchior Seb M made changes -
            Attachment job.xml [ 54785 ]
            smelchior Seb M added a comment -

            i attached an example job.xml which fails for me, maybe this can help to reproduce the issue job.xml

            smelchior Seb M added a comment - i attached an example job.xml which fails for me, maybe this can help to reproduce the issue  job.xml
            raihaan Raihaan Shouhell made changes -
            Released As Jenkins 2.293
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            raihaan Raihaan Shouhell made changes -
            Link This issue is blocked by JENKINS-65623 [ JENKINS-65623 ]
            raihaan Raihaan Shouhell made changes -
            Link This issue is blocked by JENKINS-65623 [ JENKINS-65623 ]
            raihaan Raihaan Shouhell made changes -
            Link This issue is duplicated by JENKINS-65623 [ JENKINS-65623 ]
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

            People

              raihaan Raihaan Shouhell
              smelchior Seb M
              Votes:
              8 Vote for this issue
              Watchers:
              14 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: