Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65641

Save or Apply button does not work

    XMLWordPrintable

Details

    Description

      Hello,

      The save and apply button is not working any longer after upgrading the version to 2.288.
      When clicking at the save button it happens nothing at all and with clicking apply I get the error pop up with no content (which is very helpful to find the issue and a solution).

      It appears that with a working jenkins version a POST request with /configSubmit is getting fired if the apply button is being clicked. But I do not see such a request with the not working Version 2.288. I also tried it with different browsers and none seems to work.

      For me this is very critical because I need to reboot/relaod the jenkins every time after making some changes and those changes are only possible if I do them directly in the config file. I can't create new jobs either because I can't save them.
      The only case where the save button seems to work is when changing some userpermissions.

      Is this a bug in the software or what do I have to do to fix this?
      A quick reply would be very much appreciated.

      Attachments

        Activity

          durzo_blint Durzo created issue -
          durzo_blint Durzo made changes -
          Field Original Value New Value
          Description Hello,

          The save and apply button is not working any longer after upgrading the version to 2.288.
          When clicking at the save button it happens nothing at all and with clicking apply I get the error pop up with no content (which is very helpful to find the issue and a solution).
          !image-2021-05-14-15-24-14-066.png!
          It appears that with a working jenkins version a POST request with /configSubmit is getting fired if the apply button is being clicked. But I do not see such a request with the not working Version 2.288. I also tried it with different browsers and none seems to work.

          For me this is very critical because I need to reboot/relaod the jenkins every time after making some changes and those changes are only possible if I do them directly in the config file. The only case where the save button seems to work is when changing some userpermissions.

          Is this a bug in the software or what do I have to do to fix this?
          A quick reply would be very much appreciated.
          Hello,

          The save and apply button is not working any longer after upgrading the version to 2.288.
           When clicking at the save button it happens nothing at all and with clicking apply I get the error pop up with no content (which is very helpful to find the issue and a solution).
           !image-2021-05-14-15-24-14-066.png!
           It appears that with a working jenkins version a POST request with /configSubmit is getting fired if the apply button is being clicked. But I do not see such a request with the not working Version 2.288. I also tried it with different browsers and none seems to work.

          For me this is very critical because I need to reboot/relaod the jenkins every time after making some changes and those changes are only possible if I do them directly in the config file. I can't create new jobs either because I can't save them.
          The only case where the save button seems to work is when changing some userpermissions.

          Is this a bug in the software or what do I have to do to fix this?
           A quick reply would be very much appreciated.
          ianw Ian Williams added a comment -

          Hi, the picture is of no help whatsoever.

          However, your issue is likely a result of tables to divs migration JENKINS-64072.

          This will affect any Jenkins upgrades to 2.277.1+

          Read the upgrade guide and follow the procedures. Check the broken plugins dashboard

          It may still be a matter of trial and error if your plugin has not already been identified. Be sure to upgrade all plugins which you can first, then diagnose. There's lots of similar issues documented here.

          ianw Ian Williams added a comment - Hi, the picture is of no help whatsoever. However, your issue is likely a result of tables to divs migration JENKINS-64072 . This will affect any Jenkins upgrades to 2.277.1+ Read the upgrade guide and follow the procedures. Check the broken plugins dashboard It may still be a matter of trial and error if your plugin has not already been identified. Be sure to upgrade all plugins which you can first, then diagnose. There's lots of similar issues documented here.
          durzo_blint Durzo added a comment -

          Hello,

          The jenkins is running in a enviroment that has no access to public internet so there were some outstanding plugin updates.
          After updating them all (including all dependencies) by hand the save & apply buttons are seeming to work again.

          for me the issue is solved and I will close the ticket.

          ianw Thank you for your help!

          durzo_blint Durzo added a comment - Hello, The jenkins is running in a enviroment that has no access to public internet so there were some outstanding plugin updates. After updating them all (including all dependencies) by hand the save & apply buttons are seeming to work again. for me the issue is solved and I will close the ticket. ianw Thank you for your help!
          durzo_blint Durzo made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
          markewaite Mark Waite added a comment -

          Closing because durzo_blint stated that it was resolved by updating plugins

          markewaite Mark Waite added a comment - Closing because durzo_blint stated that it was resolved by updating plugins
          markewaite Mark Waite made changes -
          Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]

          People

            Unassigned Unassigned
            durzo_blint Durzo
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: