Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65863

NodeJS Plugin doesn't recognize CPU architecture sparcv9

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: nodejs-plugin
    • Environment:
    • Similar Issues:

      Description

      Checking the box 

      Provide Node & npm bin/ folder to PATH

      `and choosing a NodeJS installation of any 12, 14 or 16 node version will produce the following stack trace when attempting to build

      ERROR: Failed to parse POMs
      jenkins.plugins.nodejs.tools.DetectionFailedException: Error getting system properties on remote Node
      	at jenkins.plugins.nodejs.tools.CPU.of(CPU.java:71)
      	at jenkins.plugins.nodejs.tools.ToolsUtils.getCPU(ToolsUtils.java:43)
      	at jenkins.plugins.nodejs.tools.ToolsUtils.getCPU(ToolsUtils.java:39)
      	at jenkins.plugins.nodejs.tools.NodeJSInstaller$NodeJSInstallable.forNode(NodeJSInstaller.java:341)
      	at jenkins.plugins.nodejs.tools.NodeJSInstaller$NodeJSInstallable.forNode(NodeJSInstaller.java:332)
      	at jenkins.plugins.nodejs.tools.NodeJSInstaller.performInstallation(NodeJSInstaller.java:112)
      	at hudson.tools.InstallerTranslator.getToolHome(InstallerTranslator.java:69)
      	at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:109)
      	at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:206)
      	at jenkins.plugins.nodejs.tools.NodeJSInstallation.forNode(NodeJSInstallation.java:95)
      	at jenkins.plugins.nodejs.NodeJSBuildWrapper.setUp(NodeJSBuildWrapper.java:158)
      	at jenkins.tasks.SimpleBuildWrapper.setUp(SimpleBuildWrapper.java:146)
      	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:665)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
      	at hudson.model.Run.execute(Run.java:1894)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
      	at hudson.model.ResourceController.execute(ResourceController.java:97)
      	at hudson.model.Executor.run(Executor.java:428)
      Caused by: jenkins.plugins.nodejs.tools.DetectionFailedException: Unknown CPU architecture: sparcv9
      	at jenkins.plugins.nodejs.tools.CPU.detect(CPU.java:117)
      	at jenkins.plugins.nodejs.tools.CPU.of(CPU.java:69)
      

       

        Attachments

          Activity

          nfalco Nikolas Falco added a comment -

          Do you have installed any NodeJS package on that machine? If yes which one?

          nfalco Nikolas Falco added a comment -

          I will close this issue followng this NodeJS issue https://github.com/nodejs/help/issues/1614

          Here there is the table of supported platform:

          https://github.com/nodejs/node/blob/master/BUILDING.md#supported-platforms

          brt brian added a comment - - edited

          Nikolas Falco

          There's a node v12 package available on my solaris install.  Will this help?

          Name: runtime/nodejs Summary: Node.js 
          Category: Development/C (org.opensolaris.category.2008) Development/Other Languages (org.opensolaris.category.2008) State: Not installed 
          Publisher: solaris 
          Version: 12.21.0 
          Branch: 11.4.32.0.1.88.2 
          Packaging Date: Thu Mar 18 19:18:18 2021 
          Size: 2.52 kB 
          FMRI: pkg://solaris/runtime/nodejs@12.21.0-11.4.32.0.1.88.2:20210318T191818Z 
          Project URL: https://github.com/nodejs/node 
          Source URL: https://github.com/nodejs/node/archive/v12.21.0.zip
          

          It's v12 instead of v14, but it would still work for me.

          But you're right about no available binaries from nodejs.org.  I couldn't find anything either.

          nfalco Nikolas Falco added a comment -

          The problem is the CPU

          brt brian added a comment -

          Ah okay.  Thanks for looking into the issue for me


            People

            Assignee:
            nfalco Nikolas Falco
            Reporter:
            brt brian
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: