Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-66097

Jenkins doesn't save changes to previously created jobs when clicking Save/Apply buttons

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Critical
    • Resolution: Unresolved
    • Component/s: pipeline
    • Labels:
      None
    • Environment:
      Jenkins 2.277.4 running on Red Hat Enterprise Linux Server 7.9
    • Similar Issues:

      Description

      We have upgraded jenkins from version 2.263.4 to 2.277.4 recently and now we are observing issue whenever we try to save any changes in existing pipelines it is not getting save. Its intermittant in nature. whenever I click on save button I am getting page stating this page is not working(server didn't send any data). Attaching the error screenshot. 

      Also, whenever I click on save button below log line gets added into logs with warning.

      2021-07-07 14:03:22.303+0000 [id=656] WARNING o.a.h.c.p.ResponseProcessCookies#processCookies: Invalid cookie header: "Set-Cookie: AWSALB=mMHaLwRSOmSR9kXAUD8u+dh6MwTzqrHpqxG7vYFUOuzPVW3zCRqtRNiKel9697oCD0VGSOdQ3kzt+P7UBSXi7Ovw9wSurTGNY2xR9KtQgqoWUvzGAQSNs4XG2356; Expires=Wed, 14 Jul 2021 14:03:22 GMT; Path=/". Invalid 'expires' attribute: Wed, 14 Jul 2021 14:03:22 GMT

      We updated plugin Apache HttpComponents Client 4.x API Plugin as well but still facing the issue.

      Can someone help here? 

        Attachments

          Activity

          sagar_nachare Sagar created issue -
          ianw Ian Williams made changes -
          Field Original Value New Value
          Description We have upgraded jenkins from version 2.263.4 to 2.277.4 recently and now we are observing issue whenever we try to save any changes in existing pipelines it is not getting save. Its intermittant in nature. whenever I click on save button I am getting page stating this page is not working(server didn't send any data). Attaching the error screenshot.

           

          Also, whenever I click on save button below log line gets added into logs with warning.

           

          2021-07-07 14:03:22.303+0000 [id=656] WARNING o.a.h.c.p.ResponseProcessCookies#processCookies: Invalid cookie header: "Set-Cookie: AWSALB=mMHaLwRSOmSR9kXAUD8u+dh6MwTzqrHpqxG7vYFUOuzPVW3zCRqtRNiKel9697oCD0VGSOdQ3kzt+P7UBSXi7Ovw9wSurTGNY2xR9KtQgqoWUvzGAQSNs4XG2356; Expires=Wed, 14 Jul 2021 14:03:22 GMT; Path=/". Invalid 'expires' attribute: Wed, 14 Jul 2021 14:03:22 GMT

           

          We updated plugin Apache HttpComponents Client 4.x API Plugin as well but still facing the issue.

           

          Can someone help here? 
          We have upgraded jenkins from version 2.263.4 to 2.277.4 recently and now we are observing issue whenever we try to save any changes in existing pipelines it is not getting save. Its intermittant in nature. whenever I click on save button I am getting page stating this page is not working(server didn't send any data). Attaching the error screenshot. 

          Also, whenever I click on save button below log line gets added into logs with warning.

          {{2021-07-07 14:03:22.303+0000 [id=656] WARNING o.a.h.c.p.ResponseProcessCookies#processCookies: Invalid cookie header: "Set-Cookie: AWSALB=mMHaLwRSOmSR9kXAUD8u+dh6MwTzqrHpqxG7vYFUOuzPVW3zCRqtRNiKel9697oCD0VGSOdQ3kzt+P7UBSXi7Ovw9wSurTGNY2xR9KtQgqoWUvzGAQSNs4XG2356; Expires=Wed, 14 Jul 2021 14:03:22 GMT; Path=/". Invalid 'expires' attribute: Wed, 14 Jul 2021 14:03:22 GMT}}

          {{  }}
          {{ We updated plugin Apache HttpComponents Client 4.x API Plugin as well but still facing the issue.}}

          Can someone help here? 
          ianw Ian Williams made changes -
          Description We have upgraded jenkins from version 2.263.4 to 2.277.4 recently and now we are observing issue whenever we try to save any changes in existing pipelines it is not getting save. Its intermittant in nature. whenever I click on save button I am getting page stating this page is not working(server didn't send any data). Attaching the error screenshot. 

          Also, whenever I click on save button below log line gets added into logs with warning.

          {{2021-07-07 14:03:22.303+0000 [id=656] WARNING o.a.h.c.p.ResponseProcessCookies#processCookies: Invalid cookie header: "Set-Cookie: AWSALB=mMHaLwRSOmSR9kXAUD8u+dh6MwTzqrHpqxG7vYFUOuzPVW3zCRqtRNiKel9697oCD0VGSOdQ3kzt+P7UBSXi7Ovw9wSurTGNY2xR9KtQgqoWUvzGAQSNs4XG2356; Expires=Wed, 14 Jul 2021 14:03:22 GMT; Path=/". Invalid 'expires' attribute: Wed, 14 Jul 2021 14:03:22 GMT}}

          {{  }}
          {{ We updated plugin Apache HttpComponents Client 4.x API Plugin as well but still facing the issue.}}

          Can someone help here? 
          We have upgraded jenkins from version 2.263.4 to 2.277.4 recently and now we are observing issue whenever we try to save any changes in existing pipelines it is not getting save. Its intermittant in nature. whenever I click on save button I am getting page stating this page is not working(server didn't send any data). Attaching the error screenshot. 

          Also, whenever I click on save button below log line gets added into logs with warning.

          {{2021-07-07 14:03:22.303+0000 [id=656] WARNING o.a.h.c.p.ResponseProcessCookies#processCookies: Invalid cookie header: "Set-Cookie: AWSALB=mMHaLwRSOmSR9kXAUD8u+dh6MwTzqrHpqxG7vYFUOuzPVW3zCRqtRNiKel9697oCD0VGSOdQ3kzt+P7UBSXi7Ovw9wSurTGNY2xR9KtQgqoWUvzGAQSNs4XG2356; Expires=Wed, 14 Jul 2021 14:03:22 GMT; Path=/". Invalid 'expires' attribute: Wed, 14 Jul 2021 14:03:22 GMT}}

          We updated plugin Apache HttpComponents Client 4.x API Plugin as well but still facing the issue.

          Can someone help here? 

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            sagar_nachare Sagar
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: