Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67833

Java.Lang.OutMemoryError with Bitbucket Server Integration Version greater or equal 3.0.0

    XMLWordPrintable

Details

    Description

      See screenshot attached (JenkinsHeapExausted.jpg) showing that Jenkins hangs eventually causing Heap allocation crash. I am using Adoptium JRE https://adoptium.net/releases.html?variant=openjdk11

      Multibranch Job pipeline, triggered from Bitbucket Server commit, but to reproduce I just do Rebuild job. I have changed Jenkins.xml to -Xmx1024m without avail

      Issue reproducible with Plugins Bitbucket Server Integration Versions: 3.2.0, 3.1.0, 3.0.0 

      Working ok with V 2.1.3

       

      FYI ONLY: JenkinsCastClassIssue.jpg attachment reproduces JENKINS-67199.

       

      Attachments

        Activity

          helciom Helcio Mayor created issue -

          Hi Helcio, thanks for your report.

          This issue seems complex enough that it probably makes the most sense to go through our support process. Can you please raise a ticket at getsupport.atlassian.com?

          mhenschke_atlassian Martin Henschke added a comment - Hi Helcio, thanks for your report. This issue seems complex enough that it probably makes the most sense to go through our support process. Can you please raise a ticket at getsupport.atlassian.com?
          atlassian_bbs Atlassian Bitbucket Server made changes -
          Field Original Value New Value
          Labels jenkins plugin jenkins plugin triaged

          Hi Helcio, I haven't seen an update on this ticket so I'll close it for now. Please re-open if you have more information on the bug, or any updates from a support case.

          mhenschke_atlassian Martin Henschke added a comment - Hi Helcio, I haven't seen an update on this ticket so I'll close it for now. Please re-open if you have more information on the bug, or any updates from a support case.
          mhenschke_atlassian Martin Henschke made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]
          mhenschke_atlassian Martin Henschke made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Closed [ 6 ] Reopened [ 4 ]

          People

            Unassigned Unassigned
            helciom Helcio Mayor
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: