Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67928

Prevent infinite loop in case of closed SSL connection

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • remoting
    • None
    • 4.13, Jenkins 2.338

    Description

      Increased CPU load on Jenkins instance.
      The root cause of CPU load was a thread that is stuck in an infinite loop in SSLEngineFilterLayer.java
      The remote agent was already terminated by kubernetes-plugin and the SSL connection is closed, but the thread is still working because can't exit from the while loop.

      Attachments

        Activity

          basil Basil Crow added a comment -

          Fixed in jenkinsci/remoting#513 toward 4.13.

          basil Basil Crow added a comment - Fixed in jenkinsci/remoting#513 toward 4.13.

          People

            gulyaev13 Ilya Gulyaev
            timja Tim Jacomb
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: