Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7300

main/war/pom.xml uses non-standard maven directory layout

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Leftovers from the CVS days, according to Kohsuke, we have a lot of web resources which are in directories outside of src/main. As the old Japanese adage (roughly) says, "the nail that sticks out gets hammered".

      Anyway, I have some ideas for resource filtering which become overly complicated when we break rank on where maven-war-plugin expects resources to be located. By moving these resources to the Maven standard directory layout, resource filtering issues will become quite simple.

      According to Kohsuke, the images/ directory should remain in place despite it not being used within the WAR itself, so that should be left intact.

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : jieryn
          Path:
          trunk/hudson/main/war/pom.xml
          http://jenkins-ci.org/commit/34095
          Log:
          JENKINS-7300 #resolve

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : jieryn
          Path:
          trunk/hudson/main/war/pom.xml
          http://jenkins-ci.org/commit/34151
          Log:
          JENKINS-7300 #comment Andrew Bayer found a regression where our maven-hudson-dev-plugin was referencing the old ${basedir}/resources – remove the configuration option to reference the default src/main/webapp dir

          s_baramov s_baramov added a comment -

          Removing the env-vars.html breaks functionality on the job configuration page. When configuring an Ant job, the help text points to the https://hudson.dev.java.net/source/browse/*checkout*/hudson/trunk/hudson/main/war/resources/env-vars.html URL. Since the file was removed, the help content cannot be loaded.

          abayer Andrew Bayer added a comment -

          Any chance you could give a screenshot?

          abayer Andrew Bayer added a comment -

          Ah, I found it. That's some weird code. Fixing it now. =)

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : abayer
          Path:
          trunk/hudson/main/war/src/main/webapp/help/project-config/ant.html
          trunk/hudson/main/war/src/main/webapp/help/project-config/ant_ja.html
          trunk/hudson/main/war/src/main/webapp/help/project-config/maven.html
          trunk/hudson/main/war/src/main/webapp/help/project-config/maven_de.html
          trunk/hudson/main/war/src/main/webapp/help/project-config/maven_fr.html
          trunk/hudson/main/war/src/main/webapp/help/project-config/maven_ja.html
          trunk/hudson/main/war/src/main/webapp/help/project-config/maven_pt_BR.html
          trunk/hudson/main/war/src/main/webapp/help/project-config/maven_ru.html
          trunk/hudson/main/war/src/main/webapp/help/project-config/maven_tr.html
          http://jenkins-ci.org/commit/34963
          Log:
          [FIXED JENKINS-7300] Got rid of absolute paths to checkout paths at hudson.dev.java.net of env_vars.html

          dogfood dogfood added a comment -

          Integrated in hudson_main_trunk #274
          [FIXED JENKINS-7300] Got rid of absolute paths to checkout paths at hudson.dev.java.net of env_vars.html

          abayer :
          Files :

          • /trunk/hudson/main/war/src/main/webapp/help/project-config/maven_tr.html
          • /trunk/hudson/main/war/src/main/webapp/help/project-config/maven.html
          • /trunk/hudson/main/war/src/main/webapp/help/project-config/maven_fr.html
          • /trunk/hudson/main/war/src/main/webapp/help/project-config/ant_ja.html
          • /trunk/hudson/main/war/src/main/webapp/help/project-config/maven_pt_BR.html
          • /trunk/hudson/main/war/src/main/webapp/help/project-config/ant.html
          • /trunk/hudson/main/war/src/main/webapp/help/project-config/maven_ja.html
          • /trunk/hudson/main/war/src/main/webapp/help/project-config/maven_ru.html
          • /trunk/hudson/main/war/src/main/webapp/help/project-config/maven_de.html

            People

            Assignee:
            jieryn jieryn
            Reporter:
            jieryn jieryn
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: