Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7515

java slave client dies on some nodes

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Incomplete
    • other
    • None

    Description

      On some of my build slaves, the java slave runs just fine, on others it dies very shortly (within a second or two) after starting. Hudson says about it:

      Connection was broken

      java.io.IOException: Unexpected termination of the channel
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:881)
      Caused by: java.io.EOFException
      at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2570)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1314)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:368)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:875)

      The log for it says:

      Connecting to 10.8.3.81
      Verifying that java exists
      java full version "JRE 1.6.0 IBM Linux build pxa6460sr7-20091215_02 (SR7)"
      Copying slave.jar
      Launching slave agent
      <===[HUDSON REMOTING CAPACITY]===>Slave.jar version: 1.372
      This is a Unix slave
      Copied maven-agent.jar
      Copied maven-interceptor.jar
      Copied maven2.1-interceptor.jar
      I can start the slave manually and it will stay running:
      [busy icon spinning]

      It will stay running if I start it manually:

      1. ssh -i ~hudson/.euca/hudson.priv root@10.8.3.81 java -jar /tmp/slave.jar
        <===[HUDSON REMOTING CAPACITY]===>[encyrpted/encoded data removed for privacy]
        [stays running, so in another terminal:]
      2. ssh -i ~hudson/.euca/hudson.priv root@10.8.3.81 ps -ef | grep java
        root 2766 2761 3 12:53 ? 00:00:01 java -jar /tmp/slave.jar

      Any ideas how to go about figuring out why it's dying so quickly on only some of my build slaves?

      Attachments

        Issue Links

          Activity

            evernat evernat added a comment -

            No response from the reporter, so resolving as incomplete.
            As Brian has said, the slaves may have OOM.

            evernat evernat added a comment - No response from the reporter, so resolving as incomplete. As Brian has said, the slaves may have OOM.
            brianfromoregon Brian Harris added a comment -

            For us, the cause of this error was our build slaves (VMs) running out of memory and self-rebooting.

            brianfromoregon Brian Harris added a comment - For us, the cause of this error was our build slaves (VMs) running out of memory and self-rebooting.
            evernat evernat added a comment - - edited

            .

            evernat evernat added a comment - - edited .
            evernat evernat added a comment -

            any news? does upgrading to a recent version of Jenkins solves the problem?

            evernat evernat added a comment - any news? does upgrading to a recent version of Jenkins solves the problem?

            People

              Unassigned Unassigned
              brianjmurrell Brian J Murrell
              Votes:
              4 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: