Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7734

Hudson : NPEs inconsistently during maven builds

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: maven-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      From time to time, on various builds, I see this exception. Can you please look at why this might occur?

      -----------------------------------------------------------------------------
      [INFO] Building expense-bridge domain service
      [INFO] task-segment: [install]
      [INFO] ------------------------------------------------------------------------
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] null
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.NullPointerException
      at org.codehaus.plexus.component.configurator.converters.lookup.DefaultConverterLookup.findConverterForType(DefaultConverterLookup.java:115)
      at org.codehaus.plexus.component.configurator.converters.lookup.DefaultConverterLookup.lookupConverterForType(DefaultConverterLookup.java:92)
      at org.codehaus.plexus.component.configurator.converters.composite.CollectionConverter.fromConfiguration(CollectionConverter.java:175)
      at org.codehaus.plexus.component.configurator.converters.ComponentValueSetter.configure(ComponentValueSetter.java:247)
      at org.codehaus.plexus.component.configurator.converters.composite.ObjectWithFieldsConverter.processConfiguration(ObjectWithFieldsConverter.java:137)
      at org.codehaus.plexus.component.configurator.BasicComponentConfigurator.configureComponent(BasicComponentConfigurator.java:56)
      at org.codehaus.plexus.component.configurator.AbstractComponentConfigurator.configureComponent(AbstractComponentConfigurator.java:54)
      at org.codehaus.plexus.component.configurator.AbstractComponentConfigurator.configureComponent(AbstractComponentConfigurator.java:47)
      at org.codehaus.plexus.personality.plexus.lifecycle.phase.AutoConfigurePhase.execute(AutoConfigurePhase.java:39)
      at org.codehaus.plexus.lifecycle.AbstractLifecycleHandler.start(AbstractLifecycleHandler.java:101)
      at org.codehaus.plexus.component.manager.AbstractComponentManager.startComponentLifecycle(AbstractComponentManager.java:105)
      at org.codehaus.plexus.component.manager.AbstractComponentManager.createComponentInstance(AbstractComponentManager.java:95)
      at org.codehaus.plexus.component.manager.ClassicSingletonComponentManager.getComponent(ClassicSingletonComponentManager.java:92)
      at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:331)
      at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:312)
      at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:440)
      at hudson.maven.agent.ContainerFilter.lookup(ContainerFilter.java:89)
      at hudson.maven.agent.PluginManagerInterceptor$1$1.lookup(PluginManagerInterceptor.java:95)
      at org.apache.maven.plugin.DefaultPluginManager.getPluginComponent(DefaultPluginManager.java:1595)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtension(DefaultLifecycleExecutor.java:1438)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findMappingsForLifecycle(DefaultLifecycleExecutor.java:1346)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.bindLifecycleForPackaging(DefaultLifecycleExecutor.java:1292)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.constructLifecycleMappings(DefaultLifecycleExecutor.java:1275)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:534)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.lifecycle.LifecycleExecutorInterceptor.execute(LifecycleExecutorInterceptor.java:65)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at hudson.maven.agent.Main.launch(Main.java:165)
      at hudson.maven.MavenBuilder.call(MavenBuilder.java:165)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:694)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:638)
      at hudson.remoting.UserRequest.perform(UserRequest.java:114)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:270)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 4 seconds
      [INFO] Finished at: Sun Oct 10 15:55:08 PDT 2010
      [INFO] Final Memory: 7M/245M
      [INFO] ------------------------------------------------------------------------

        Attachments

          Issue Links

            Activity

            saimad saimad added a comment -

            Looks like the underlying issue is either a Maven2 or Plexis issue. Here is the link for the plexis issue : http://jira.codehaus.org/browse/PLX-413

            saimad saimad added a comment -

            Whoever is looking at this, this happens fairly regularly in our world. Can someone please respond to this thread?

            We love hudson but for a few of these random failures during the build process. we need the build process to be rock solid. Anything I can do to help move this along?

            kutzi kutzi added a comment -

            According to the Plexus issue you posted this is solely a Maven/Plexus issue.
            So what do you expect Hudson developers can do about it?

            saimad saimad added a comment -

            There are multiple options :

            (a) Hudson bundles an older version of Maven and thus, plexus. I understand that the Maven 2 architecture may have forced this decision, but it would be good to keep up with later versions of Maven
            (b) Since this exception affects Hudson users (and not when using Maven directly), there is maybe atleast a hacky way of dealing with this error and not failing the build?

            In essence, people using Hudson need a reliable operating environment and anything to help reduce random failures would be a boost.

            kutzi kutzi added a comment -

            AFAIK, Hudson uses the bundled Maven version mainly only for POm parsing. Building the projects is done via the configured Maven installation.
            I might be wrong there, but in the end both options (cause by the bundled or by the configured maven) boil to to be dependend on JENKINS-4988

            kutzi kutzi added a comment -

            Current Jenkins version now do use Maven 3 internally. Do you still experience this problem?

            kutzi kutzi added a comment -

            Please reopen, if it's still an issue


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              saimad saimad
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: