Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7877

Git publisher pushes to early

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • git-plugin
    • None
    • Windows Xp

    Description

      git publisher pushes to early.
      Whe've set git publisher to push only when build succeeds.
      The problem is that when the git publisher checks whether the status is succeeded this status can be still be changed, by test results or fxcop for instance.

      Would it be possible for the publisher to be the very last task after build.

      I've added the config and a result in the attachments to clarify.

      We're using http://ci.hudson-labs.org/job/plugins_hudson-git-plugin/28/org.jvnet.hudson.plugins$git/ .

      Attachments

        1. config.png
          config.png
          27 kB
        2. result.png
          result.png
          30 kB

        Activity

          anonymousultimo anonymousultimo created issue -
          anonymousultimo anonymousultimo made changes -
          Field Original Value New Value
          Description git publisher pushes to early.
          Whe've set git publisher to push only when build succeeds.
          The problem is that when the git publisher checks whether the status is succeeded this status can be still be changed, by test results or fxcop for instance.

          Would it be possible for the publisher to be the very last task after build.

          I've added the config and a result in the attachments to clarify.
          git publisher pushes to early.
          Whe've set git publisher to push only when build succeeds.
          The problem is that when the git publisher checks whether the status is succeeded this status can be still be changed, by test results or fxcop for instance.

          Would it be possible for the publisher to be the very last task after build.

          I've added the config and a result in the attachments to clarify.

          We're using http://ci.hudson-labs.org/job/plugins_hudson-git-plugin/28/org.jvnet.hudson.plugins$git/ .

          abayer Andrew Bayer added a comment -

          Seems reasonable - it's not 100% guaranteed, but I can set the Git publisher to run after all post-build plugins that don't specify anything in re: build ordering. I'll get that into the next release.

          abayer Andrew Bayer added a comment - Seems reasonable - it's not 100% guaranteed, but I can set the Git publisher to run after all post-build plugins that don't specify anything in re: build ordering. I'll get that into the next release.
          abayer Andrew Bayer added a comment -

          Resolved in upcoming release.

          abayer Andrew Bayer added a comment - Resolved in upcoming release.
          abayer Andrew Bayer made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          dogfood dogfood added a comment - Integrated in plugins_hudson-git-plugin #35
          markewaite Mark Waite made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 137980 ] JNJira + In-Review [ 204653 ]

          People

            abayer Andrew Bayer
            anonymousultimo anonymousultimo
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: